Add ons wurden deaktiviert

  • Deaktivierte Erweiterungen verlieren keine Einstellungen. Wenn du die Erweiterung zwischenzeitlich deinstalliert und wieder neu installiert hast, dann natürlich, dann sind deine Daten weg. Aber wer einfach nur gewartet oder manuell den Fix eingespielt hat, hat auch keinen Datenverlust.

    Doch, mit Multi-Account Containers ist es definitiv so, wohingegen meine anderen Erweiterungen deren Einstellungen behalten haben. Ich habe es dank Time Machine-Sicherungen gerade mehrmals nachstellen können (auf einem MacBook Pro unter Mojave 10.14.4).

    Gruß
    Manfred


    FF in aktueller Releaseversion, auf MacBook Pro 16" M1 2021 unter macOS Monterey

  • Zitat

    Der Build 1 war definitiv noch nicht als Release-Version gedacht, die hat noch keinen vollständigen Fix beinhaltet. Mittlerweile sind wir bei Build 3:


    Danke für die Info, mal beobachten :)

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?


  • Gerade getestet, ebenfalls Mojave 10.4.4. Container erstellt, Erweiterung deaktiviert, Erweiterung wieder aktiviert, Container war noch vorhanden.

    Das kann ich bestätigen. Beim bloßen De- und Reaktivieren der Erweiterung bleiben die Container erhalten. Nach dem gestrigen Erreignis war dem nicht so. Das war der Grund, warum ich überhaupt erst auf diesen Fehler aufmerksam geworden bin.


    EDIT: Möglicherweise liegt die Ursache darin, dass du Nightly verwendest, ich Beta.

    Gruß
    Manfred


    FF in aktueller Releaseversion, auf MacBook Pro 16" M1 2021 unter macOS Monterey

  • Hallo an alle,
    habe auch dieses Problem und die letzten 3 Stunden damit verbracht. Mein FF ist 66.03. keiner der Patches o.ä. haben bei mir einen positiven Effekt. Der sog. Patch konnte zwar gestartet werden, danach OK-Button, dann aber die Fehlermeldung, daß ein Verbindungsproblem auftritt - also nichts.
    Irgendwie kam es dann zu einem Neustart von Firefox worin alles mögliche bereinigt wurde etc.. Das Ergebnis ist, daß nun die nicht mehr funktionierenden Add-Ons ganz weg sind, Einstellungen weg sind und wenn ich meine Add-Ons wieder neu installieren will, ich die Fehlermeldung: Download fehlgeschlagen. Bitte überprüfen Sie die Verbindung..
    WAS muss jetzt geschehen, damit ich meiine Add-Ons wieder ins System bekomme? Kann mir jemand helfen?
    Grüße


  • So einfach wie du es dir machst milupo, ist es aber nicht ;)


    A) Für viele Addons gibt es nach wie vor keinerlei Ersatz


    Du hast dir wirklich die Mühe gemacht, mal auf AMO alle Webextensions durchzusehen? Mit Verlaub, aber deine Behauptung ist oft nur eine Behauptung und wird nicht dadurch wahrer, dass man sie dauernd wiederholt. Außerdem, fehlen wird immer mal wieder etwas und das tat es auch früher. Damals haben schon Add-on-Entwickler ihre Add-ons aufgegeben, weil sie keine Lust oder Zeit mehr hatten. Da musste es auch gehen. Das lag aber nicht an Mozilla.


    Zitat

    B) Anpassungen an FF werden immer komplizierter


    Das Einzige, was man bedauern kann, ist, dass Webextension die Firefox-Oberfläche nicht mehr verändern können. Dafür gibt es Benutzer-CSS mit userChrome.css und userContent.css und Benutzerskripte. Wir Forumshelfer helfen dir da gerne. Aber selbst das betrifft nur einen Bruchteil der Benutzer.


    Zitat

    C) Als Addonschreiber hätte ich auch keine Lust bei "jedem" Update alles umschreiben zu müssen nur weil FF meint, mal wieder einiges zu ändern.


    Durch Webextensions gehört das - zumindest zum größten Teil - der Geschichte an. Das traf auf Add-ons alten Typs zu. Aber auf denen beharrst du ja. Dann trage auch die Konsequenzen. Ach ja, stimmt, die alten Add-ons werden ja nicht mehr weiterentwickelt. Da bist du ja nun fein raus. Deine Aussage würde übrigens bedeuten, dass Firefox auf einer Version stehen bleibt, also nicht mehr weiterentwickelt wird. Keine Sicherheitsupdates, keine neuen Funktionen. Mozilla kann dann Firefox sich selbst überlassen und sich anderen Dingen zuwenden.


    Zitat

    Letztendlich began der Aufstieg von FF mit den Addons und der unglaublichen Wandlungsfähigkeit und Möglichkeiten die man hatte als User aber irgendwann ging die Entwicklung des Browsers in eine vollkommen "falsche" Richtung und am Ende ist man nun wieder in der Nische gelandet, wo man vor gefühlt 20 Jahren gestartet ist.


    Dazu kann ich nur eins schreiben: Unsinn. Du bist einfach zurückgeblieben. Und beharrst noch darauf.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • 1. Wer nichts bei STUDIEN umgestellt hat (also erlaubt) sollte das Update automatisch bekommen (also warten)
    2. Für FF 66.0.3 gibt es einen FIX
    3. Für FF Nightly und/oder ESR könnte man xpinstall.signatures.required auf false setzen


    Welcher Fix soll denn nun funktionieren? Die von Seite 6 ff jedenfalls nicht !

  • dehasselaar: der problembeschreibung zufolge verhindert bei dir wahrscheinlich ein sicherheitsprogramm, das an verschlüsselten https-verbindungen herumdoktert (in der regel avast/avg, kaspersky, bitdefender, eset) das erfolgreiche einspielen des hotfixes. in dem fall musst du wohl leider noch auf das update auf firefox 66.0.4 warten, das in kürze eintreffen sollte und das problem ebenfalls behebt.


  • dehasselaar: der problembeschreibung zufolge verhindert bei dir wahrscheinlich ein sicherheitsprogramm, das an verschlüsselten https-verbindungen herumdoktert (in der regel avast/avg, kaspersky, bitdefender, eset) das erfolgreiche einspielen des hotfixes. in dem fall musst du wohl leider noch auf das update auf firefox 66.0.4 warten, das in kürze eintreffen sollte und das problem ebenfalls behebt.


    Oder sich von dem Schlangenöl (insbes. Avira,Avast,KAV) trennen und nur den Defender (Windows10) nutzen. Der ist seit langem für geschätzt 90% der Nutzer völlig ausreichend und blockiert eben nicht wichtige Verbindungen. :lol:

  • Lese ich heute nicht das erste Mal. Ich würde es auf irgendwas im Profil schieben, könnte auch eine SSL-Intervention des genutzten Antivirus sein. Steht denn bei dir was unter "about:studies"

    Zitat

    hotfix-update-xpi-signing-intermediate-bug-1548973•Aktiv
    This is a hotfix that updates an intermediate certificate used for signing add-ons. It is one of the mechanisms used to fix bug 1548973.


    Zitat

    hotfix-reset-xpi-verification-timestamp-1548973•Aktiv
    Diese Studie setzt den Wert von "app.update.lastUpdateTime.xpi-signature-verification" auf "1556945257".


    Ersteres ist ja das temporäre Zertifikat, zweites ist lediglich ein Wert, den man auch selbst in about:config eintragen kann. Ich brauchte für meine v66 & v67 nur das besagte XPI installieren (keine Studie aktiviert), v68 darf Studien, daher das Zitat.


    PS Windows 10, mit Windows Defender.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?


  • 1. Wer nichts bei STUDIEN umgestellt hat (also erlaubt) sollte das Update automatisch bekommen (also warten)
    2. Für FF 66.0.3 gibt es einen FIX
    3. Für FF Nightly und/oder ESR könnte man xpinstall.signatures.required auf false setzen


    Welcher Fix soll denn nun funktionieren? Die von Seite 6 ff jedenfalls nicht !


    Doch, der von Zitronella funktioniert.
    Lade ihn herunter und packe ihn in einen Ordner.
    [attachment=0]Zwischenablage03.jpg[/attachment]
    Dann manuell installieren über :
    [attachment=1]Zwischenablage02.jpg[/attachment]

  • Hallo Leute


    Ich hab den Rechner seit gestern Morgen an. Firefox hat den Hhot-Fix bis jetzt nicht runtergeladen. Dachte mir machste jetzt über den Link von Zitronella. Sicherheitsabfrage mit Ja bestätigt und schon ploppt die nächste meldung auf . das addon konnte wegen eines verbindungsproblem nicht runtergeaden werden .. Und Nu ?? hat jemand ne idee. proxy steht auf system einstellungen verwenden.


    gruß marco

  • Dann pfuscht vielleicht dein Antivirenprogramm dazwischen? Welches verwendest du?

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • Das wird seit eben als hotfix via System-Add-on ausgerollt. Also wer nicht abwarten kann, bis es automatisch passiert, einfach diesen Link anklicken --> https://storage.googleapis.com…illa.com-1.0.2-signed.xpi und installieren.


    Eine Frage dazu: Sobald Mozilla eine Aktualisierung von FF angeboten hat, belässt man die Erweiterung (Fix), oder sollte sie besser deinstalliert werden?

    Viele Grüsse von hall77
    Betriebssystem: Linux Mint 64-bit, Desktop Mate

  • du kannst sie auch jetzt schon deinstallieren, da sie nur einmal das richtige zertifikat nachinstalliert und dann ihren dienst getan hat. allerdings scheint sie nicht im addons-manager auf, sondern man muss dafür zu about:support gehen, den button zum öffnen des profil-ordners klicken, dort zum unterordner extensions wechseln und die datei /hotfix-update-xpi-intermediate@mozilla.com-1.0.2-signed.xpi manuell löschen.