Beiträge von klickman

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    Hallo Kollegen,


    vermutlich hab ich hier ein "Nischenproblem", doch ev. kann es jemand nachvollziehen/bestätigen/lösen:


    Auf meinem alten 15" MacBook Pro aus 2015 läuft macOS Mojave 10.14.6 mit der genannten FF-Version.

    Auf meinem neuen 16" MacBook Pro M1 aus 2021 läuft macOS Monterey 12.0.1 mit identem Firefox und identen Einstellungen (ich habe das komplette Profil vom alten auf das neue MacBook kopiert, was bestens klappt).


    Nun der Unterschied: Wenn ich unter Monterey am neuen MacBook einen externen Link bei geschlossenem FF klicke, öffnen sich zwei Fenster, obwohl Links in Tabs anstatt in neuen Fenstern öffnen in den Einstellungen markiert ist. Das erste Fenster zeigt die aufgerufene Seite, das zweite Fenster legt sich über das erste und zeigt die leere Startseite an. Das passiert nicht, wenn FF bereits geöffnet ist. Unter Mojave am alten MacBook ist dieses Problem nicht vorhanden. Ich habe FF mittels "Firefox bereinigen" bereits zurückgesetzt - gleiches Verhalten.


    Wer hat eine Erklärung dafür?

    Ja, in dem Fall wird diese Dummy userChrome.js erstellt[...]

    Ich hatte vor dem Bereinigen von FF bereits seit längerem Scripte verwendet, daher waren schon alle nötigen Dateien vorhanden. Auch die userChrome.js. Dennoch haben die Scripte nach dem Bereinigen, trotz vorhandener Dateien, nicht gearbeitet. Mir half eben, diese userChrome.js aus dem chrome-Ordner zu löschen und neuerlich hinzuzufügen. Das wollte ich ausdrücken.

    Firefox bringt manchmal eine eigene userChrome.js mit.

    Bei mir war es so, dass ich Firefox mittels der Bereinigungsfunktion zurückgesetzt hatte. Die für die Funktion von Scripten zu verteilenden Dateien waren danach zwar noch vorhanden, doch es funktionierte kein einziges. Alle diese Dateien waren aktuell. Erst als ich besagte userChrome.js gelöscht und neu hinzugefügt hatte, taten die Scripte wieder ihren Dienst. Ich könnte mir vorstellen, dass das eine Eigenheit unter macOS (und Linux?) ist.

    Ich hab jetzt mal unter Verwendung von "Temporary Containers" GMail in getrennten Containern geöffnet und mich mit beiden Accounts gleichzeitig eingeloggt. In der Cookieverwaltung von Firefox ist diese Trennung nicht zu erkennen und die Google-Cookies werden gesamt, also nicht getrennt nach Account angeführt (so wie im Screenshot in #14).

    Ich verwende aber auch das Add-on Vergiss mein nicht, mit dem du dir die Cookies ansehen kannst. Und hier siehst du, welches Cookie zu welchem Account gehört. Zumindest per Zuordnung des Containers:


    Ein Account war im tmp2-Container geöffnet, der andere im tmp3.

    Vielleicht hilft dir das weiter.


    Nachsatz: Mit z. B. dem Add-on "Google-Container" gelingt das natürlich nicht, da damit alle "Google"-Tabs in ihm geöffnet werden und daher nicht voneinander getrennt sind.

    Ebenso wird es nicht gelingen, mit MAC eine Domain unterschiedlichen Containern zuzuordnen (imho).

    In der normalen Cookie-Verwaltung erscheinen die nur für bestimmte Container geltenden Cookies nicht.

    Kann ich nicht bestätigen. Diese drei Seiten hab ich jetzt testweise unter Verwendung der Add-ons MAC (Facebook und Youtube) und Temporary Containers (camp-firefox.de) in unterschiedlichen Containern geöffnet. Deren Cookies sind alle kumuliert in der "Cookies und Website-Daten"-Verwaltung zu sehen:


    Möglicherweise hast du Cookie-relevante Erweiterungen installiert.

    Relevant wären z.B. die Zeilen mit dem Namen der Erweiterung oder mit dem Eintrag "extensions".


    Und dann? Woher soll der TE wissen, welche Einstellung und vor allem welche Werte sein Problem verursachen? Die Einträge in der prefs.js bzw. unter "about:config" sind nicht gerade selbsterklärend.


    Abgesehen davon, wird bei der Suche z. B. nach "container" das hier in about:config angezeigt:


    Und wenn ich nach z. B. "account" suche, das hier:


    Das sind zwei Begriffe, die im Namen der Erweiterung vorkommen. Also scheitert die Suche nach "Zeilen mit dem Namen der Erweiterung".


    Schließlich bringt mir die Suche nach "extensions" 3 Seiten mit Einstellungen, von denen ich nicht mal eine dem Add-on "Firefox Multi-Account Containers" zuordnen kann (und ja, ich hab es auch in Verwendung).

    Mich würde wirklich interessieren, wie du vorgehen würdest.


    Aber scheint zu viel Arbeit zu sein...

    Wie du über deinem Beitrag lesen kannst, hat der TE sein Problem mit einer für ihn passenden Methode lösen können.

    Der Fehlerbehebungsmodus von Firefox hilft in diesem Fall nicht viel, da dann ja MAC auch deaktiviert wird. Ob man in diesem Fehlerbehebungsmodus dann einzelne Erweiterungen aktivieren kann, weiß ich nicht. Ich würde daher mal alle Erweiterungen manuell deaktivieren und den Versuch mit de- und reaktivieren von MAC erneut versuchen. Möglicherweise pfuscht ein anderes Add-on dazwischen, das du so orten könntest.

    Leider hat das Addon einen Haken: Wenn man es (auch nur ganz kurz) deaktiviert und dann wieder aktiviert, sind alle Einstellungen (Namen der Container, diesen zugeordnete Websites) verschwunden, und man muss scheinbar alles von vorn definieren.

    Ich verwende diese Erweiterung auch, kann das Verhalten aber nicht bestätigen. Bin zwar am Mac mit macOS unterwegs, doch das sollte keine Rolle spielen.

    Eventuell entfernst du die Erweiterung und fügst sie nochmals neu hinzu?

    Vorweg danke für eure Beteiligung!


    hier funktioniert es mit einem Klick, ist das auch im #Fehlerbehebungsmodus von Fx so?

    Ja

    Allerdings funktioniert das nicht, wenn man von der Seite Neuer Tab aus suchen will.

    Das funktioniert bei mir auch nicht mit einem Tab, der eine Webseite geöffnet hat.

    Bei gedrückter Shift-Taste wird nach Klick sofort gesucht.

    Danke! Wenn das noch mittels Skript ohne Shift-Taste realisiert werden könnte, wärs perfekt.

    Hi Kollegen,


    ich freunde mich gerade mit der Suchfunktion der Adressleiste an, bisher hatte ich das Suchfeld der Firefox-Startseite verwendet. Was ich gerne erreichen möchte:

    Wenn ich die Suchleiste verwende, dann kann ich nach Eingabe eines Begriffs auf eines der erscheinenden Suchmaschinensymbole klicken, was die Suche unmittelbar startet:


    Das klappt nicht in der Adressleiste. Hier stellt ein Klick auf eines der erscheinenden Suchmaschinensymbole lediglich die entsprechende Suchmaschine sozusagen ein und ich muss die Eingabetaste drücken (oder den von mir augeblendeten "Go-Button"), damit die Suche gestartet wird (das Erscheinungsbild des "Megabar-Popups" habe ich mittels css-Codes angepasst):


    Wie erreiche ich das gleiche Verhalten wie in der Suchleiste - also sozusagen die "Ein-Klick-Suche"?

    Somit funktioniert das Script hier mit der Standardseite vom Fx einwandfrei.

    Ja Andreas, unter Windows... Ich bin auf macOS. Noch dazu mit der CustomCSSforFX von Aris. Und darüber hinaus verwende ich das Script "TabFocus", welches seinerzeit von Aborix für FF 69 ebenfalls angepasst wurde (so wie das betroffene Script "HideTabbarWithOneTab").


    TabFocus:

    Wie ich gerade herausgefunden habe, arbeitet das Script offensichtlich nur dann korrekt, wenn für "Startseite und neue Fenster" "Leere Seite" eingestellt ist. Mit der Einstellung auf "Firefox-Startseite (Standard)" entsteht der eingangs beschriebene Effekt eines unnötigen, leeren Tabs.

    Für mich stellt es sich also so dar, als könnte das Script nur mit "about:blank" umgehen und nicht mit "about:newtab" oder mit "about:home".