Tab mit Maus wegziehen funktioniert nicht mehr richtig

  • Firefox-Version
    91.0b9
    Betriebssystem
    win 10

    Seit ner Weile (etwa 1-2 Wochen oder so) funktioniert das "Wegziehen" von Tabs mit der Maus nicht mehr richtig. Also wenn ich ein Tab halte und wegziehe, um damit ein neues Fenster zu öffnen. Nicht mehr richtig bedeutet, dass ich mehr Zeit benötige. Wenn ich den Tab ganz schnell packe und "wegschmeisse", dann reagiert es nicht. Ich muss den Tab länger mit der Maus halten, erst dann funktioniert es (habs getestet).


    Das nervt mich schon ziemlich, da ich so ausgebremst werde bzw. ich dann oftmals 5 mal den Tab weg ziehe, bis es dann endlich funktioniert. Kann man das irgendwie wieder so machen, wie es früher war? Das hat sich definitiv geändert. (Beispielsweise funktioniert es mit Chrome einwandfrei, da kann ich so schnell ziehen, wie ich will).


    Edit: Man sieht es auch. Wenn man den Tab packt, und weg zieht (ganz langsam), dann ist die Tabvorschau zuerst weiss, erst kurz danach sehe ich den inhalt des Tabs und auch erst dann kann ich den Tab loslassen, so dass ein neues Fenster entsteht. Ist diese Vorschau noch weiss, funktioniert es nicht.

  • Probiere es bitte mal im Fehlerbehebungsmodus des Firefox aus:

    Probleme beheben mit dem Fehlerbehebungsmodus


    Teste es bitte auch mal mit einem neuen Profil aus:

    Firefox Profile erstellen und löschen

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Unstable Debian-Channel ( Sid, pending) und ESR 102.3.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Das selbe Problem habe ich mit allen 3 Firefoxversionen, die ich habe (Beta, Dev und Nightly). (Edit: Es ist auch an meinem Laptop, der hat völlig andere Profile. Ich glaube nicht, dass es ein "Fehler" ist. Ich denke, es ist so umgesetzt worden mit einer Verzögerung)


    Und das mit dem Fehlerbehebungsmodus hat auch nichts gebracht. Ist genau gleich.


    Habt ihr es mal ausprobiert? Packt mal ein Tab und schaut dann auf die Tabvorschau daneben. Ist sie für einen Bruchteil einer Sekunde kurz weiss ?


    Hier habe ich ein Video bei Youtube hochgeladen, welches das Problem zeigt (mit Vergleich zu Google Chrome und FF Dev Edition):

    Externer Inhalt youtu.be
    Inhalte von externen Seiten werden ohne deine Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklärst du dich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.

    2 Mal editiert, zuletzt von sotnu () aus folgendem Grund: Ein Beitrag von sotnu mit diesem Beitrag zusammengefügt.

  • Hast Du den Fehler schon auf Bugzilla gemeldet?

    Gruß Ingo

    Ich glaube nicht, dass es ein Fehler ist. Ich glaube, man hat einfach schlicht eine Verzögerung eingebaut. Das Problem besteht bei 3 Firefoxversionen am PC und auch am Laptop habe ich das Problem (habe ich gerade getestet).

  • Komisch, hast du das Video gesehen? Vlt. fällt es dir gar nicht auf. Jenachdem, wie schnell du die Maus bewegst, fällt es vlt. gar nicht erst auf.

  • Für mich ist das Problem auch nicht nachvollziehbar. Weder erscheint das Vorschaubild kurz weiß noch wäre es mir möglich, noch schneller zu ziehen - das Ablösen des Tabs funktionierte bei mir bei jedem Versuch. An eine absichtlich eingebaute Verzögerung glaube ich also nicht und ich wüsste auch nicht, wozu das gut sein sollte. Für mich klingt das eher nach einer Performance-Geschichte, wenn es bereits in der Darstellung eine Verzögerung gibt.


    Wenn du meinst, dass das Problem seit einer bestimmten Version auftritt, nutze bitte mozregression, um festzustellen, welche Änderung in Firefox eine Änderung des Verhaltens bei dir hervorgerufen hat:


    mozregression

  • Ich kann das beschriebene "Problem" bestätigen. Normalerweise ist die Funktion bei mir deaktiviert, weil ich grundsätzlich immer nur ein Fenster nutze. Wenn ich es einschalte, dann sieht es hier genauso aus wie im Video des Threadstarters. Das Vorschaubild ist beim Starten des 'dragging' anfänglich weiß und nach kurzer Zeit zeigt sich erst der verkleinerte Screenshot. Führt man die ganze Aktion schnell aus, dann funktioniert es nicht immer mit dem neuen Fenster. Es scheint aber wohl auch mit der dargestellten Seite zu tun haben, bei manchen Seiten geht es besser bei anderen muss man sich wirklich Zeit lassen(ca.1s) damit es funktionieren soll.


    Dieses exakt gleiche Verhalten zeigt sich hier in FF78ESR, der FF90 und der FF92Nightly (im 'Fehlerbehebungsmodus, aber nicht mit neuem Profil, getestet!).

  • Muss die Reproduktion zwingend unter Windows 10 im Dark Mode erfolgen oder ist das egal? Denn unter Windows 8 (hat keinen Dark Mode) bekomme ich beim Tab Tearing nur das kleine Vorschaubild, und das hier ist die aktuelle nightly. In einem neuen Profil / v90 sieht das hier nicht anders aus.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Für mich ist das Problem auch nicht nachvollziehbar. Weder erscheint das Vorschaubild kurz weiß noch wäre es mir möglich, noch schneller zu ziehen - das Ablösen des Tabs funktionierte bei mir bei jedem Versuch. An eine absichtlich eingebaute Verzögerung glaube ich also nicht und ich wüsste auch nicht, wozu das gut sein sollte. Für mich klingt das eher nach einer Performance-Geschichte, wenn es bereits in der Darstellung eine Verzögerung gibt.


    Wenn du meinst, dass das Problem seit einer bestimmten Version auftritt, nutze bitte mozregression, um festzustellen, welche Änderung in Firefox eine Änderung des Verhaltens bei dir hervorgerufen hat:


    https://mozilla.github.io/mozregression/

    Ich werde das mal ausprobieren heute. Aber wenn es ein Perfomanceproblem ist, warum tritt es dann erst seit kurzem auf und warum läuft es bei Google Chrome absolut flüssig und verzögerungsfrei?

  • Chrome hat ja nichts mit Firefox zu tun, insofern spielt es für dein Firefox-Problem keine Rolle, ob das Problem auch in Chrome auftritt oder nicht. Bei einem Website-Problem wäre es sinnvoll, andere Browser zum Vergleich heranzuziehen. Bei einem Problem, welches den Browser selbst betrifft, bringt das eher wenig.


    Könnte ich dir beantworten, wieso das Problem bei dir erst seit kurzem auftritt, könnten wir das alles abkürzen, denn mit der Antwort hätten wir die Ursache für dein Problem gefunden. ;) Wenn die Ursache aber wirklich eine Änderung in Firefox ist und nichts, was sich an deinem System geändert hat, sollte uns mozregression ein großes Stück weiter bringen.

  • Ok, ich habe das Programm mal genutzt. Ich kann nicht klar sagen, welche Versione besser oder schlechter ist. Grenzt dann schon an Einbildung, dass die eine besser oder schlechter ist. Sind alle schlecht.


    Praktisches Progamm übrigens. Aber hab bis letztes Jahr getestet. Und gleichzeitig habe ich mit meiner Version gegengetestet. Aber es scheinen alle etwa gleich (Schlecht) zu sein. Ist komisch. Am Laptop habe ich schliesslich das selbe Problem. Kann irgendwie ja dann schlecht von der Perfomance kommen.


    Vlt. fällt es mir erst jetzt auf. Seit vor 2 Wochen oder so, probiere ich die Maus von einem Bekanntem aus und die ist deutlich besser. Vlt. fällt es mir ja deswegen erst auf?


    Aber andererseits: Manche von euch haben ja das Problem anscheinend nicht, also kann es eig. auch das nicht sein.

  • BTW: Computer-Mäuse altern auch, und können bspw. durch Abnutzung/Verschmutzung den Fokus verlieren.

    Oder Minikabelbrüche, USB-Buchsenkontakte etc. Auch harmonieren manche besser oder schlechter mit dem jeweiligen PC/Notebook/ bzw. Standard-Treiber.