Beiträge von sotnu

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    Ok, ich habe das Programm mal genutzt. Ich kann nicht klar sagen, welche Versione besser oder schlechter ist. Grenzt dann schon an Einbildung, dass die eine besser oder schlechter ist. Sind alle schlecht.


    Praktisches Progamm übrigens. Aber hab bis letztes Jahr getestet. Und gleichzeitig habe ich mit meiner Version gegengetestet. Aber es scheinen alle etwa gleich (Schlecht) zu sein. Ist komisch. Am Laptop habe ich schliesslich das selbe Problem. Kann irgendwie ja dann schlecht von der Perfomance kommen.


    Vlt. fällt es mir erst jetzt auf. Seit vor 2 Wochen oder so, probiere ich die Maus von einem Bekanntem aus und die ist deutlich besser. Vlt. fällt es mir ja deswegen erst auf?


    Aber andererseits: Manche von euch haben ja das Problem anscheinend nicht, also kann es eig. auch das nicht sein.

    Für mich ist das Problem auch nicht nachvollziehbar. Weder erscheint das Vorschaubild kurz weiß noch wäre es mir möglich, noch schneller zu ziehen - das Ablösen des Tabs funktionierte bei mir bei jedem Versuch. An eine absichtlich eingebaute Verzögerung glaube ich also nicht und ich wüsste auch nicht, wozu das gut sein sollte. Für mich klingt das eher nach einer Performance-Geschichte, wenn es bereits in der Darstellung eine Verzögerung gibt.


    Wenn du meinst, dass das Problem seit einer bestimmten Version auftritt, nutze bitte mozregression, um festzustellen, welche Änderung in Firefox eine Änderung des Verhaltens bei dir hervorgerufen hat:


    https://mozilla.github.io/mozregression/

    Ich werde das mal ausprobieren heute. Aber wenn es ein Perfomanceproblem ist, warum tritt es dann erst seit kurzem auf und warum läuft es bei Google Chrome absolut flüssig und verzögerungsfrei?

    Das selbe Problem habe ich mit allen 3 Firefoxversionen, die ich habe (Beta, Dev und Nightly). (Edit: Es ist auch an meinem Laptop, der hat völlig andere Profile. Ich glaube nicht, dass es ein "Fehler" ist. Ich denke, es ist so umgesetzt worden mit einer Verzögerung)


    Und das mit dem Fehlerbehebungsmodus hat auch nichts gebracht. Ist genau gleich.


    Habt ihr es mal ausprobiert? Packt mal ein Tab und schaut dann auf die Tabvorschau daneben. Ist sie für einen Bruchteil einer Sekunde kurz weiss ?


    Hier habe ich ein Video bei Youtube hochgeladen, welches das Problem zeigt (mit Vergleich zu Google Chrome und FF Dev Edition):

    Externer Inhalt youtu.be
    Inhalte von externen Seiten werden ohne deine Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklärst du dich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.

    Seit ner Weile (etwa 1-2 Wochen oder so) funktioniert das "Wegziehen" von Tabs mit der Maus nicht mehr richtig. Also wenn ich ein Tab halte und wegziehe, um damit ein neues Fenster zu öffnen. Nicht mehr richtig bedeutet, dass ich mehr Zeit benötige. Wenn ich den Tab ganz schnell packe und "wegschmeisse", dann reagiert es nicht. Ich muss den Tab länger mit der Maus halten, erst dann funktioniert es (habs getestet).


    Das nervt mich schon ziemlich, da ich so ausgebremst werde bzw. ich dann oftmals 5 mal den Tab weg ziehe, bis es dann endlich funktioniert. Kann man das irgendwie wieder so machen, wie es früher war? Das hat sich definitiv geändert. (Beispielsweise funktioniert es mit Chrome einwandfrei, da kann ich so schnell ziehen, wie ich will).


    Edit: Man sieht es auch. Wenn man den Tab packt, und weg zieht (ganz langsam), dann ist die Tabvorschau zuerst weiss, erst kurz danach sehe ich den inhalt des Tabs und auch erst dann kann ich den Tab loslassen, so dass ein neues Fenster entsteht. Ist diese Vorschau noch weiss, funktioniert es nicht.

    Aber ich denke, dass das hier nicht der Ort ist, um das auszudiskutieren. Und die Seite ist (für mich) nicht illegal als Besucher. Ich denke zwar, du meinst aus sicht der Betreiber. Aber wie gesagt, ich werde drauf schauen, dass ich keine solche Links mehr poste.

    Das kam wohl falsch rüber.


    Aber dann nochmals anders: Sorry, ich habe nicht dran gedacht. In meinem Land ist es nicht illegal, dass es das auf dieser Plattform ist, habe ich vergessen. Also sorry. Ich wollte sicherlich nicht der Plattform schaden.

    Lol ok, sorry, dann nochmals mit der Seite "https://de.pons.com/"


    Die dürfte doch wohl erlaubt sein ? :)


    Ich muss nur über den Link fahren im Inspektor und dann wird mir das auch angezeigt (Firefox Version 88). Den Link kann ich auch z.B als Thumbnail für google Translate nutzen, wie im 2. Bild zu sehen.


    Aber der link funktioniert nicht über CSS (andere Bilder aus google schon).


    Ich bin dann aber für heute mal weg, ist schon spät :)


    Trotzdem danke für alle Antworten heute!


    Das ist der Link zum Thumbnail aus einer anderen Firefoxversion, die noch Thumbnails verwendet (was die Version 89 anscheinend nicht tut).


    Wenn ich den im Inspektor direkt nutze, funktioniert das auch.


    Aber ich bin dann wohl gezwungen, dieses Design zu nutzen bzw. bei jeder Webseite selbst Thumbnails zu erstellen...


    Also so wie hier (das ist original so)

    Ahh, hat geklappt. Als Selektor dann in diesem Fall mittels rechtsklick->kopieren->CSS Selektor.


    Danke.


    Edit: Irgendwie funktioniert das nicht mit diesen Links:


    Funktioniert nur mit "normalen" Links und dann kann ich gleich die Funktion von Firefox nutzen.


    Weiss jemand, was das für Links sind? Ich hab den Links aus Firefox selbst.

    Hallo :)


    Ich versuche gerade etwas an Firefox zu ändern. Mit dem Entwicklerwerkzeug "Inspektor" schaffe ich das auch. Aber ich weiss dann nicht, welchen Selektor ich nehmen muss (ich glaube, das heisst selektor, wenn ich das in der Anleitung von Sören richtig kapiert habe). Also ich meine den "Ort", indem ich dann Dinge abändern kann.


    Hier ein Beispielbild:


    https://abload.de/img/firefox89thumbnailseimrkyj.png


    Wenn ich z.B die höhe und breite (grün eingekreist) ändern will, was muss ich da als "Selektor" nehmen? Wenn ich da folgendes nehme, funktioniert es nicht:


    Code
    .outer-wrapper.newtab-experience .top-site-outer .tile {
    width: 89px;
    height: 89px;
    }

    Wenn ich links auf das blau markierte rechtsklicke, dann kopieren->CSS-Selektor wähle, funktioniert es auch nicht. Wenn ich es im Inspektor selbst ändere, funktioniert es aber.


    Code
    li.top-site-outer:nth-child(5) > div:nth-child(1) > a:nth-child(1) > div:nth-child(1) {
    width: 89px;
    height: 89px;
    }

    Beides Funktioniert nicht. Bei mir scheitern solche Dinge so oft darüber, dass ich den "Ort" nicht erreiche. Im Inspektor schaffe ich es meistens, etwas zu ändern (so wie ich es will), aber mit CSS funktionierts dann irgendwie nicht.


    Und dann noch eine 2. Frage: Das rot eingekreiste steht unter "Element". Wie finde ich da den "Ort" (Selektor?), den ich abändern muss?

    Also bei mir hat das sehr gut funktioniert bei meinen angepinnten Seiten. Ich hatte da nie Probleme.


    Und ja, die Benutzeroberfläche ist nunmal wichtig. Das unterschätzen viele. Die mögliche Individualisierung von Werkzeugen macht diese effizienter.


    Ich finde eben nicht, dass die Optik nur "schön aussieht" oder eben nicht. Wie eine Benutzeroberfläche gestaltet ist, hat erheblichen Einfluss auf die Effizienz, wie gut man diese benutzen kann. Natürlich gibt es keine "perfekte" Benutzeroberfläche, da diese sehr vom Nutzer abhängt. Deswegen ja individualisierbar.


    Aber ich schiebe das ja nicht euch beiden zu oder will mich bei euch beschweren. Ich bin dankbar für die Hilfe hier! Ich glaube manchmal einfach nur, dass optische Entscheidungen oftmals deswegen getroffen werden, weil sie "modern" aussehen "müssen". Und das stört mich.

    Ja, habe die Screenshots gesehen. Das ist ja das Problem, es sind immer Logos und keine (atomaitsche) Bilder (Thumbnails). Bis Version 88 scheint es auch noch Thumbnails zu geben und ab 89 dann nur noch logos.


    Und ich verlange ja nicht, dass man alles mögliche einbaut, es wäre nur schön, wenn man nicht alles mögliche ausbaut.


    Und ja, ich könnte jedes mal, wenn ich eine Webseite dort anpinne, ein Bild machen. Aber das ist alles andere als Wartungsarm.


    @Sören: Ich finde, Thumbnails sind aussagekräftiger wie irgendwelche Logos bzw. vlt. kann ich mir ja nicht jedes Logo von irgendeiner kleinen Seite merken. Bei einem Thumbnail weiss ich aber sofort, welche Webseite das ist. Klar, ich kann es beschriften, aber Thumbnails sind einfach effizienter. Man findet die Webseite deutlich schneller, wie wenn man alle Beschriftungen duchlesen müsste.


    Ist für mich eine Sache der Effizienz.

    Ja, bei FF88 funktioniert das bei mir auch noch. Nur bei der Developer Vers 89 sieht es ganz anders aus (auch mit abgerundeten Tabs etc.).


    Da werden anscheinend keine Thumbnails mehr genutzt, nur noch Logos.


    Aber ich sehe gerade: Wenn ich die Webseiten besuche, kriege ich (irgendwann mal) ein Logo (aber kein Thumbnail wie früher). Aber wenn ich Firefox schliesse und neustarte, sind alle Logos wieder weg (bei mir löscht es immer die Chronik).


    Das verursacht aber in FF88 keine Probleme, da lösche ich auch immer alles und beim Neustarten sind die Thumbnails noch da.


    Ja, Änderungen sind ja ok, wenn es nicht einfach "Neu gleich besser"-mässig ist bzw. eine "Muss jetzt modern ausehen"-Änderung. Individualisierbar sollte es sein. Man hätte ja was einbauen können, um zwischen Logos und Thumbnails zu wählen oder ähnliches, anstatt das eine durch das andere zu ersetzen.


    Ich muss dann mal schauen, wie ich (automaitsche) Thumbnails wieder aktivieren kann. Vlt. gibts auch was irgendwo bei about:config oder ähnliches.

    Ja gut, aber bei mir funktioniert der Link.


    (Edit: ich sehe gerade, dass bei mir Pons nun auch automatisch ein anderes Logo hat - aaaber trotzdem kein Thumnail der Webseite, eben nur ein Logo).


    Ich habs jetzt geschafft, dass zu ändern (aber nicht richtig...):


    Code
    li.top-site-outer:nth-child(29) > div:nth-child(1) > a:nth-child(1) > div:nth-child(1) {
    background-image: url("moz-page-thumb://thumbnails/?url=https%3A%2F%2Fde.pons.com%2F&revision=8177");
    }

    Das fügt das Thumbnail hinzu, aber! ich hab den Link aus der anderen Firefox Version rauskopiert. Ich weiss also nicht, was ich machen muss, damit das automatisch passiert (also ein thumbnail als Hintergrund nutzen).


    Wobei das noch nicht genug ist.


    Code
    li.top-site-outer:nth-child(29) > div:nth-child(1) > a:nth-child(1) > div:nth-child(1) > div:nth-child(1)

    Ich muss diesen Knoten löschen, damit das "P" (Der buchstabe [Edit: Allgemein das Logo]) verschwindet. (Wie löscht man eig. knoten mittels css, also was muss ich schreiben, um knoten zu löschen?)