Einige Webseiten werden seit Firefox 89 nicht mehr richtig dargestellt

  • Firefox-Version
    90.0.1
    Betriebssystem
    Windows 10 20H2

    Hallo Forum,

    seit Firefox 89 (auch im aktuellen 90.0.1) werden auf einem meiner PCs einige Webseiten nicht mehr richtig dargestellt (z.B. Ecosia, nach einer Suche, s. Screenshot).

    Manchmal ist der Fehler recht subtil, z.B. nur der Inhalt eines Eingabefeldes wird nicht angezeigt.

    Auf meinen anderen PCs läuft der Firefox einwandfrei.


    Was ich schon probiert habe:

    - Bereinigen

    - Deinstallieren und C:\Program Files\Mozilla\Firefox und ...AppData\Roaming\Mozilla\Firefox\ gelöscht (seltsamerweise beomme ich auch nach dieser "kompletten" Deinstallation nach erneuter Installation angeboten, einiges wiederherzustellen)

    - Hardwarebeschleunigung aktiviert und deaktiviert

    - Addons deaktiviert


    Wie kann ich das Problem lösen, bzw. wie kann ich den Firefox wirklich komplett deinstallieren, ohne dass Spuren zurückbleiben? Vielleicht funktioniert er ja dann nach einer Neuinstallation wieder.


    Danke schon mal.

  • Gib uns bitte mehr Infos über deinen Firefox und zwar folgendermaßen:
    ●☰ ➜ (?) Hilfe ➜ Weitere Informationen zur Fehlerbehebung
    ● jetzt die Schaltfläche "Text in die Zwischenablage kopieren" anklicken
    ● jetzt den kopierten Text aus der Zwischenablage, per rechtsmausigen Klick, als </>Code hier ins Forum einfügen. siehe dazu

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Danke für die Anleitung!


    Hier der Code ;)


  • Teste zuerst den SafeMode indem du folgendes machst:

    ☰ ➜ (?) Hilfe ➜ Fehlerbehebungsmodus ➜ Neu starten ➜ Im Fehlerbehebungsmodus starten

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • @grisu2099: Auch mit aktuellem Grafikkartentreiber gibt es dasselbe Darstellungsproblem

    @.DeJaVu: Den Antivirus kann ich nur deaktivieren, das hat keine Auswirkung.

    @Zitronella: Im Safe Mode wie beschrieben funktioniert er! Wenn ich ohne einen Fehler zu beheben neu starte, wieder nicht.


    Was wäre der nächste Schritt?

  • Die vorgeschlagenen Aktionen habe ich durchgeführt:

    - Hardwarebeschleunigung deaktiviert

    - Standard-Theme aktiviert

    - Alle Erweiterungen erst deaktiviert, dann auch entfernt

    - Noch mal bereinigt


    Leider ohne Erfolg.


    Gibt eine komplette Deinstallationsroutine ohne jegliche Reste im System? Dann würde ich das gerne probieren und neu installieren.

    Wenn es dann immer noch icht funktioniert, muss es ja etwas an meinem PC sein.

    Antivirus und Firewall kann ich mir eher nicht vorstellen, weil dann ja auch andere PCs im Netzwerk, die dasselbe benutzen, Probleme haben sollten - oder?

  • - Hardwarebeschleunigung deaktiviert

    Wurde Firefox denn danach auch beendet und erneut gestartet? Das ist nämlich zwingend notwendig, damit die Deaktivierung auch greift.

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Habe ich probiert, ohne Erfolg.


    Aber ich habe - weil es ja anscheinend ein Schrift-Darstellungsproblem ist - mal dien Haken entfernt bei "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben". Dann sieht zumindest Ecosia wieder normal aus und die Suchergebnisse werden auch wieder angezeigt.

    Also eigentlich alles gut, nur weiß ich nicht, ob es bei anderen Websites Darstellungsfehler geben wird, die für eigene Schriften optimiert sind. Und nach wie vor seltsam, dass dieser Fehler nur bei dem einen PC auftritt.


    Hat jemand einen Idee dazu?

  • Habe ich probiert, ohne Erfolg.

    Was hast du probiert?

    Dir sind seit deinem letzten Post mehrere Maßnahmen vorgeschlagen worden. Hast du die alle probiert?

    mal dien Haken entfernt bei "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben".

    Den solltest du wieder setzen, sonst kann es auf anderen Seiten Probleme geben...

  • @Zitronella: Ja, ich habe nach allen Maßnahmen Firefox beendet und wieder neu gestartet.

    @grisu2099: Ohne Erfolg habe ich ein neues Profil erstellt und damit gestartet. Und ich habe alle anderen Maßnahmen erfolglos probiert und nach jeder Maßnahme den Firefox neu gestartet.


    Zitat

    Den solltest du wieder setzen, sonst kann es auf anderen Seiten Probleme geben...

    Das denke ich auch, aber momentan ist es die einzige Möglichkeit, die Seiten korrekt anzuzeigen.

    Nach wie vor wäre die Frage, ob es ggf. eine Windows-Einstellung gibt, die das Problem lösen könnte.

  • Falls ein neues Profil ohne alles es auch nicht richtig anzeigt, solltest Mal deine Sicherheitssoftware deinstallieren, nicht nur deaktivieren, und dann leider noch Mal mit einem neuen Profil testen.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Also man sollte mal den Antivirus komplett deinstallieren, ein deaktivieren alleine reicht oftmals nicht.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Stable Release Channel und ESR 91 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Das Deinstallieren des Antivirus muss ich mal in Ruhe machen. Das kann noch ein paar Wochen dauern.

    Ich melde mich dann wieder.


    Danke schon mal für die vielen Hinweise!

  • Noch eine Überlegung zum Antivirus: Auf anderen PCs im Netzwerk ist auch dieselbe Software installiert und der Firefox funktioniert trotzdem (gleiche Version). Also kann es doch eigentlich nicht am Antivirus (alleine) liegen - oder?

  • Sollte nicht, aber wir haben hier im Forum schon andere Erfahrungen gemacht. Mit unterschiedlichen Antivirus Lösungen, bei dem einen geht es beim anderen nicht. Kommt ja auch oftmals auf die gemachten Einstellungen an. Auch auf die, die die verwendete Software selber macht.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Stable Release Channel und ESR 91 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Hallo Forum,


    ich habe jetzt endlich die Möglichkeit gehabt, das Antivirusprogramm zu deinstallieren, um zu prüfen, ob das Problem dadurch gelöst ist. (Bei manchen Websites wird in Eingabefeldern bzw. Dropdown Menüs kein Text angezeigt, bei manchen ist die ganze Darstellung kaputt (s. Screenshots).


    Leider besteht es immer noch, auch mit dem neuesten Firefox (94.0.1)


    Ich habe den Firefox auch noch mal deinstalliert, die Ordner Mozilla in

    C:\Users\[Name]\AppData\Roaming\ und

    C:\Users\[Name]\AppData\Local\

    gelöscht, den PC neu gestartet und Firefox neu installiert. Alles ohne Erfolg.


    Alles oben schon erwähnte gilt nach wie vor.

    Hat jemand noch eine Idee?