FF71.0 - Menüleiste verrutscht

  • Ihr vergesst, dass es euer nicht funktionierender Code ist, der die Menüleiste nach unten bringt. Standard ist, dass die Menüleiste eben ganz oben ist. Also, den Code einfach deaktivieren und erst einmal auf den Rest verzichten.

    Ja das stimmt aber dann hat man die Tab Leiste wieder über der Adressleiste

    Alles ein wenig verzwickt.

  • Ja das stimmt aber dann hat man die Tab Leiste wieder über der Adressleiste

    Ist das so schlimm? Das ist doch Standard und ist außerdem zeitlich begrenzt, bis die Ursache für das Problem gefunden ist. Für die Tableiste unter der Lesezeichenleiste gibt es außerdem noch ein Benutzerskript.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Siehst Du für die Zukunft eher Probleme/Einschränkungen/Schwierigkeiten bei CSS- oder JS-Basteleien?


    Nicht wirklich mehr als in den letzten 15 Jahren. Momentan tut sich natürlich besonders viel in Hinblick darauf, proprietäre Mozilla-Technologien (XBL, XUL) durch Webstandards zu ersetzen, daher gab es sicher schon "ruhigere" Zeiten als mit den Updates in 2019 und den in 2020 kommenden Firefox-Updates, das heißt, es muss vielleicht häufiger mal was angepasst werden als es dem einen oder anderen lieb wäre. Aber grundsätzlich war diese Form der Firefox-Anpassung schon immer eine Risiko-Angelegenheit ohne jede Garantie und vor allem ohne jedes Versprechen seitens Mozilla. Mozilla muss Firefox weiterentwickeln und gemessen an der Gesamtzahl der Nutzer hat praktisch niemand solche Anpassungen. Es ist technisch auch überhaupt nicht möglich, dass Mozilla weiß, in welcher Art und Weise Firefox von Nutzern durch Scripts und userChrome.css angepasst wird. Damit ist es auch nicht möglich, dass Mozilla darauf Rücksicht nimmt, selbst wenn sie es wollten.

  • Beitrag von Panther1 ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Sorry, hat was gedauert, weil ich noch woanders zu tun hatte...

    //

    Beitrag Nr. 19 wurde gelesen und der Code getestet?

    Gelesen, getestet und... Applaus, Applaus, Applaus, Andy hats mal wieder gerichtet :thumbup:


    Ich mußte aber einen Wert verändern weil sonst wieder so'n blöder grauer Balken da war:

    CSS
    1. /* Linux/macOS */
    2. /* space above navigation toolbar (OS titlebar) */
    3. /* set to '0', if no menubar is used */
    4. #main-window:not([tabsintitlebar]):not([sizemode="fullscreen"]) #nav-bar {
    5. margin-top: -4px !important; /* war 20 bei Andreas */

    Und dann kam das dabei raus:



    Guck Dich nicht um, 2002Andreas , ich hab den Dank grade schonmal losgeschickt :frech:

  • https://www.computerbase.de/fo…-tabs-nach-unten.1852242/


    Das war die Lösung : Dateien von Post 4 runter laden in den Chrome Ordner einfügen fertig.

    Habe hier alles wie vorher und läuft einwandfrei.

    Glück gehabt. Der Code ist für eine ältere Version gewesen und muss auch nicht für dich geeignet sein, wenn du noch andere Anpassungen hast.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Hallo,

    Zitat von 2002Andreas

    Ganz wichtig, zusätzlich in about:config den Wert:

    layout.css.xul-box-display-values.survive-blockification.enabled

    auf false setzten.

    mein Hauptprofil machte nach dem Update auf 71.0 mal wieder dicke Backen, es zeigte sich wiedermal ein leerer Raum unterhalb meiner Lesezeichen-Tabs (rund und farbig).

    Abhilfe schaffte obiger Eintrag in about:config.

    Vielen Dank dafür! :)

  • Ganz wichtig, zusätzlich in about:config den Wert:


    layout.css.xul-box-display-values.survive-blockification.enabled


    auf false setzten.

    Das hier war der Schlüssel für mein Problem. Danke.

    Einfach die bisherigen Einstellungen beibehalten und nur dieses Flag deaktivieren.

  • Auch von mir, lieber 2002Andreas, danke. War genau das, was noch fehlende. Jetzt muß ich nur noch in den wirren hier, die Grunddateien für das Funktionieren der user.css finden, damit meine Mousehover und die Uhr wieder funktioniert.

    Mit besten Grüßen vom Ammersee
    Thomas

    Dell XPS 13 9360, Intel Core i5-7200U, 8 GB RAM, SSD 256 GB, Intel HD Graphics 620, Win 10 Prof 64 bit, Kaspersky KAV, MS Office 2016

  • 2002Andreas : Der einzelne Wert reicht aus - wer weiß, wie lange noch...

    Besten Dank an Dich! :thumbup:

    Aloha, Uli
    Firefox Tete009 - immer letzte Version (die mit den neuen Fehlern in der Oberfläche)
    Trottel werden nicht geboren, schöne Frauen stellen sie in ihrer Freizeit her.
    Note to myself: Never argue with morons, they pull you down on their level and beat you with experience!

  • Mit der aktuellen Version von Aris (2.9.0) funktioniert das mit dem auf "false" setzen bei dem genannten Schlüssel leider nicht. Die 2.4.2 läuft damit. Was wäre denn bei der 2.9.0 zu ändern bzw. zu aktualisieren?

    Greetz
    quick