Wetterfuchsbutton FX 68 und Nightly 69

  • Hallo,


    nachdem mein Wetterfuchs für die Nightly und Beta 69 angepasst wurde, scheint momentan alles zu passen:


    Alle Icon werden angezeigt.


    Habe nun mal versucht, das ganze für den FX 68 bereit zu stellen, sieht momentan so aus:


    Kann mich entsinnen, dass der kleine Pfeil (am WF-Icon) früher schon mal angezeigt wurde.

    Leider werden hier bei den Untertiteln (u. weiteren) keine Icon angezeigt.

    Hängt es evtl. mit moz - binding (in *.css) zusammen?

    Was ist da zu tun?

  • Hängt es evtl. mit moz - binding (in *.css) zusammen?

    Teste es, indem du mal einen Eintrag aus der Nightly Version einträgst.


    Ich vermute, daran liegt es.

    Habe es so gemacht - z.B.

    Code
    1. /* Symbole für Menüeintrage */
    2. menu[label="DE Wetterdaten"] {
    3. -moz-appearance:nome!important;
    4. url("chrome://global/content/bindings/menu.xml#menu-iconic") !important;
    5. list-style-image: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACK0lEQVQ4jbWR3UtTcRjHn7sgIvWcnfOLIAi7KIIu+hP6C9a71rQ3acQQiQhKLwy6iQoiYgRdFFjTDUvcip3YnF7aRW8ez9Z2th3dsq1s0023zu9sRN8urEjUyos+958PX56H6H+QUmgDEVFljHVVlE3SugNfxraAiKg6ylAZka8QES2MMPxVrI6xyC8xwqJca8NCmAXLIflrKcSKRESFgG1nzi9sWzVQGZW/LUYYFsJysp53o553w0pfgpW9huJz2V9UZBSC8solswGZLY7IF4mIymGG+se7sNLd4HEXrEQnakYPTKMXs89WkX9SDjOUQgxV1YFa5ip47Cx49DS4dgJca0dtqgflV0eR90vIDUtI3Vk69DLmFKlUz7thJTrBo6fAtXaYk8dgqkfA42dQ1S/g/ZA4vEIsBCWlEJSx+OY46rlb4O+c4FobzMlWmOphmBN28JgDpnEZhRd2ZB7bEBvcLKwIfQqItyvaOVh6F0y1FaZ6COaEHaa6HzXjPD6P2zHlFTrSPsEZ9zZuXybnAzZHzi9h/mULajM3YekucK0FfPIgrJQLc69PIuNvRtorrn7ID0PSAyKi7BPhRk7ZjZLqBJ/qRm26B/NvOzA93IzE/Y1bdY/4SO9v6lvzG9ODNqR8DTuyT3ch7ROys+MHkBwQryf7RSQ8gm9NkYjI8DTtMe41NRARpQaWpur9ohX3CL1ERPGHwuAfA7+j/5BifY17o32N+/5ZXC/fAen2UmIDHbyPAAAAAElFTkSuQmCC") !important;
    6. -moz-image-region: rect(0px 16px 16px 0px) !important;
    7. padding-left:4px!important;}

    Den ganzen Passus eingetragen - leider keine Änderung. Oder meintest du etwas anderes?

  • Teste bitte mal:


    CSS
    1. menu[label="DE Wetterdaten"] {
    2. -moz-appearance:none!important;
    3. background: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACK0lEQVQ4jbWR3UtTcRjHn7sgIvWcnfOLIAi7KIIu+hP6C9a71rQ3acQQiQhKLwy6iQoiYgRdFFjTDUvcip3YnF7aRW8ez9Z2th3dsq1s0023zu9sRN8urEjUyos+958PX56H6H+QUmgDEVFljHVVlE3SugNfxraAiKg6ylAZka8QES2MMPxVrI6xyC8xwqJca8NCmAXLIflrKcSKRESFgG1nzi9sWzVQGZW/LUYYFsJysp53o553w0pfgpW9huJz2V9UZBSC8solswGZLY7IF4mIymGG+se7sNLd4HEXrEQnakYPTKMXs89WkX9SDjOUQgxV1YFa5ip47Cx49DS4dgJca0dtqgflV0eR90vIDUtI3Vk69DLmFKlUz7thJTrBo6fAtXaYk8dgqkfA42dQ1S/g/ZA4vEIsBCWlEJSx+OY46rlb4O+c4FobzMlWmOphmBN28JgDpnEZhRd2ZB7bEBvcLKwIfQqItyvaOVh6F0y1FaZ6COaEHaa6HzXjPD6P2zHlFTrSPsEZ9zZuXybnAzZHzi9h/mULajM3YekucK0FfPIgrJQLc69PIuNvRtorrn7ID0PSAyKi7BPhRk7ZjZLqBJ/qRm26B/NvOzA93IzE/Y1bdY/4SO9v6lvzG9ODNqR8DTuyT3ch7ROys+MHkBwQryf7RSQ8gm9NkYjI8DTtMe41NRARpQaWpur9ohX3CL1ERPGHwuAfA7+j/5BifY17o32N+/5ZXC/fAen2UmIDHbyPAAAAAElFTkSuQmCC") !important;
    4. background-position: 5px 2px !important;
    5. }

    Die beiden Werte unten wenn dann noch anpassen.

  • Apropos Wetterfuchs.

    Hab ich schon wieder irgendwas verpasst, oder warum krieg ich im 68er gar kein Menü mehr am Button angezeigt :/

    Hallo,

    diese Geschichte mit dem 68er FX hat mich gestern einige Zeit gekostet.

    Also, habe die *.css Dateien "Wetterfuchs Button u. "Wetterfuchs Symbole" in den Ordner CSSWeb verfrachtet und die import-Befehle dann entsprechend in der "userContent.css" unter gebracht.

    Damit habe ich in mehreren Profile den Wetterfuchs (s.w.#1gezeigt) zumindest mit den Untermenüs hinbekommen.

  • Ja, das hast du zwar alles auch sehr schön und richtig gemacht. Nur ist das halt so, dass es mir hier um das ganze Buttonmenü geht und dieses wird ausschließlich ins Script geschrieben und auch nur von da aus bereit gestellt.

    Und ohne was am Script geändert zu haben, krieg ich nach dem Update kein Menü mehr am Start!


    Das von dir erwähnte ist für die reine Optik und Kosmetik gedacht.

  • Ja, das hast du zwar alles auch sehr schön und richtig gemacht. Nur ist das halt so, dass es mir hier um das ganze Buttonmenü geht und dieses wird ausschließlich ins Script geschrieben und auch nur von da aus bereit gestellt.

    Und ohne was am Script geändert zu haben, krieg ich nach dem Update kein Menü mehr am Start!


    Das von dir erwähnte ist für die reine Optik und Kosmetik gedacht.

    Dann stelle ich mal meine Version z.Vfg. Damit klappt es zumindest mit dem Aufruf der Menüs:

    Kannst ja mal unverbindlich ausprobieren. Ist für mein Ländle SH konzipiert! :)

  • 2002Andreas ,

    habe schon mehrfach ausprobiert (auch mit deinem Vorschlag).

    Bisher noch keine Änderung in Sicht??

    Gruß,
    D. Büssen
    Firefox 68.0.1 (WIN 10 64 bit)

    Einmal editiert, zuletzt von Büssen () aus folgendem Grund: Berichtigung der Adresse

  • // Büssen du sprichst einen falschen Nutzer an. Der Name ist 2002Andreas und nicht andreas und wenn du das @ davor schreibst wird dieser direkt angesprochen. EDIT: es wurde korrigiert

    Hilfe auch im deutschsprachigen Firefox-Chat möglich.
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

    Einmal editiert, zuletzt von Zitronella ()

  • Hallo Meister.

    Du verwendest ja meinen CSS Code für die Symbole im Kontextmenü.

    Der muss ab Firefox 68 geändert werden, sonst geht das Menü nicht, so wie bei Dir.

    Durchsuche mal Deine diesbezüglichen Klamotten und ändere dann den entsprechende
    Teil CSS Code, es ist übrigens ein eigener CSS Code den Du da irgendwo reingezimmert hast

    und nur der verursacht das Problem. Das Script läuft hier ansonsten einwandfrei.

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0.2
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/Firefox/70.0a1

    OS: Windows 7 H. P. 64 Bit
    Kein Support per PN. Fragen bitte im Forum stellen!

  • // Büssen du sprichst einen falschen Nutzer an. Der Name ist 2002Andreas und nicht andreas und wenn du das @ davor schreibst wird dieser direkt angesprochen.

    Das wollte ich aber nicht, werde in Zukunft den Einwurf berücksichtigen.

    Vielen Dank für den Hinweis!

    Werde noch nachträglich auf 2002Andreas ändern.

    Nachtrag:

    Im Moment komme ich nicht weiter, melde mich hiermit aus dem Kreis!

    Gruß,
    D. Büssen
    Firefox 68.0.1 (WIN 10 64 bit)

    Einmal editiert, zuletzt von Büssen () aus folgendem Grund: Nachtrag eingefügt

  • Bisher noch keine Änderung in Sicht??

    Sorry, kleiner Fehler in meinem CSS Code, so sollte es sein:


    CSS
    1. menu[label="DE Wetterdaten"] {
    2. -moz-appearance: none !important;
    3. background: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACK0lEQVQ4jbWR3UtTcRjHn7sgIvWcnfOLIAi7KIIu+hP6C9a71rQ3acQQiQhKLwy6iQoiYgRdFFjTDUvcip3YnF7aRW8ez9Z2th3dsq1s0023zu9sRN8urEjUyos+958PX56H6H+QUmgDEVFljHVVlE3SugNfxraAiKg6ylAZka8QES2MMPxVrI6xyC8xwqJca8NCmAXLIflrKcSKRESFgG1nzi9sWzVQGZW/LUYYFsJysp53o553w0pfgpW9huJz2V9UZBSC8solswGZLY7IF4mIymGG+se7sNLd4HEXrEQnakYPTKMXs89WkX9SDjOUQgxV1YFa5ip47Cx49DS4dgJca0dtqgflV0eR90vIDUtI3Vk69DLmFKlUz7thJTrBo6fAtXaYk8dgqkfA42dQ1S/g/ZA4vEIsBCWlEJSx+OY46rlb4O+c4FobzMlWmOphmBN28JgDpnEZhRd2ZB7bEBvcLKwIfQqItyvaOVh6F0y1FaZ6COaEHaa6HzXjPD6P2zHlFTrSPsEZ9zZuXybnAzZHzi9h/mULajM3YekucK0FfPIgrJQLc69PIuNvRtorrn7ID0PSAyKi7BPhRk7ZjZLqBJ/qRm26B/NvOzA93IzE/Y1bdY/4SO9v6lvzG9ODNqR8DTuyT3ch7ROys+MHkBwQryf7RSQ8gm9NkYjI8DTtMe41NRARpQaWpur9ohX3CL1ERPGHwuAfA7+j/5BifY17o32N+/5ZXC/fAen2UmIDHbyPAAAAAElFTkSuQmCC")no-repeat !important;
    4. background-position: 5px 2px !important;
    5. }

    Das sieht dann so aus:



    Um dann bei hover einen Hintergrund zu bekommen bedarf es eines 2ten Codes:


    CSS
    1. menu[label="DE Wetterdaten"]:hover {
    2. -moz-appearance: none !important;
    3. background: #90C7F5 url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACK0lEQVQ4jbWR3UtTcRjHn7sgIvWcnfOLIAi7KIIu+hP6C9a71rQ3acQQiQhKLwy6iQoiYgRdFFjTDUvcip3YnF7aRW8ez9Z2th3dsq1s0023zu9sRN8urEjUyos+958PX56H6H+QUmgDEVFljHVVlE3SugNfxraAiKg6ylAZka8QES2MMPxVrI6xyC8xwqJca8NCmAXLIflrKcSKRESFgG1nzi9sWzVQGZW/LUYYFsJysp53o553w0pfgpW9huJz2V9UZBSC8solswGZLY7IF4mIymGG+se7sNLd4HEXrEQnakYPTKMXs89WkX9SDjOUQgxV1YFa5ip47Cx49DS4dgJca0dtqgflV0eR90vIDUtI3Vk69DLmFKlUz7thJTrBo6fAtXaYk8dgqkfA42dQ1S/g/ZA4vEIsBCWlEJSx+OY46rlb4O+c4FobzMlWmOphmBN28JgDpnEZhRd2ZB7bEBvcLKwIfQqItyvaOVh6F0y1FaZ6COaEHaa6HzXjPD6P2zHlFTrSPsEZ9zZuXybnAzZHzi9h/mULajM3YekucK0FfPIgrJQLc69PIuNvRtorrn7ID0PSAyKi7BPhRk7ZjZLqBJ/qRm26B/NvOzA93IzE/Y1bdY/4SO9v6lvzG9ODNqR8DTuyT3ch7ROys+MHkBwQryf7RSQ8gm9NkYjI8DTtMe41NRARpQaWpur9ohX3CL1ERPGHwuAfA7+j/5BifY17o32N+/5ZXC/fAen2UmIDHbyPAAAAAElFTkSuQmCC")no-repeat !important;
    4. background-position: 5px 2px !important;
    5. color: black !important;
    6. }

    Mit anderen Worten, du muss alle CSS Codes anpassen wie oben, und immer den 2ten zusätzlich für hover nehmen.

  • Kann mich entsinnen, dass der kleine Pfeil

    Wenn du ihn entfernen willst:


    CSS
    1. #wetterfuchs-toolbarbutton .toolbarbutton-menu-dropmarker {
    2. display: none !important;
    3. }

    Hallo,


    die Pfeile stören mich nicht unbedingt.

    Habe die Code von dir mal getestet - leider komme ich damit noch nicht weiter. Irgendwo hakt es noch.

    Was mir auffällt: bei Nightly und Beta werden bei mir die beiden *.css-Dateien im CSS-Ordner gespeichert , bei den 68er Profilen aber im CSSWeb-Ordner.

    Habe schon alles ausprobiert, leider ohne Erfolg. In meinem Hauptprofil wird bei gleicher Konfiguration nur der Wetterfuchsbutton angezeigt, bei Klick darauf immer noch das kleine Quadrat darunter.


    Ich glaube, es liegt daran, dass wir bei uns in Schleswig-Holstein anderes Wetter als in Niedersachsen haben! :)

  • CSSWeb-Ordner

    Das ist der falsche Unterordner. Da kommen nur Änderungen für Webseiten bzw. about Seiten rein.

    Das hatte ich immer berücksichtigt. Dann wird bei mir nur der Wetterfuchsbutton in der Tableiste angezeigt - ohne weitere Funktion (nur das kleine Quadrat).

    Habe es nur mal mit dem CSSWeb-Ordner getestet - damit habe ich zumindest die Untermenüs.

    Werde deine Eingabe aber berücksichtigen und deinen Code damit noch mal testen (nach meiner Gartenarbeit).

    Vorerst mal vielen Dank!

  • Werde deine Eingabe aber berücksichtigen und deinen Code damit noch mal testen (nach meiner Gartenarbeit).

    Vorerst mal vielen Dank!

    Bei 30 Grad im Schatten - läuft der Schweiß nach getaner Gartenarbeit, vor allen Dingen hier noch am Schreibtisch immer weiter.

    Aber das Schwitzen hat sich gelohnt.


    Nachdem ich aufgrund deiner Vorschläge alle Änderungen in der Wetterfuchs Button.css durchgeführt hatte, wurde aber nur Wetterdaten mit Icon als Untermenü gezeigt.


    Das machte mich stutzig - aber nachdem ich alle"-moz-binding: Zeilen" in "moz-appearance" geändert habe, wurde mir dieses Bild gezeigt:



    Das ist doch schon mal etwas. Nur beim Regionales Wetter hakt es noch:



    da fehlen mir noch drei Icon.

    Bin aber froh, dass ich diese Mammutaufgabe bis jetzt geschafft habe! :)

    Ich habe dir zu danken, wie immer!! :)

    Gruß,
    D. Büssen
    Firefox 68.0.1 (WIN 10 64 bit)

    Einmal editiert, zuletzt von Büssen () aus folgendem Grund: Nachbesserung

  • Vielleicht passen die dir ja...