Fx 68 Skript LoadingBar.uc.js

  • Bei mir funktioniert diese Version noch:


    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Hallo milupo, danke für Deine Rückmeldung!

    Bei Deinem Code handelt es sich um den langen schmalen Balken oben im Webfenster. Der funktioniert bei mir auch.

    Mein Code erzeugte ein farbliches Verlaufsmuster in der url-bar, bzw. zeigte es mir bis Version 67.0.4


    Als ich des Suchens müde war, erlernte ich das Finden (Friedrich Nietzsche)

  • Hallo Kerian, wahrscheinlich hatte ich eine ältere Version, denn der Dateiname ist gleich.


    Aber stimmt, deine Version funktioniert nicht und ich muss ehrlich sagen, ich bin nicht so bewandert in JavaScript. Da müssen wir wahrscheinlich auf aborix warten, er ist unser JavaScript-Spezialist.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Da müssen wir wahrscheinlich auf aborix warten, er ist unser JavaScript-Spezialist.

    Ok, dann warten wir mal auf aborix, vielleicht schaut er ja mal rein. Wenn nicht, werde ich nicht sterben, ein bischen Schwund ist halt immer :)

    Danke für Deine Mühe:thumbup:

    Als ich des Suchens müde war, erlernte ich das Finden (Friedrich Nietzsche)

  • seit dem Update auf 68.0 funktioniert bei mir das Skript LoadingBar.uc.js nicht mehr. Kann das jemand bestätigen?

    Ja läuft bei mir auch nicht mehr. Bin beim Suchen darauf gestoßen "Load Progress Bar" - "https://addons.mozilla.org/de/firefox/addon/load-progress-bar/". Ähnlich wie das was wir vorher hatten nur unterhalb meiner Lesen Zeichenleiste.


    Gruß hwww

  • Bei mir funktioniert sie nur noch beim öffnen/laden eines neuen Tab, nur reload bzw. laden einer neuen Seite im gleichen Tab geht nicht mehr.

    Vielleicht könnte die Info ja hilfreich für das anpassen sein ;)

  • In der Browser-Konsole kommt für Zeile 7:

    CSS
    1. background-image: -moz-repeating-linear-gradient(top -45deg, rgba(255,255,255,0), rgba(255,255,255,0) 6px, rgba(255,255,255,1) 6px, rgba(255,255,255,1) 12px), -moz-linear-gradient(left, rgba(255,255,255,0) 0%, rgba(17,238,238,.7) 100%);

    diese CSS-Meldung:


    Fehler beim Verarbeiten des Wertes für 'background-image'


    Das hängt möglicherweise damit zusammen:

    While we're keeping the prefixed versions of the various gradient properties (linear-gradient(), radial-gradient(), and repeating-radial-gradient() available for compatibility reasons, we have revised how they're parsed so that they're handled much more like the non-prefixed versions. This means that certain existing styles won't work correctly.


    In particular, the complicated syntax taking both an angle and a position will no longer work, and the to keyword in the <side-or-corner> parameter is not required for the prefixed gradient properties. You are encouraged to use the standard, non-prefixed gradient properties instead, as they're now widely supported (bug 1547939).

    Weiß jemand, was zu ändern ist?

  • 1. Erst einmal alle -moz-Präfixes entfernen, die da bereits seit fast sieben Jahren (!) nichts mehr zu suchen haben.


    2. Die Standard-Syntax sieht ein to-Schlüsselwort bei Richtungsangaben vor. Achtung: Die Richtung ist bei der Standard-Syntax genau entgegengesetzt. Das heißt, aus einem left beispielsweise wird to right.


    3. Wo sowohl eine Richtung als auch ein Winkel angegeben ist, nur den Winkel verwenden.


    Ergibt:


    CSS
    1. background-image: repeating-linear-gradient(-45deg, rgba(255,255,255,0), rgba(255,255,255,0) 6px, rgba(255,255,255,1) 6px, rgba(255,255,255,1) 12px), linear-gradient(to right, rgba(255,255,255,0) 0%, rgba(17,238,238,.7) 100%);


    Das Ergebnis sieht exakt identisch zur alten Syntax aus. Getestet mit Firefox ESR 60 und Firefox Nightly 70.

  • @ aborix und Sören!

    Funktioniert auch wieder mit Fx 68.0!

    Superklasse, vielen Dank euch beiden :thumbup:

    Als ich des Suchens müde war, erlernte ich das Finden (Friedrich Nietzsche)

  • Ich kenne das Skript nicht weiter, bei mir funktioniert es nur beim Start von Firefox, nicht beim Laden irgendeiner Seite. Ist das so gewollt?

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • milupo

    Bei mir funktioniert es wieder beim laden von allen Seiten, allerdings nur in einem neuen Tab. Beim reload oder laden von Seiten im selben Tab geht es nicht, hatte ja auch Andredd1 schon geschrieben. Wobei ich mich gerade frage wieso es bei ihm noch funktionierte?

    Da ich aber jede Seite in einem neuen Tab lade ist diese Version für mich perfekt.

    Für alle Interessierten hier nochmal der komplette Code, die Farben und das Verlaufsmuster kann man sich in Zeile 7 anpassen.

    Als ich des Suchens müde war, erlernte ich das Finden (Friedrich Nietzsche)

  • Danke, Kerian. Ja, ich kann bestätigen, dass das Skript beim Laden in einem neuen Tab ebenfalls funktioniert.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Nur als Anmerkung:

    1. Erst einmal alle -moz-Präfixes entfernen, die da bereits seit fast sieben Jahren (!) nichts mehr zu suchen haben.

    Ich benutze dieses Skript seit Jahren (und davor ein entsprechendes Addon). Bei irgendeinem Update des Firefox, das noch gar nicht so ewig lange her sein kann (müsste eigentlich bei der Umstellung auf Fx57 gewesen sein), hatte ich mal probiert, den CSS-Teil im Skript umzustellen, aber damals wollte es nicht so richtig funktionieren (wie genau, weiß ich nicht mehr) und habe deshalb die alte Version wieder aktiviert. Auf jeden Fall habe ich mir das Skript damals wegen möglicher Konflikte mit der Adressleistenfärbung angesehen, vgl. Adressleiste per CSS entsprechend Sicherheitsstatus einfärben.

  • Die Sache mit den Verläufen ist halt, dass es eben nicht reicht, nur das Präfix zu entfernen. Die Syntax ist unterschiedlich und muss entsprechend angepasst werden, wenn man das -moz- entfernt.

    Du darfst mir glauben, dass ich das getan hatte. Weil es nicht funktionierte, hatte ich das sogar noch einmal kontrolliert. Einen Fehler kann ich natürlich trotzdem nicht hundertprozentig ausschließen.