Seit dem letzten Update Problem mit close-Event

  • Firefox-Version
    94.0.2 (64-Bit)
    Betriebssystem
    Windows 10

    Hallo,


    auf einer Webseite nutze ich eine Bildergalerie. Das Bild wird in der Lightbox mit einen Close-Button geschlossen.

    Dahinter steht ein ganz normales Close () JS-Event.

    Wird das Close-Event per Klick ausgeführt schließt sich das Modalfenster mit dem Bild.


    Anders als vorher werde ich neuerdings auf die Seite in der Webseite weitergeleitet, die ich vor der Seite mit der Bildergalerie besucht habe, zurück geleitet.

    Es muss also etwas mit der "history" Event geben.

    Da dieses Problem nach mehreren Tests nur im FF und in keinen anderen Browser auftritt, liegt es für mich sehr nahe, dass es ein Bug im Firefox gibt.


    Eventuell wird der Bug mit dem nächsten Update behoben?


    Viele Grüße

    Pleppolino

  • ok

    Schmetterlinge in Brandenburg und Berlin - Home


    dann oben im Menü auf "Arten & Verbreitung" klicken.


    Wähle oben rechts eine Art aus, die ein Bild hat. Mit Klick auf dem blauen Button wird man zur Bildergalerie nach unten geleitet. Dann auf ein Bild klicken. Das Bild mit dem Close-Button schließen.

    Anstatt nur das Bild geschlossen wird, wird man unweigerlich auf die Homeseite geleitet, was das Problem ist.

  • Also unter Firefox Nightly für Android klappt es ohne Probleme. Habe mir mal den Kleinen Fuchs rausgesucht (haben gerade einen bei uns im Treppenhaus der dort überwintert :)) und die Bilder dazu angeschaut. Diese jeweils mit dem Kreuz geschlossen und immer auf der Seite des Kleinen Fuchs geblieben.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Stable Release Channel (pending) und ESR 102.3.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Klappt bei mir auch am Desktop in Firefox 94.0.2 einwandfrei.


    Teste im Fehlerbehebungsmodus von Firefox:

    Probleme analysieren im Fehlerbehebungsmodus von Firefox | Hilfe zu Firefox


    (Hier hätte man auch einiges an Klickaufwand ersparen können. Die Seite "Arten & Verbreitung" kann direkt verlinkt werden und dann wäre ein Beispiel gut gewesen, wo es denn Lightboxen gibt. Ich musste erst ein halbes Dutzend Arten ausprobieren, bis ich das erste Mal eine Lightbox zu Gesicht bekam. Ich war schon kurz davor, aufzugeben. ;) )

  • Ich habe mir Abrostola triplasia - Dunkelgraue Nessel-Höckereule herausgesucht. Beide vorhandenen Bilder angeklickt und wieder per Schließen-Kreuz geschlossen. Und bin zurück auf der gleichen Seite.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • Vielen Dank für eure schnelle kompetente Hilfe und die Tests!


    Sören: Ich habe die Seite "Arten & Verbreitung" mit Absicht nicht direkt verlinkt, denn so hätte man das Problem mit der "history" im JS nicht simulieren können.


    Unabhängig davon bin ich dem Vorschlag gefolgt und habe den FF im Fehlermodus gestartet und anschließend auf die Standardeinstellungen zurückgesetzt. Hätte ich mal selbst drauf kommen sollen. ;)

    Das von mir beschriebene Problem hatten aber auch noch andere User, die mich deshalb benachrichtigt hatten. Die werde ich über die Möglichkeit der Fehler-Behebung informieren.


    Viele Grüße

    F.

  • Bei mir ist/war die Ursache

    "fission.autostart", true


    Ich habe meine prefs im Testprofil genutzt und solange reduziert, bis ich es darauf eingrenzen konnte.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Bei mir ist/war die Ursache

    "fission.autostart", true

    Trifft für mich auch zu.

    Da das aber zur Sicherheit beiträgt (jedenfalls lt. Mozilla), wenn Fission aktiviert ist, lasse ich es auf "true" stehen.

    Oder spricht etwas dagegen?

    Gruß
    dbpdw


    Ubuntu 21.10, Fx snap 99.0.1

  • Hat keinerlei Auswirkungen hier, Fission läuft hier, sehe ich im Taskmanager sehen, dass es mehr als 8 Sub-Prozesse (childs) hat. Auch wenn es hier anders steht:


    6 Tabs und 10 Childs. (-childID 1 bis 9, ein -parentBuildID und dann noch den Mutterprozesse)

    Und ich habe keinerlei Auswahl mehr, was die Leistung und Prozesse angeht.


    Mein anderes Profil für die Recherche hat diesen Eintrag nicht und da werden etliche Subs mehr angezeigt (bei teils > 200 Tabs)

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Oder spricht etwas dagegen?


    Dagegen, Fission aktiviert zu lassen, spricht nichts, solange du von keinen Problemen betroffen bist, ganz im Gegenteil. Wie du selbst sagst, trägt das zur Sicherheit bei. Und bald wird Fission für alle Nutzer aktiv sein und damit die einzige von Mozilla offiziell unterstützte Konfiguration sein.


    Der einzig zielführende Weg hier ist, ein Problem an Mozilla zu melden, so dass das behoben werden kann, ehe es nur noch Firefox mit Fission gibt.


    Auch wenn es hier anders steht:


    Was genau soll da anders stehen?

  • Das

    Zitat
    Q:

    Ich nehme an, dass immer noch fission.autostart die relevante Einstellung für Fission ist. Oder muss ich noch andere Einstellungen vornehmen, um Fission zu aktivieren / optimieren?

    Zitat

    A:

    Nur diesen Schalter - und Firefox anschließend neu starten.

    Wie gesagt, in meinem anderen Profil gibt es diesen Schalter nicht, und dennoch hab ich etliche Kindprozesse mehr, als die maximalen 8, die es vorher in den Einstellungen einzustellen gab. Deswegen muss ich davon ausgehen, dass fission aktiv ist, mit und ohne Schalter. Warum ausgerechnet jener Schalter die Fehlfunktion erzeugt auf der Webseite, keine Ahnung.


    Warum der Schalter hier überhaupt vorhanden war - Neugier.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Dagegen, Fission aktiviert zu lassen, spricht nichts, solange du von keinen Problemen betroffen bist, ganz im Gegenteil.

    Danke, dass wollte ich wissen. :thumbup:

    Bislang hatte es keine negativen Auswirkungen auf den von mir genutzten Seiten. Von daher bleibt es aktiviert.

    Gruß
    dbpdw


    Ubuntu 21.10, Fx snap 99.0.1

  • Dieser Schalter stand so in den prefs, und ich habe oben auch nur die prefs erwähnt, nie das about:config. Steht auch nicht in der user.js, daher muss ich den mal im about:config umgestellt haben und daher steht es auch in den prefs, Standardwert ist "false".


    Und trotzdem habe ich mehr Prozesse als ohne, deswegen stelle ich auch die Frage/Antwort in deiner Ankündigung in den Vordergrund.


    Was stimmt denn da nun, um fission (site isolation) nutzen zu können? Damit müssen praktisch ja mehr Prozesse laufen, aber das tut es ja auch ohne "fission.autostart" > true ja schon. Magst entschuldigen, für mich ist das ein und das selbe grad.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Dieser Schalter stand so in den prefs


    Ich hätte gedacht, dass du nach so vielen Jahren und Beiträgen weißt, was die Datei prefs.js macht, insbesondere da wir das Thema bereits hatten. Die Datei prefs.js ist keine Referenz dafür, welche Schalter existieren und welche nicht. Die Datei prefs.js bildet nur einen Teil aller Einstellungen ab. Wenn du schreibst, dass es einen Schalter gibt oder nicht gibt, ist dafür nicht die Datei prefs.js maßgeblich, sondern about:config.


    Und trotzdem habe ich mehr Prozesse als ohne, deswegen stelle ich auch die Frage/Antwort in deiner Ankündigung in den Vordergrund.


    Was stimmt denn da nun, um fission (site isolation) nutzen zu können?


    Ob Fission aktiviert ist oder nicht, siehst du via about:support. Was ich im anderen Thema schrieb, stimmt: Zur manuellen Aktivierung von Fission ist nur dieser eine Schalter relevant.


    Damit müssen praktisch ja mehr Prozesse laufen, aber das tut es ja auch ohne "fission.autostart" > true ja schon. Magst entschuldigen, für mich ist das ein und das selbe grad.


    Auch ohne Fission kann man Firefox mit vielen Prozessen nutzen. Die Anzahl der Prozesse sagt nicht aus, ob Fission aktiv ist oder nicht.

  • Nicht abschweifen bitte, oben steht prefs (prefs.js), nicht about:config, nicht mehr. Wenn du was anderes daraus schliesst, ist das deine Sache, und in dem Fall einfach nur falsch.


    aus dem about:support, jetzt, nicht von vorhin

    Zitat

    Fission-Fenster 0/1 Standardmäßig deaktiviert
    Fission (Seitenisolierung) (fission.autostart) false

    fission.autostart.session false

    Ergo inaktiv. Auch gut.


    Was ich neulich erst las, wegen der erhöhten Zahl der Prozesse:

    Zitat

    http://forums.mozillazine.org/….php?p=14911089#p14911089
    When Fission is enabled then you get more content processes and you can no longer limit these processes.

    Das ein gewisser corvl als dickvl auf mozillazine geschrieben hatte. (ist ein und dergleiche Benutzer)


    Was anderes macht(e) für mich keinen Sinn, die Anzahl der Prozesse so massiv zu erhöhen, solange Firefox stabil läuft in der jeweiligen Umgebung. Deswegen hatte ich diesen Zusammenhang gezogen und corvl/dickvl hat es ja auch so beschrieben.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?