Mit der heutigen Nightly funktionieren viele Codes und Scripts nicht mehr

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Ziemlich präzise. Dennoch die Frage, um welche geht es?

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Meine Codes funktionieren ebenfalls.

    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:95.0) Gecko/20100101 Firefox/95.0a1 , Windows 11 Pro Version 21H2 (Build 22000.282)

  • Tja, was soll ich sagen.... Das Script für die Statusleiste funktioniert nicht... der CSS-Code für das Forum ebenfalls nicht...

    Die Tabs unter der URL-Bar hingegen funktioniert.. ebenso die Uhr in der Nav-Bar..

  • Dieses Script funktioniert nicht, vor allem ist kein Button im Anpassen-Fenster, Sonst wurde dieser in der Status-Bar angezeigt...

  • Für das userCSSLoader-Skript kann ich das nicht bestätigen. Das funktioniert. Bisher kann ich nur für das Statusleisten-Skript bestätigen. Das funktioniert wirklich nicht mehr, die Symbole der dort abgelegten Skripte bzw. Add-ons sind im Anpassen-Fenster.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Man ersetze


    JavaScript
    document.getElementById('navigator-toolbox').parentNode.insertBefore


    durch


    JavaScript
    document.getElementById('navigator-toolbox').parentNode.parentNode.insertBefore


    siehe https://hg.mozilla.org/mozilla…al/rev/fa9ff3a262bc#l2.94 ff.


    Ist aber nicht für die Ewigkeit, da wird bald wieder eine Anpassung notwendig werden.

  • Danke Sören, funktioniert bestens.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Dann müsste ich meinen Chrome-Ordner komplett umbauen... (wüsste im Moment gar nicht, wie das geht... :|) Endor hat mir via Mail bestätigt, das bei ihm der Loader in einer neueren Version funktioniert... diese nutze ich nun..

  • Vielen Dank, die Scripte funktionieren nun wieder, aber alle CSS-Codes nicht, auch eine neuere Version für das UserCSSLoader Script bringt keine Änderung..:(

    Da muss bei dir etwas klemmen. Bei mir funktionierten außer dem Statusleisten-Skript gestern alle Skripte, bei Andreas auch. Du has von vielen geschrieben, die nicht mehr funktionierten, hast aber nur zwei angegeben und jetzt plötzlich funktionieren alle wieder. CSS-Codes hast du bisher überhaupt nicht genannt oder kannst du die nur nicht aufrufen, weil bei dir das userCSSLoader-Skript nicht funktioniert? Du musst schon etwas genauer werden, damit man dir helfen kann.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Also, nach der Korrektur aus Beitrag 8 sind die Scripte wieder aktiv, ausser anscheinend das CSS Loader Script...

    Kein CSS-Code funktioniert... der Hinweis, ob diese ohne LoaderScript funktionieren funktionieren, müsste ich ausprobieren, benötige dazu aber nochmal einen Hinweis, wie die CSS-Codes ohne Loader im Chrome-Ordner einzusortieren und aufzurufen sind... Ich habe z.B. keine userContent.css Datei mehr, da der Loader auch die css-Codes, die sich mit Firefox beschäftigen (zum Beispiel zur Gestaltung des AddonsManagers), direkt einbinden...

  • Kein CSS-Code funktioniert... der Hinweis, ob diese ohne LoaderScript funktionieren funktionieren, müsste ich ausprobieren, benötige dazu aber nochmal einen Hinweis, wie die CSS-Codes ohne Loader im Chrome-Ordner einzusortieren und aufzurufen sind... Ich habe z.B. keine userContent.css Datei mehr, da der Loader auch die css-Codes, die sich mit Firefox beschäftigen (zum Beispiel zur Gestaltung des AddonsManagers), direkt einbinden...

    Aber, aber ... ;) Du musst doch aber trotzdem die CSS-Dateien haben. Ich weiß nicht, wo du sie hast, in einem Ordner CSS nehme ich mal an. Denn das Skript muss die Dateien ja von irgendwo her einlesen. Such dir eine CSS-Datei aus und schreibe sie in die userChrome.css, wenn der Code die Firefox-Oberfläche verändert oder in die userContent.css, wenn der Code eine Webseite verändert, also z. B. hier im Forum. Und dann schreibst du:


    CSS
    @import "CSS/datei.css";

    Für datei.css musst du natürlich den Namen deiner Testdatei angeben. Wenn du die CSS-Dateien wie die Skripte auch alle direkt im Ordner chrome hast, dann schreibst du eben nur den Dateinamen:


    CSS
    @import "datei.css";

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

    2 Mal editiert, zuletzt von milupo () aus folgendem Grund: Korrektur: Ein Anführungszeichen im ersten Code-Kasten vergessen.

  • Also, die Skriptversion aus Beitrag #14 bringe ich momentan nicht zum Laufen. Bei mir funktioniert dieses Version:


    In Zeile 51 ist der Pfad zum von mir verwendeten Dateimanager eingetragen.


    Standardmäßig sollten wenigsten die Buchstaben CSS in der Symbolleiste erscheinen. Ergänzend dazu lässt sich folgender CSS-Code für ein eigenes Symbol verwenden:


    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Also das hier ist die Scriptversion die ich Boersenfeger gesendet habe: