FireFox sperrt fast alle Websites

  • Hallo
    seit Sommer tauchen auf einem meiner Rechner (Win 7 Prof.) mehr und mehr Probleme bei der Nutzung mit Firefox auf (sowohl frühere als auch aktuelle Version). Vor kurzem wurde es dann so schlimm, dass ich erst auf Chrome umgestiegen bin und dann auf Opera - einfach, um halbwegs weiterarbeiten zu können.


    Wichtig: Alles, was ich im Folgenden schildere, gilt nur für meinen (Haupt-Arbeits-)Rechner in meinem privaten Netzwerk. Auf allen anderen PCs / Notebooks läuft alles wunderbar.


    Etwa seit Juli hat Firefox auf dem betreffenden PC angefangen, den Zugriff auf bestimmte Websites zu sperren, meist mit dem Hinweis:


    "Diese Verbindung ist nicht sicher. Der Inhaber von blablabla.com hat die Website nicht richtig konfiguriert. Firefox hat keine Verbindung mit dieser Website aufgebaut, um Ihre Informationen vor Diebstahl zu schützen."

    Über die nächsten Wochen wurden es gefühlt immer mehr Seiten, auf die ich nicht mehr zugreifen konnte. (Unter anderem auch mozilla.org :-?? ) Das hat schließlich so genervt, dass ich die in Firefox enthaltene Funktion genutzt habe, den Browser zurückzusetzen - eine ganz dumme Idee, denn danach hat Firefox nahezu jeden Zugriff auf jede Seite verweigert. Eine komplette De- und Neuinstallation von FF (mit zwischenzeitlichem Neustart) hat auch nichts gebracht.
    Interessanterweise gingen bei Stichproben ein paar wenige Websites aus meinen gespeicherten Lesezeichen dennoch aufzurufen, gefühlt etwa jede zwanzigste Adresse. Welcher Regel das folgt, ist für mich nicht ersichtlich.


    Ich bin dann irgendwann auf Google Chrome umgestiegen. Aber selbst da gehen nicht alle Seiten aufzurufen (die meisten aber schon) und werden mit einem ähnlichen Hinweis gesperrt. In Opera funktioniert zwar (fast) alles. Aber ich hätte gerne mein FF zurück, erstens bin ich das seit Jahren gewöhnt und außerdem fehlen mir meine ganzen schönen Add-Ons für FF, die ich mir über die Jahre zugelegt hatte.


    Ich hatte zwischenzeitlich auch mal die Sicherheiteinstellungen der FritzBox im Verdacht. Aber dann dürften doch die anderen Rechner nicht reibungslos laufen? Die gehen ja über denselben Router (sowohl LAN als auch WLAN).


    Irgendwann kam mir mal der Geistesblitz, Windows im abgesicherten Modus zu starten. Und siehe da: Alles läuft reibungslos, sowohl in FF als auch in Chrome. Keine Fehlermeldungen mehr, alle (!) Seiten werden anstandslos aufgerufen. (Aber das ist natürlich auch keine dauerhafte Lösung. :roll: )
    Ist es also doch was in den Windows-Einstellungen (z.B. Firewall)? Aber warum kann dann Chrome auf die meisten Seiten zugreifen, die FF verweigert?


    Also, wann jemand 'ne Idee hat... da wär' ich echt dankbar, denn so ist derzeit das Arbeiten doch recht umständlich.


    Vielen Dank im Voraus!

    PC 1: Wortmann Terra PC 6000 mit Win 7 Prof.; Intel i5; 12 GB RAM
    PC 2: Wortmann Terra Notebook mit Win 7 Pro, Intel i7; 8 GB RAM
    PC 3: Wortmann Terra Business 7100 mit Win 8.1 Pro; Intel i7; 16 GB RAM


  • Ist es also doch was in den Windows-Einstellungen (z.B. Firewall)?


    Nein, das Problem wird mit höchster Wahrscheinlichkeit von deiner Sicherheitssoftware/Antivirensuite verursacht bzw. genauer gesagt dessen SSL/HTTPS-Scanning Feature (=auch Untersuchung sicherer Verbindung genannt). Über dieses Problem wird in diesem Forum gefühlt fast täglich berichtet, und immer wieder sind Sicherheitssuiten/Antivirensoftware bzw. dessen SSL/HTTPS-Scanning Funktion dafür verantwortlich.
    Dass bei dir unter dem abgesicherten Modus alles problemlos funktioniert, ist ein weiteres starkes Indiz, dass es tatsächlich an deiner verwendeten Sicherheitssoftware liegt, denn diese wird im abgesicherten Modus nicht geladen.


    Aus diesem Grunde würde ich bei deiner Sicherheitssoftware einmal in dessen Einstellungen nach dem Feature SSL/HTTP Scanning/Untersuchung sicherer Verbindungen Ausschau halten und dieses dauerhaft deaktivieren, da es ohnehin nur solche Probleme verursacht und dabei noch die Sicherheit senkt als sie zu steigern.

  • Hallo,
    danke für die superschnelle Antwort! - Ich bin mal meine Programmliste durchgegangen - wenn ich das richtig sehe, läuft als Echtzeitschutz bei mir nur das Windwos Security Essentials. In dessen Einstellungen konnte ich die von dir beschriebenen Parameter aber nicht finden.
    Als weitere Security-Software habe ich nur noch den "Trojan Remover" installiert. Den starte ich aber immer manuell; also dürfte der doch gar nicht im Hintergrund unbemerkt irgendwas blockieren...? Zudem gab es auch beim TR keine Einstellmöglichkeit für die oben genannten Parameter.
    Oder hab ich vielleicht irgendwo was übersehen? :-???

    PC 1: Wortmann Terra PC 6000 mit Win 7 Prof.; Intel i5; 12 GB RAM
    PC 2: Wortmann Terra Notebook mit Win 7 Pro, Intel i7; 8 GB RAM
    PC 3: Wortmann Terra Business 7100 mit Win 8.1 Pro; Intel i7; 16 GB RAM

  • gehe mal bitte auf mozilla.org und wenn diese gesperrt ist, dann klicke auf den blauen SEC_ERROR_UNKNOWN_ISSUER Fehlercode, dann auf den Button um den gesamten Text zu kopieren und füge das in die nächste Antwort als Code hier ins Forum ein - Hoffentlich gibt das dann Aufschluss darüber, was schief läuft...


    Außerdem: Gib uns bitte mehr Infos über deinen Firefox und zwar folgendermaßen:
    ●☰ ➜ (?) Hilfe ➜ Informationen zur Fehlerbehebung
    ● jetzt die Schaltfläche "Text in die Zwischenablage kopieren" anklicken
    ● jetzt den kopierten Text aus der Zwischenablage als Code hier ins Forum einfügen. siehe dazu

    Hilfe auch im deutschsprachigen Firefox-Chat möglich.
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • gehe mal bitte auf mozilla.org und wenn diese gesperrt ist, dann klicke auf den blauen SEC_ERROR_UNKNOWN_ISSUER Fehlercode


    Öhm... meinst du das da (Screenshot)?


    https://www.dropbox.com/s/ny9h…11-21%2012.51.35.png?dl=0


    Wenn ich dann auf den blauen Fehlercode mit dem Titel "MOZILLA_PKIX_ERROR_MITM_DETECTED" gehe, dann kommt als nächstes dieser Code:



    Soweit zum ersten Code.


    Der zweite, um den du gebeten hattest, liest sich so:




    Ich hoffe, ich hab alles richtig gemacht... Für mich sind das alles böhmische Dörfer, aber vielleicht entdeckt ihr ja das Problem - wäre super!


    Danke schon mal für alle Unterstützung!


    Edit 2002Andreas
    Text in Klammercode gesetzt.

    PC 1: Wortmann Terra PC 6000 mit Win 7 Prof.; Intel i5; 12 GB RAM
    PC 2: Wortmann Terra Notebook mit Win 7 Pro, Intel i7; 8 GB RAM
    PC 3: Wortmann Terra Business 7100 mit Win 8.1 Pro; Intel i7; 16 GB RAM

  • Code
    1. Ihre Verbindung wird durch einen TLS-Proxy kontrolliert

    und woher kommt der? Das kannst nur du beantworten, durch welche Software dies hervorgerufen wird, oder wie deine Verbindung zum Internet aufgebaut wird. Ist die Verbindung möglicherweise Teil eines Unernehmennetzwerks?

    Hilfe auch im deutschsprachigen Firefox-Chat möglich.
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • Fehlercode mit dem Titel "MOZILLA_PKIX_ERROR_MITM_DETECTED"
    Ihre Verbindung wird durch einen TLS-Proxy kontrolliert. Deinstallieren Sie diesen falls möglich oder richten Sie Ihr Gerät so ein, dass es dem Stammzertifikat des TLS-Proxies vertraut.


    security.pki.mitm_canary_issuer: CN=WebFilter Certificate 2,C=EN


    Sowohl die ausgegebene Fehlermeldung, sowie die Daten von "Informationen zur Fehlerbehebung" bestätigen ganz klar meine anfängliche Vermutung, dass auf deinem PC eine Software eingesetzt wird, welche SSL/HTTPS bzw. gesicherte Verbindungen untersucht/aufbricht.


    Um welche Software es sich dabei genau handelt, kann ich leider auch nicht sagen, da anscheinend "WebFilter Certificate 2" von verschiedenen Sicherheitssoftwares eingesetzt wird.
    Aus diesem Grund wirst du selber nachforschen müssen, welche Software genau bei dir am laufen ist die gesicherte Verbindungen untersucht.

  • Hattest du ggf. mal eine Sicherheitssoftware installiert und diese nicht nach Herstelleranleitung entfernt oder gar etwas von ZoneAlarm etc. installiert?

  • GraKa-Treiber wie vorgeschlagen aktualisiert.
    Aktuelle FF-Version aufgespielt.
    Allen Spuren ehemaliger Sicherheitssoftware verfolgt und (soweit für mich ersichtlich) aufgeräumt.


    Ohne Erfolg.


    Dann plötzlich, gestern: Ohne ersichtlichen Grund (ehrlich, ich hab nichts gemacht...!) funktioniert FF wieder - lädt allerdings nur etwa 90% aller Websites. Beim Rest verweigert es immer noch den Dienst.


    Soweit, so gut - FF läuft, aber ich weiß halt nicht, warum eigentlich. Und nachdem es immer noch nicht alle websites lädt und es ja schon mal ohne ersichtlichen Grund in den Generalstreik getreten ist (genau so wie es nun ohne ersichtlichen Grund wieder zur Arbeit erschienen ist, wenn auch mit leicht verringertem Arbeitseifer), werde ich demnächst voraussichtlich mal meinen PC komplett neu aufsetzen. Das ist vermutlich die einzige Lösung, damit ich da wieder Ruhe habe.


    Dem Vorschlag der Überprüfung, ob "auf deinem PC eine Software eingesetzt wird, welche SSL/HTTPS bzw. gesicherte Verbindungen untersucht/aufbricht" konnte ich nicht nachkommen - sorry, aber da muss ich leider die Segel streichen. Soweit reicht meine PC-Kompetenz nicht, ich weiß leider gar nicht, was da zu tun wäre... :oops:


    Trotzdem vielen Dank für eure Hilfe und für alles Mitdenken!

    PC 1: Wortmann Terra PC 6000 mit Win 7 Prof.; Intel i5; 12 GB RAM
    PC 2: Wortmann Terra Notebook mit Win 7 Pro, Intel i7; 8 GB RAM
    PC 3: Wortmann Terra Business 7100 mit Win 8.1 Pro; Intel i7; 16 GB RAM


  • Dem Vorschlag der Überprüfung, ob "auf deinem PC eine Software eingesetzt wird, welche SSL/HTTPS bzw. gesicherte Verbindungen untersucht/aufbricht" konnte ich nicht nachkommen - sorry, aber da muss ich leider die Segel streichen. Soweit reicht meine PC-Kompetenz nicht, ich weiß leider gar nicht, was da zu tun wäre... :oops:


    Hallo :)


    versuche es mit dem Ausführen eines sauberen Neustarts in Windows. Wie sieht es anschließend aus?



    Trotzdem vielen Dank für eure Hilfe und für alles Mitdenken!


    Bitte und HTH
    Gruß Ingo

  • Moin,


    hast du Proxy Server ?
    Hier ist Screenshot von deine Zertifikat:
    WebFilter Certificate 2 Root CA hat mozilla.org Zertifikat erstellt, aber Originale mozilla.org Zertifikat ist von DigiCert.

    Code
    1. https://picload.org/view/dclrwwci/zert.png.html


    Wenn du nicht mit Internet Explorer (IE) Probleme hast, öffne mal Windows Zertifikat Store, such und export "WebFilter Certificate 2" Root Zertifikat, dann in Firefox importieren.

  • Um Schadware auszuschließen:
    Benutze AdwCleaner
    Poste den Inhalt des Logfiles in der Klammer CODE in deiner nächsten Antwort.


    Klicke nun noch im Firefox auf Hilfe :arrow: Informationen zur Fehlerbehebung :arrow: Firefox bereinigen
    Dies wird Firefox auf die Standardeinstellungen zurücksetzen. Deine Lesezeichen und Passwörter gehen dabei nicht verloren. Die bisherigen Erweiterungen musst du allerdings neu installieren. Nach dem Zurücksetzen werden die alten Profildaten in einem Ordner namens „Alte Firefox Daten“ auf dem Desktop abgelegt. Wenn das Zurücksetzen das Problem nicht behebt, können einige der Daten, die nicht ins neue Profil übernommen wurden, von dort in das neue Profil kopiert werden. Wenn der Ordner nicht mehr benötigt wird, sollte man diesen löschen, da sensible Daten darin enthalten sind.


    Damit dir dies nicht wieder passiert, lade Software nur beim jeweiligen Hersteller.

    Zitat von 2002Andreas

    Und bitte nie wieder etwas von der Seite Softonic downloaden :!:


    Installiere dann benutzerdefiniert, hierbei genau lesen, dann kannst du Mitbringsel (Toolbars, Startseiten-HiJacking etc. etc) oder geänderte Einstellungen in der Regel abwählen... Vielleicht auch noch interessant: Sicherheitskonzept für Windowsnutzer


    Mache zur Überprüfung einen Scan mit Malwarebytes
    Anleitung

  • Falls jemand als Sicherheitssoftware Bitdefender verwendet: ich habe jetzt vom Bitdefender-Support die Lösung erhalten :lol: :


    1. Bitte öffnen Sie Firefox
    2. Klicken Sie auf das Menü und wählen Sie Einstellungen aus
    3. Klicken Sie auf Datenschutz & Sicherheit
    4. Wählen Sie die Option Zertifikate anzeigen



    Entfernen Sie erstmal das vorhandene Bitdefender Zertifikat, indem Sie die Option "Löschen oder Vertauen entziehen..." anklicken. Starten Sie den Browser neu und begeben Sie sich erneut unter Einstellungen - Zertifikate anzeigen.


    5. Begeben Sie sich unter Vertrauenswürdige Zertifizierungsstellen und klicken Sie auf Importieren
    6. Suchen Sie den folgenden Ordner durch: C:\Programme\Bitdefender\Bitdefender Security\mitm_cache
    7. Wählen Sie die Datei fake-ca.crt aus und klicken Sie auf Öffnen.
    8. Im neuen Fenster haken Sie alle 2 Kästchen an und klicken Sie auf OK und nochmals auf OK.


    9. Starten Sie Firefox neu und öffnen Sie die gewünschte Webseite.



    Danach hat es bei mir wieder funktioniert.

  • Die wirklich sinnvolle Lösung wäre allerdings diesen Unsinn von SSL-Scanning zu deaktivieren
    siehe:

    Macht die Verbindung dann auch sicherer (aber das wollen die AV Hersteller halt ungern zugeben)

    Hilfe auch im deutschsprachigen Firefox-Chat möglich.
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • Die wirklich sinnvolle Lösung wäre allerdings diesen Unsinn von SSL-Scanning zu deaktivieren
    siehe:

    Macht die Verbindung dann auch sicherer (aber das wollen die AV Hersteller halt ungern zugeben)


    Ist das in Bitdefender 2019 der verschlüsselte Webscan? Hatte ich auch mit Erfolg ausprobiert, aber wieso ist das sicherer?

  • Aus dem ganz einfachen Grund, dass Browser wie Firefox und Chrome einem extrem hohen Sicherheits-Standard folgen. Was diese Funktion deiner "Sicherheits"-Software macht, ist ein Man-in-the-Middle-Angriff auf deine Verbindung, ganz im Stile einer Schadsoftware. Die Motivation, nämlich deine Verbindung zu prüfen und dich damit zu schützen, mag noch so nobel sein, du gewinnst dadurch nichts. Es ist eben ein Feature, welches erst einmal toll klingt und damit Geld in die Kassen des Herstellers spült.


    Natürlich bist du in der Tat ganz besonders sicher unterwegs, wenn du durch diese Funktion gar keine Webseite mehr aufrufen kannst, aber das ist ja nicht Sinn und Zweck davon.

  • Mir ist das jetzt auch passiert - AAABER:
    - Zu dieser Site hate ich in der Sperr-Meldung die Option das 'nicht-vertrauenswürdige Zerti akzeptieren! So konnte ich hierher und das mit Bitdefender lesen, den ich seit gestern habe.
    - Auf Sites, die ich über ein anderes Profil (fast keine AddOns, so gewünscht) lade fehlt diese Option komplett?? Wie kann ich deren Zertis akzeptieren - immerhin arbeite ich mit mit denen über diese Sites?
    - Ich habe auch das Bitdefender-Workaround gemacht - keine Verbesserung ??

    Ceterum censeo fenestras X non esse ad rem accommodatas