Beiträge von macko

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    Ich habe hier "Scroll Zoom" und damit geht's halt scheinbar nicht.

    Das wäre noch wichtig zu erwähnen gewesen, dass du eine Erweiterung nutzt, mit welcher man mittels gedrückter rechter oder linker Maustaste + Mausrad zoomen kann.

    Denn der von mir beschriebene about:config Eintrag wird nur dann einen Einfluss haben, wenn man mittels Steurungstaste + Mausrad zoomt. Aus diesem Grund hätte es auch gar nicht funktionieren können in Kombination mit deiner Erweiterung "Scroll Zoom".


    Wenn du aber gerne in deiner Erweiterung "Scroll Zoom" ein invertiertes Zoom-Verhalten möchtest, dann müsste man dafür eine kleine Änderung innerhalb des Quellcodes der Erweiterung tätigen.

    Da ich gesehen habe, dass die benötigte Änderung relativ trivial ist (ein Grösser-als-Zeichen mit einem Kleiner-als-Zeichen innerhalb des Quellcodes austauschen), war ich einmal so frei, und habe dir kurz die Erweiterung modifiziert sowie neu signieren lassen, und die xpi-Datei der Erweiterung auf Workupload hochgeladen.


    Du kannst die modifizierte Erweiterung (.xpi Datei) hier runterladen ➡ https://workupload.com/file/Km4E5xWe


    Installieren kannst du die Erweiterung wenn du innerhalb der Add-ons-Verwaltung auf die Zahnradschaltfläche gehst, und dann dort auf "Add-on aus Datei installieren" klickst ➡ dann die heruntergeladene scroll_zoom_inverted_zoom-0.4.0-fx.xpi auswählen. Vorher bitte noch die "originale Scroll Zoom" Erweiterung deaktivieren/deinstallieren, da du ansonsten zweimal die gleiche Erweiterung aktiv hättest.

    Hmm, seltsam.

    Der von mir beschriebene about:config Eintrag zeitigt bei mir genau den von dir gewünschten Effekt, nämlich dass beim Scrollen mit gehaltener Steuerungstaste die Zoomrichtung invertiert ist. (hab dies extra noch einmal in mehreren Firefox-Profilen nachgetestet.)

    Aus diesem Grund kann ich dir jetzt nicht genau sagen, wieso dass bei dir nicht zu funktionieren scheint.


    Vielleicht versuchst du das gleiche noch einmal testweise unter einem frischen Firefox-Profil, um so etwaige Fehlerquellen auzuschliessen.


    Wird FF neu gestartet ist alles wieder weg.


    Hat einer eine Idee?


    Vergewissere dich bitte, ob du nicht zufälligerweise unter den Firefox-Einstellungen eingestellt hast, dass die Firefox-Chronik bzw. ganz spezifisch die Website-Einstellungen beim Beenden von Firefox automatisch gelöscht werden -> siehe Screenshot. [attachment=0]firefox_2019-03-20_01-07-36.png[/attachment]
    Sollte dies bei dir nicht der Fall sein, dann könnten auch allfällig verwendete Bereinigungsprogramme wie beispielsweise CCleaner dafür verantwortlich sein, soweit denn diese bei dir automatisch den Firefox bereinigen.

    Da sich die von der Erweiterung hinzugefügten "Livemarks" wie ein normaler Lesezeichenordner verhält, kannst du daher einfach einen neuen Lesezeichenordner erstellen, und dann deine erstellten "Livemarks" dorthin verschieben lassen. Beispielsweise könntest du alle deine Kommentare-Livemarks in den Lesezeichenordner namens Kommentare verschieben, soweit denn dies die gewünschte Intention ist.
    Auch wäre es möglich innerhalb der erstellten "Livemarks"-Ordner nochmals neue Ordner zu erstellen usw.


    mit dem heutigen Update auf Version 66 funktioniert nun leider die mehrzeilige Tableiste nicht mehr.


    Die Skripte von folgender Seite funktionieren unter Firefox 66 damit die Tableiste mehrzeilig angezeigt wird:
    https://github.com/Endor8/user…er/Mutirowtabs/Firefox-66
    Auch funktioniert dieser CSS-Code von Aris für die userChrome.css, auch wenn dort, im Gegensatz zum Skript, dann Drag-and-Drop der Tabs nicht richtig funktioniert: ► https://github.com/Aris-t2/Cus…abs_multiple_lines_v2.css


    Es scheint, als ob jedes FF Update die mühsam erarbeiteten Einstellungen zerlegt


    Das war schon immer so. Für inoffizielle Anpassungen gibt es seitens Mozilla nämlich keinen Support, weswegen es relativ normal ist, dass man hin und wieder bei einem Update seine CSS-Codes/Skripts anpassen muss.


    nur kann ich eben nun nich mehr die angezeigte Liste scrollen.


    Ersetze in diesem Fall noch folgende Regel in deiner userChrome.css:

    CSS
    #PopupAutoCompleteRichResult .autocomplete-richlistbox > scrollbox {overflow-y: auto !important;}


    mit folgendem CSS-Code:

    CSS
    #PopupAutoCompleteRichResult .autocomplete-richlistbox{overflow-y: auto !important;}


    Danach sollte die Autovervollständigungsliste wieder scrollbar sein.



    browser.urlbar.maxRichResults ist 80 bei mir angezeigt.


    Das hatte ich mir auch gedacht, da ich es ja persönlich auch so handhabe, dass ich mir eine deutlich höhere Anzahl an Resultaten in der Url-Autovervollständigungsliste anzeigen lasse.


    Seit Firefox 66 geht bei mir nun die angepassten Seitenauflistung immer bis ganz runter bis zum Bildschirmende statt auf Maximale Höhe von 555px.


    Ersetze einmal folgende Regel in deiner userChrome.css:

    CSS
    #PopupAutoCompleteRichResult .autocomplete-richlistbox {max-height: 555px; background: #FFFFFF !important;}


    mit folgendem CSS-Code:

    CSS
    panel[type="autocomplete-richlistbox"] {max-height: 555px !important; background: #FFF !important;}



    Sieht hier so aus damit


    Das beschriebene Problem von Mr. Cutty tritt auch nur auf, wenn man unter dem Schalter browser.urlbar.maxRichResults einen deutlich höheren Wert als den Standardwert 10 eingestellt hat, und dabei auch genügend Resultate zum anzeigen vorhanden sind.


    Nach dem neuesten Update funktioniert das Drop-Down-Menü nicht mehr richtig;


    Kann ich persönlich nicht bestätigen, denn bei mir funktioniert es auch unter der neusten Nightly-Version weiterhin wie bisher. (mit der Methode aus Beitrag #6)
    Aus diesem Grund sollte es eigentlich auch in deinem Falle weiterhin richtig funktionieren.
    Testweise kannst du ja versuchen den Skriptcache von Firefox zu löschen, oder es schnell unter einem neuen Testprofil probieren, um so etwaige Fehlerquellen auszuschliessen.


    Also der Scrollbalken kommt nur wenn man mit der Maus darüber fährt und der ist mir zu Dick, zu Breit ist nur bei Firefox so.


    Wenn es nur darum geht die Dicke der Scrollbalken auf YouTube zu verkleinern, dann liesse sich dies anstelle des Skripts auch einfach mittels einer userContent.css realisieren. Beispielsweise mit folgendem CSS-Code könnte man die Scrollbalkenbreite auf YouTube anpassen:


    YouTube sähe dann mit diesem CSS-Code in etwa so aus:
    [attachment=0]firefox_2019-03-14_12-38-53.png[/attachment]


    bis auf den Download funktioniert es


    Falls du den Download-Icon mit einem eigenen Icon verändern möchtest, dann kannst du folgenden Beispielcode verwenden:
    Hier mit einem alternativen Icon, welches weiterhin den unteren Fortschrittsbalken integriert hat (untere Linie beim Downloadpfeil)


    Würde bei einem laufenden Download dann so aussehen:
    [attachment=0]2019-03-11_15-55-36.png[/attachment]


    Selbstverständlich kannst du innerhalb des CSS-Codes dein eigenes Icon einfügen.
    Falls du noch den Fortschrittsbalken (=untere Linie) ausblenden möchtest, dann kannst du dazu folgenden Code verwenden:

    CSS
    #downloads-indicator-progress-outer,
    #downloads-indicator-progress-inner{
    display: none !important;
    }

    Bilder

    • 2019-03-11_15-55-36.png


    Ich möchte da also auf einen Link klicken können und der soll sich dann im Arbeits Firefox öffnen, sofern der zuletzt aktiv war.
    Aber externe Links aus z.B. Telegram oder WhatsApp sollen sich im Privat Firefox öffnen.


    Meines Wissens nach ist das so, wie du das beschrieben hast, unter Firefox nicht möglich, da dieser Links aus externen Anwendungen immer mit dem aktuell definierten Standardprofil öffnet. Aus diesem Grund wirst du die Links unter Firefox wohl oder übel manuell im gewünschten Profil öffnen müssen per Kopieren/Einfügen der URL. -> Ergo müsstest du bei Telegram oder WhatsApp Links nichts weiter tun, falls "Privat Firefox" dein Standardprofil ist, und bei Links welche du im "Arbeits Firefox" geöffnet haben möchtest, müsstest du diese halt manuell in dessen Fenster rein-kopieren.


    Wird hier von uBlock origin blockiert. Ist das bei euch auch so?


    Ja, denn es handelt sich bei dieser Seite auch um eine inoffizielle und nicht vertrauensvolle Seite, welche unter anderem auch schon Malware an die Nutzer verteilt hat, weswegen diese Art von Webseite gemieden werden sollte, und man daher die Software bei der offiziellen Seite beziehen sollte (das Gleiche gilt auch für Seiten wie vlc.de)
    Offizielle Seite ► https://www.audacityteam.org/download/
    ► siehe auch hier zum Grund der Blockierung: [badware] audacity.de



    Aber man kann die Sperre gottseidank für immer überwinden. :)


    Wenn eine Seite durch eine Malware/Badware Filterliste geblockt wurde, dann hat dies in den meisten Fällen auch seine berechtigten Gründe. Aus diesem Grund würde in einem solchen Fall empfehlen, dass man bitte doch genau überprüft, was man denn für Webseiten dauerhaft erlaubt. (im Zweifelsfall lieber geblockt lassen)

    Aus eigener Erfahrung weiss ich, dass das beschriebene Problem gelegentlich auftritt, wenn man bei Firefox DNS-over-HTTPS mit der Einstellung ("network.trr.mode", 3) betreibt. (ergo TRR-only ab Firefox-Start)


    Das Problem kann man dabei lösen, indem man kurz den Schalter network.trr.mode entweder auf 0 (TRR ausgeschaltet) oder 2 (TRR mit Fallback aufs systemweite DNS) setzt, und danach eine beliebige Seite aufruft. Sobald wieder Seiten korrekt aufgelöst werden, kann man in der Regel wieder den Schalter network.trr.mode auf 3 setzen.
    Alternativ bietet es sich auch an TRR nur mit network.trr.mode auf 2 gesetzt zu nutzen, wo das Problem nicht auftreten sollte, da du dort immer noch den Fallback auf dein System-DNS hast.



    user_pref("network.trr.bootstrapAddress", 104.16.111.25 , 104.16.112.25);


    Du solltest in dieser Einstellung lediglich eine IP-Adresse des DNS-Resolvers einsetzen. (könnte vielleicht bei dir auch für das Problem verantwortlich sein, wenn hier zwei IP-Adressen angegeben sind.)
    Beispielsweise wäre 104.16.111.25 in diesem Fall vollkommen ausreichend.



    Auf Empfehlung hin sollte der folgende Wert so gesetzt werden:


    user_pref("security.OCSP.enabled", 0);


    Entgegen der Empfehlung vom Privacy-Handbuch würde ich diese Einstellung auf 1 (eingeschaltet) belassen, da eine Veränderung dieser Einstellung nicht notwendig ist für das korrekte Funktionieren von DNS-over-HTTPS bei Firefox. Darüber hinaus ist auch die Sicherheit deines Browsers gemindert, da keine Gültigkeitsabfrage von Zertifikaten per OSCP-Server mehr stattfindet.


    Es mag daran liegen das, ähnlich anderen Softwareportalen, irgendwas "beigemengt" wird. Kann ich mir zwar nicht vorstellen und habe ich so auch noch nicht von Computerbase gehört, aber es ist eben nicht endgültig auszuschließen.


    Im Fall von ComputerBase ganz sicher nicht, denn deren Download für Firefox verlinkt direkt auf die Mozilla Server -> um genau zu sein auf diesen Link hier für Firefox 65.0.2 x64: https://download-installer.cdn…efox%20Setup%2065.0.2.exe ► ergo der gleiche Link wie auf der offiziellen Mozilla-Seite


    Bezüglich der Verbindung zum Amazon Server, hat Sören ja schon erwähnt gehabt, dass Mozilla Amazon's Service als CDN (=Content delivery network) in Anspruch nimmt. Daher verwundert ein Verbindungsaufbau zu Amazon Servern eigentlich nicht.

    Wie schon erwähnt, handelt es sich hierbei um eine Beschränkung der Webextension Schnittstelle. (=die verwendete Erweiterungsschnittstelle seit Quantum)
    Wenn also Erweiterungen Dateien auf die Festplatte speichern möchten, dann müssen diese das über den Weg der Download Schnittstelle machen, weswegen erzwungenermassen nur der festgelegte Downloadordner dafür verwendet werden kann.


    Ich benutze bislang auf jeden Fall diesen Code für den Hovereffekt mit der Maus im URL Dropdown Menü:


    Ersetze bitte einmal deinen Code mit folgendem CSS-Code, welches beide Dropdown-Hervorhebungsfarben abdeckt (auch die, die mittels der Tastatur ausgewählt):

    CSS
    .autocomplete-richlistitem:hover,
    .autocomplete-richlistitem[selected] {
    background-color: #d1cdc8 !important;
    }


    Hab hier einen anderen Farbcode als #f2f2f2 gewählt, da dieser Farbwert im eigentlichen deiner Hintergrundfarbe des Autovervollständigungspopups entsprechen würde. (kannst ja deine gewünschte Farbe einsetzen)



    Im ersten Bild bin ich mit der Pfeiltaste nach unten auf den ersten Eintrag und mit der Maus auf den zweiten (weiß).


    Als kleine Nebenbemerkung: Bei deinem Screenshot wird augenscheinlich deine gesetzte Hoverfarbe nicht angewendet, denn der Farbwert #f2f2f2 würde ja der Hintergrundfarbe (sehr helles Grau) von der Zeile "Mit Google suchen" entsprechen.
    Ich nehme einmal an, dies hat mit deinem verwendeten Theme zu tun, welche unter anderem auch die Autovervollständigungspopups farblich anpassen. (mein geposteter Code sollte die Hoverfarben aber dennoch überschreiben.)



    Damit kann dann die Auswirkung geänderter CSS-Codes sofort ohne Neustart überprüft werden...


    Dies ist auch mittels den Entwicklerwerkzeugen/Browser-Werkzeuge und deren Stilbearbeitung möglich.