FF Menü reagiert nicht

  • Laut den alten Beiträgen gab es zumindest mal Userscripts:


    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 109 (Stable Channel) - Linux Debian Bullseye: Firefox Unstable Debian-Channel ( Sid, pending) und ESR 102.7.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Laut den alten Beiträgen gab es zumindest mal Userscripts:

    Danke, aber das Skript betrifft nur die Tableiste.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • Hallo erstmal, ich weiß nicht ob Ihr's schon wusstet.... aber ich bin wieder da...

    War etwas im Streß.


    Schön, dass Ihr meine Fragen / Probleme unter Euch schon beantwortet / klärt ^^ :thumbup:


    Also soweit ich weiß, habe ich seit dem Umstieg von "Vor-Quantum" ( FF 56 ) nach "aktuell" keine UserScripte mehr im Einsatz. War froh, dass dann alles lief - Dank Euch! Frei nach Murphy.... "Never touch a running system..."

    Habe alles bei CSS und bei Änderungen Änderungen in der "about:config" belassen. Falls ich doch noch Script am Laufen haben sollte - wo finde ich die ( hab keine gefunden !? ) ?


    Noch'n Hinweis:

    In der gleichen FF-Kopfzeile des Hauptmenüs liegen rechts auch die Close/Klein/Groß-Icons. Die funktionieren.


    Andere Ideen: Kann es sein, dass...

    ... über dem Hauptmenü ( im CSS ) irgendein transparenter Layer drüber liegt ?

    ... nach einem UpDate auf 107 irgendwas in der about:config abgeschossen wurde

    ... es an der Beta liegt ( ich könnte ja mal auf 108 Beta 5 updaten... ?)

    ... Äääh...meine alter 56'er (letzte vor Quantum) läuft aber auf dem Rechner noch unter anderem Profil - daran kann es aber nicht liegen ?


    Grüße

    Grüße aus dem Harz und vielen Dank,
    Ralf


    Ach übrigens: Wer die Rekursion verstehen will, muß vorher die Rekursion verstanden haben 8o

  • Ok, ok ....

    habe folgendes Userscript am Laufen:



    Ich kregs aber nicht mehr gebacken was das alles mal war bzw noch ist.


    Außerdem der Screenshop cpm PÜrofilordner /chrome/ mit mrkierte Zeile des Userscripts.

    Die "user.js" ist leer

  • Moin Andreas, milupa un Euch anderen !


    Die Dateien

    - userChrome_tabs.css

    - userChrome_tabs_only_01.css

    sind alte Versionen. Ich denke und hoffe nicht, dass die von FF geladen werden !?


    Die "MultiRowTab_LiteforFx48.uc.js" und "user.js" lösche ich aus dem Verzeichnis bzw. kopier sie sicherheitshalber in ein anderes Verzeichnis.


    Ich mach das heute abend, dann hab ich Ruhe und Zeit.... melde mich dann gleich!

    Mal wieder: Danke Dir, milupa und Euch anderen!


    Ralf

    Grüße aus dem Harz und vielen Dank,
    Ralf


    Ach übrigens: Wer die Rekursion verstehen will, muß vorher die Rekursion verstanden haben 8o

  • Ok,Jungs... alles weg im chrome-Ordner, außer die "userChrome.css"

    Alle Erweiterungen deaktiviert

    Anderes Theme geladen.


    Was soll ich sagen... Menüs klappen nicht runter...

    Vielleicht doch irgendwas in der about:config ?


    Aber hey: Mit der Tastenkombination für jedes Menü funzt es - dann alles gut. Nur mit der Maus halt nicht.

    Grüße aus dem Harz und vielen Dank,
    Ralf


    Ach übrigens: Wer die Rekursion verstehen will, muß vorher die Rekursion verstanden haben 8o

    2 Mal editiert, zuletzt von Atarist ()

  • außer die "userChrome.css"

    Bis jetzt hast du immer noch nicht den Code deiner userChrome.css eingestellt.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • Uuuups...


    UserChrome.css ;


    Grüße aus dem Harz und vielen Dank,
    Ralf


    Ach übrigens: Wer die Rekursion verstehen will, muß vorher die Rekursion verstanden haben 8o

  • UserChrome.css ;

    Ich habe den Code mal etwas verändert, bzw. Einträge auskommentiert.

    Den Abstand der Tableiste nach oben habe ich auch etwas vergrößert.

    Hier war die Leiste fast in den Menübuttons gewesen.



    Kannst es ja mal testen wenn du magst.


    Vielleicht doch irgendwas in der about:config ?

    Dazu müsste man wissen, was du alles verändert hast.


    Sollte alles nicht funktionieren bleibt noch ein neues Profil.


    Daten werden teilweise übernommen, Codes etc. musst du dann wieder neu einfügen.

  • Danke!


    Dazu müsste man wissen, was du alles verändert hast.

    ... Wenn ich das alles wüßte und noch zusammentragen kann. Eher nicht.

    Werden bei einem neuen Profil die about:config's übernommen ?


    Ich werde mal versuvhen FF neu zu installieren und den alten Profilordner reinzukopieren.

    Oder ich belassses es bei den Menü-Short-Cuts... die funzen ja.

    Grüße aus dem Harz und vielen Dank,
    Ralf


    Ach übrigens: Wer die Rekursion verstehen will, muß vorher die Rekursion verstanden haben 8o

  • 2002Andreas Sag mal, mir kommt im Code aus der userChrome.css das Wörtchen fokus in Zeile 119 suspekt vor. Schreibweise mit k statt mit c? Und der betrifft ja u. a. die Menüeinträge, auch wenn nur die Opazität festgelegt wird.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • in Zeile 119 suspekt vor.

    Das stimmt so auch nicht.

    Aber den Teil vom Code habe ich ja gleich mal auskommentiert, weil opacity eh 1 Standard ist.

    Ob da noch mehr raus könnte, habe ich nicht getestet.


    PS:

    Mit einem neuen Profil, und nur dem CSS Code, wäre das Problem schon lange gelöst.

    Aber warum einfach, wenn es auch umständlich geht ;)


    So sieht das mit dem Code hier aus:


    Mit freundlichem Gruß
    Andreas
    Mein Laptop    Meine Add-ons

    Einmal editiert, zuletzt von 2002Andreas () aus folgendem Grund: Ein Beitrag von 2002Andreas mit diesem Beitrag zusammengefügt.

  • So, ich habe mich mal in die Vergangenheit begeben, zu Fx 107. :) Die Untermenüs erscheinen bei mir in einem frischen Profil nur mit seiner userChrome.css ( Beitrag #32, also nicht mit deiner auskommentierten) und seinem Multitab-Skript (Beitrag #26). Bei mir sieht es ähnlich aus wie bei dir. Ich habe mal ein dunkles Theme eingestellt.


    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook