Verlinkungen zu Webseiten werden nicht immer im Firefox geöffnet

  • Firefox-Version
    Firefox 87.0
    Betriebssystem
    Win 10

    Ich bin unentschlossen, ob ich einen eigenen Thread aufmachen sollte, aber ich hänge mich hier mal mit dem gleichen Problem ran. Ich habe seit mehreren Jahren ein ähnliches Problem wie der Threadersteller, das ich nicht in den Griff bekomme, und vermute, die Zusammenarbeit in Form einer Linkübergabe mit dem Webschutz einer AV-Software (in meinem Fall Avira) funktioniert nicht. Ich möchte das kurz erläutern:


    Wenn ich aus anderen Programmen auf Verlinkungen zu Webseiten klicke, werden diese nicht immer im Firefox geöffnet. Zum Beispiel aus einer E-Mail von Outlook heraus oder wenn ich einen Link im Passwort-Programm KeyPass aufrufe. Das sind oft Verlinkungen zu Webseiten, die viel Werbung enthalten und vermutlich entsprechende Tracker aufrufen. Beispielwebseite sind www.zeit.de oder www.gmx.de oder www.nzz.ch. Es erscheint in solchen Fällen ein leeres Fenster (siehe Anlage), beim zweiten oder dritten Klick auf den gleichen Link funktioniert dieser Linkaufruf dann aber doch.


    Wenn ich in Windows 10 Professional statt Firefox 87.0 (64 bit) abweichend Google Chrome 89.0.4389.114 (64-Bit) als Standard-App eintrage, tritt dieses Phänomen nicht auf. Wenn ich als Administrator eingeloggt Avira abschalte und mit Firefox surfe, existiert dieses Problem ebenfalls nicht, weswegen ich davon ausgehe, dass bei mir das Problem im Webschutz von Avira-Security begründet ist.


    Ein anderes Phänomen ist, die Nichtannahme von händisch eingegebenen Internetadressen im Firefox. Beispiel: In Firefox ist https://www.google.de geöffnet und ich tippe nun händisch www.zeit.de in die Adresszeile ein, dann passiert nach drücken von Enter, dass die vorherige Adresse (also www.google.de) wieder in der Adresszeile steht und eben nicht die gewünschte Seite aufgerufen wird.


    Cookies löschen, abgesicherter Modus etc. habe ich schon alles durch. Möglicherweise hat der Threadersteller unbewusst noch eine AV-Software oder irgendeinen Webschutz-Security-Lösung im Hintergrund laufen. Ich habe bei mir jetzt mal den Avira-Support um Hilfe gebeten, vielleicht gibt es ja nach all den Jahren doch noch eine Lösung.


    So sieht ein leeres Fenster nach Klick auf http://www.gmx.de von KeyPass aus:

  • ob ich einen eigenen Thread aufmachen sollte,

    Zitat

    5.1 Eigene Themen eröffnen


    Während es in manchen Foren üblich ist, sich an bestehende Themen dranzuhängen, bitten wir Nutzer in diesem Forum, für ihre Probleme jeweils eigene Themen zu erstellen. Nur so kann jedem Nutzer zielgerichtet und effizient geholfen werden, ohne dass die Probleme eines Nutzers untergehen. Auch könnte eine bereits vorgenommene "Erledigt"-Markierung ansonsten dafür sorgen, dass man nicht die Hilfe erhält, die man sonst erhalten würde, weil nicht jeder Helfer zwingend in Hilfe-Themen liest, welche bereits als erledigt markiert sind.

    https://www.camp-firefox.de/regeln/

  • Wenn ich als Administrator eingeloggt Avira abschalte und mit Firefox surfe, existiert dieses Problem ebenfalls nicht, weswegen ich davon ausgehe, dass bei mir das Problem im Webschutz von Avira-Security begründet ist.

    Warum deinstallierst du dann nicht einfach Avira?

    Unter Windows10 brauchst du keine externe AV-Software, das kann der Windows-Defender mindestens genau so gut - und der ist besser ins System integriert und verursacht keine solchen Probleme. (Kostenlos ist er auch noch... ) ;)

  • Nun ja, mein Anliegen war eigentlich, dem Threadersteller in "Externe" Verknüpfungen werden nicht mehr geöffnet an meinem detaillierten Beispiel den Tipp zukommen zu lassen, dass da im Hintergrund evtl. noch eine AV-Software werkelt, von der er vielleicht gar nichts weiß und die diese Probleme mit Firefox verursacht.


    Zu deiner Frage: Ich benutze Avira Prime. Das ist ein Programmpaket, das auch noch andere Applikationen aufweist, und ich habe mich bewusst dafür entschieden. Das mit dem Windows-Defender stimmt zwar prinzipiell, ich muss aber jetzt nicht unbedingt auf ein Microsoft-Produkt vertrauen. Genauso gut könnte ich auf Edge ausweichen, weil "mindestens genau so gut - und der ist besser ins System integriert und verursacht keine solchen Probleme." (in meinem Fall) - will ich aber nicht, ich bin gerne mit Firefox unterwegs.


    Ich werde mal berichten, wenn ich irgendwann eine Lösung gefunden habe, vielleicht hilft es ja dem einen oder anderen.

  • Zu deiner Frage: Ich benutze Avira Prime. Das ist ein Programmpaket, das auch noch andere Applikationen aufweist...

    ... Die Sicherheitseinrichtung eines Betriebssystems bzw einem externen Sicherheitsprogramm mit 2 Browsern zu vergleichen ist wie Äpfel und Birnen... 8)

    Interessehalber: Welche anderen Applikationen wären dies? :)

  • Das Problem mit der Linkübergabe in Firefox bekomme ich leider nicht in den Griff.


    Vorab: Ich hatte zunächst die AV-Software im Verdacht und habe das komplette Avira-Prime-Paket deinstalliert, im abgesicherten Modus den Avira Registry Cleaner drüberlaufen lassen, manuell den Avira-Ordner in Programme gelöscht und zu guter Letzt in der Eingabeaufforderung "netsh winsock reset" ausgeführt. Es laufen weder irgendwelche Werbeblocker noch Drittanbieter AV-Lösungen, nur der Windows Defender.


    Ich habe zwei Rechner, die auf unterschiedliche Weise mit dem Internet verbunden sind (VDSL und T-Mobile) ein Firewall-Problem im Router kann daher ausgeschlossen werden. Gleichwohl habe ich auf zwei Rechnern folgendes Problem:


    Phänomen 1: Eine Linkübergabe in Firefox aus anderen Anwendungen heraus (sei es aus KeePass oder Outlook) klappt nicht immer. Klicke ich auf so einen Link, öffnet sich Firefox, und es erscheint ein leeres Fenster mit leerer Adresszeile (siehe Screenshot):



    Dies betrifft im Schwerpunkt Nachrichtenseiten, die entsprechend trackend unterwegs sind. Wenn ich als Standard-App Google Chrome als Browser einstelle, existiert das Problem nicht.


    Phänomen 2: Das beschriebene Problem gibt es jeweils nur einmal. Will sagen, bei einem erneutem Klick auf den Link funktioniert alles wie gewünscht.


    Dazu folgende Beispiele:

    a) Nachfolgender Link aus dem Newsletter der Zeitung NZZ: https://click.email.nzz.ch/?qs…76ad1e19876f0d6d9a2062e77


    b) GMX ist auch so ein Kandidat: Der GMX-Link in diesem Posting: In memoriam (Franco Battiato ist verstorben (ESC-Sänger u. Liedermacher)), zeigt das gleiche Phänomen.


    Frage:

    Funktionieren bei euch beide Links beim ersten Öffnen im Firefox sofort?


    Ist bei mir irgendetwas unvorteilhaft eingestellt?


    Code siehe hier:

  • Ich würde raten: Profil zurücksetzen, auf Logitech und Adobe verzichten.

    Und Firefox gleich auf englisch installieren

    Zitat

    Name: English (US) Language Pack
    Typ: locale
    Version: 88.0buildid20210415204500
    Aktiviert: true
    ID: langpack-en-US@firefox.mozilla.org


    Firefox-Profil zurücksetzen:
    https://support.mozilla.org/de/kb/firefox-bereinigen

    Zitat

    Sie können viele Firefox-Probleme lösen, indem Sie den Browser bereinigen. Die Funktion „Bereinigen” beseitigt viele Fehler, indem Firefox auf seine Standardeinstellungen zurückgesetzt wird. Dabei werden Ihre wichtigsten Daten ... gesichert.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Ich habe das Profil in Firefox zurückgesetzt und die Erweiterungen entfernt. Das behebt das Problem leider nicht. Dieses besteht zudem auf zwei Rechnern, die nichts miteinander zu tun habe.


    Ich habe daraufhin den Firefox komplett deinstalliert und nochmal neu installiert, auch das behebt das Problem leider nicht.


    Meine Frage ist offen geblieben: Funktionieren die von mir geposteten Links bei anderen Forenteilnehmern?

  • Funktionieren die von mir geposteten Links bei anderen Forenteilnehmern?

    Funktionieren hier mit Firefox 88.0.1 unter Linux einwandfrei. Mangels Windows kann ich dir weiter nicht helfen, sorry.

    Firefox 103.0.1 | Lubuntu 22.04 | Kernel: 5.15.0-43-generic

  • Meine Frage ist offen geblieben: Funktionieren die von mir geposteten Links bei anderen Forenteilnehmern?

    ... bei mir funktioniert es wie gewünscht.

    Zitat

    Ich habe seit mehreren Jahren ein ähnliches Problem wie der Threadersteller, das ich nicht in den Griff bekomme, und vermute, die Zusammenarbeit in Form einer Linkübergabe mit dem Webschutz einer AV-Software (in meinem Fall Avira) funktioniert nicht. Ich möchte das kurz erläutern:


    Wenn ich aus anderen Programmen auf Verlinkungen zu Webseiten klicke, werden diese nicht immer im Firefox geöffnet.

    ... damit gehe ich ganz stark davon aus das es ein Problem mit deinem System ist, aber nicht mit dem Firefox als solches.

    Vergiss bitte auch nicht, dass keiner von uns bei dir vor Ort vor dem PC sitzt und dein Problem nachvollziehen kann.

    Gruß Micha

    Ich beantworte keine technischen Fragen per PN, ICQ, E-Mail, sondern nur in diesem Forum.

    Mein produktiver Firefox ist die jeweils aktuellste installierte Release-Version.

    Beta und Nightly ebenfalls als portable Versionen zum Testen in VMs.

  • Dass "meine" Links sowohl unter Linux als auch in Windows bei anderen funktionieren, ist eine wertvolle Rückmeldung, vielen Dank dafür.


    Es wird in der Tat so sein, dass das Problem außerhalb vom Firefox angesiedelt ist, obwohl es ausschließlich beim Firefox als Browser auftritt. Dass das beschriebene Problem gleich auf zwei Clients auftritt, ist ungewöhnlich.

  • obwohl es ausschließlich beim Firefox als Browser auftritt.

    ... betrifft dann vermutlich der Browser-Standardanwendung im Windows 10.

    Gruß Micha

    Ich beantworte keine technischen Fragen per PN, ICQ, E-Mail, sondern nur in diesem Forum.

    Mein produktiver Firefox ist die jeweils aktuellste installierte Release-Version.

    Beta und Nightly ebenfalls als portable Versionen zum Testen in VMs.

  • genau, wird Google Chrome als Standard-Browser-App in Windows 10 hinterlegt, funktioniert alles wie gewünscht, dito bei Edge. Das Phänomen tritt nur beim Firefox als Standard-Browser auf.

  • Das Phänomen tritt nur beim Firefox als Standard-Browser auf.

    ... kann ich in keinen meiner Windows-Systeme nachvollziehen, egal ob Windows-10-Home oder -Pro, Fx-Release, -Beta, oder -Nightly.

    Gruß Micha

    Ich beantworte keine technischen Fragen per PN, ICQ, E-Mail, sondern nur in diesem Forum.

    Mein produktiver Firefox ist die jeweils aktuellste installierte Release-Version.

    Beta und Nightly ebenfalls als portable Versionen zum Testen in VMs.

  • kreien


    probiere es bitte mal mit einem kompletten neuen Windows Benutzerkonto aus, welcher an sich noch nie etwas mit Avira zu tun hatte.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 104 (Stable Channel) - Linux Debian Bullseye: Firefox Stable Release Channel und ESR 91 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)