Addons Manager Nightly

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

  • Ich habe den Code von Aris :thumbup: dazu etwas erweitert, ab Zeile 145.


  • Und dann bitte ich dich um einen Gefallen, steigere dich bitte nicht in diese Sache hinein, das ist es nicht wert. Ich schätze deine Hilfe sehr, habe ich immer betont, und wir sollten uns hier keine Schuldzuweisungen aufzwingen. Locker bleiben!!

    Ich steigere mich da nicht hinein. Ich wollte dir nur klar machen, dass du von Anfang an die Sache sofort auf den richtigen Punkt bringst. Alles Andere ist vergeudete Zeit. Auch andere Mitglieder warten auf Hilfe. Stelle dir vor, du müsstest dann warten.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Mit kleinen Anpassungen funktioniert der Code aus Beitrag Nr. 61 auch in Fx 70.



  • Ich habe den Code von Aris :thumbup: dazu etwas erweitert, ab Zeile 145.

    Ja, Andreas, da gibt dir keiner mehr Antwort. Die Aufregung war einfach zu groß, um nichts, ich musste auch erst mal ein Bier zu mir nehmen. Lecker !!

    Danke, für den Code, habe da noch mal reingeschaut, und ihn dann für die Auflösung 1920x1080 für mich auf Probe eingerichtet. Ich betone hier ausdrücklich für Nightly. Hier dann der Code, wer möchte langt zu. milupo und dich Andreas bitte ich den Code noch mal unter die Lupe zu nehmen, denn ich habe den Eindruck, dass da noch was überflüssig ist.




    Grüße

    FuchsFan

    Grüße vom FuchsFan

  • Auf der Basis von FuchsFan :

    habe ich nun meinen Code nochmal überarbeitet und finde es jetzt supi:


    Wer mag, hier ist der Code... ich hoffe fehlerfrei:

  • wenn alles funktioniert, dann lass ihn auch so

    Ich hatte aus dem Code fünf Blöcke entfernt (probehalber), wurde trotzdem normal alles angezeigt. Nun habe ich sie aber wieder eingefügt, lasse es so.


    Grüße

    FuchsFan

    Grüße vom FuchsFan

  • habe ich nun meinen Code nochmal überarbeitet und finde es jetzt supi:

    Schön, dann sind wir bei Nightly schon Zwei. Ich möchte dich aber noch darauf hinweisen, dass ich das Menü hinter dem Zahnrad neu einrichten musste, da stimmte so einiges nicht. Dann habe ich versucht die Button auf der rechten Seite wieder abzurunden, der Nachteil dabei, bei Mauskontakt ist wie im Addon-Manager im 70er der Hintergrund leicht zu erkennen. Das abzuändern, dazu bin ich nicht in der Lage, eventuell unterstützt uns Andreas wieder dabei. So sind wir dem alten Aussehen schon ein ganzes Stück näher gekommen.

    So, hier dann Bild und Code:


  • auf der rechten Seite wieder abzurunden

    Die sind doch rund in deinem Screenshot:/



    der Hintergrund leicht zu erkennen

    Teste bitte:


    CSS
    button:focus,
    button:enabled:hover {
    background-color: transparent !important;
    }

    Kleiner Nachteil bei dem Code, wenn du oben mit der Maus auf das Zahnrad gehst, dann fehlt bei hover der Hintergrund.

    Bis jetzt habe ich leider keine Lösung dafür gefunden.

  • Für das Zahnrad habe ich mir erstmal damit geholfen;)


    CSS
    /* Button oben mit dem Zahnrad */
    .page-options-menu > .more-options-button {
    fill: red !important;
    }
    /* Button oben mit dem Zahnrad bei hover blau */
    .page-options-menu > .more-options-button:hover {
    fill: green !important;
    border: 1px solid red !important;
    }
  • Die sind doch rund in deinem Screenshot

    Ich schrieb versucht, natürlich habe ich es gemacht. :rolleyes:

    Teste bitte:

    Der Hintergrund ist weg, aber Hover funktioniert dann auch nicht mehr. Das hatte ich auch schon versucht


    background: transparent !important;


    mit dem gleichen Ergebnis.

    dann fehlt bei hover der Hintergrund.

    Ja Andreas, so ist es. Wenn man auf eine Leiste klickt, dann erscheint vom linken zum rechten Rand ein Hintergrund in hellgrauer Farbe.


    Grüße

    FuchsFan

    Grüße vom FuchsFan

  • aber Hover funktioniert dann auch nicht mehr

    Mein Code ist etwas anders als deiner bezüglich dem Hintergrund der rechten Button.

    Bei hover sieht das hier so aus:



    Der graue Hintergrund ist mit dem Code weg, und hover funktioniert trotzdem.


  • Teste bitte:

    So, Andreas, ich habe deinen Code leicht angepasst, nun bin ich zufrieden.


    CSS
    button:focus,
    button:enabled:hover {
    background-color: blue !important;
    border-radius: 15px !important;
    color: white ! important;
    box-shadow: inset 0 0 5px 5px lightgrey;
    }

    Danke !!:thumbup:


    Grüße vom FuchsFan

  • Der graue Hintergrund ist mit dem Code weg, und hover funktioniert trotzdem.

    Das ist natürlich auch eine Möglichkeit, werde den Code studieren. Danke ! :thumbup:


    Noch eine Sache, gebe ich den Code dazu, dann wird unter Erweiterungen der Text auch richtig angezeigt. Gehe ich dann bei einer Erw. auf Verwalten , so ist der Text dort senkrecht aufgeführt.

    CSS
    .addon-badge-private-browsing-allowed::after {
    content: "(In privaten Fenstern erlaubt)" !important;
    margin-left: 20px !important;
    }

    Grüße vom FuchsFan

    Einmal editiert, zuletzt von FuchsFan ()

  • Dein Edit habe ich eben erst gelesen, besser wäre immer ein neuer Beitrag;)


    Teste bitte:


    CSS
    .addon-badge-private-browsing-allowed::before {
    content: "(In privaten Fenstern erlaubt)" !important;
    margin-left: 20px !important;
    }
    .addon-badge-private-browsing-allowed {
    min-width: 500px !important;
    }