Immer wieder Probleme mit NoScript/uBlock im FF 60 ESR

  • Ich hab jetzt einige Wochen den aktuellsten FF 60 ESR benutzt und hatte dabei immer wieder Probleme mit den Erweiterungen Noscript und uBlock. ZB kam es immer wieder mal vor, daß ich auf YouTube Werbung zu sehen bekam und auch, auf einschlägigen Porn Seiten, irgendwelche Seiten im Hintergrund aufpoppten - also genau das was man eigentlich unbedingt vermeiden will, und was mir seit Verwendung von NoScript und uBlock eigentlich auch nie mehr passiert ist - bis zum erscheinen der "neuen, supersicheren Erweiterungen".
    Ich kann nicht mit Sicherheit sagen welche Erweiterung da Probleme macht, aber ich hab gerade entschieden, wieder zur alten FF ESR mit alten Erweiterungen zurückzukehren.


    Hat hier jemand ähnliche Erfahrungen gemacht ? Gibt es vieleicht noch bessere Lösungen ?


    Gruß Martin

  • > zur alten FF ESR mit alten Erweiterungen zurückzukehren


    Das meinst du hoffentlich nicht ernst. Firefox ESR 52 ist tot, es erscheinen keine Sicherheits-Updates mehr. Das kann also unter gar keinen Umständen eine Option sein.


    Ich kann mich nicht daran erinnern, auf dem Desktop auf YouTube in den letzten Monaten irgendwelche Werbung gesehen zu haben. Nur in der Android-App. Ich weiß zwar nicht, was "neue, supersichere Erweiterungen" sind (WebExtensions kannst du ja nicht meinen, die werden nämlich nicht als "supersichere Erweiterungen" vermarktet), aber zu meiner Installation: So etwas wie NoScript käme mir niemals auf die Festplatte, als Werbeblocker kommt bei mir Adblock Plus zum Einsatz.

  • FF 52 ESR - das war die einzige Alternative. Ich halte es, angesichts der Umstände, nicht nur für vertretbar, sondern für die einzige sichere Lösung. Ich weiss natürlich auch noch nicht sicher, ob die angesprochenen Fehler dadurch ausgeräumt sind - das muss sich erst zeigen.
    Die scheinbaren Fails der Erweiterungen kamen bei mir ca. alle 2-3 Tage vor. Aber zuvor hatten die alten Erweiterungen, jahrelang, absolut zuverlässig gearbeitet.

  • FF 52 ESR - das war die einzige Alternative. Ich halte es, angesichts der Umstände, nicht nur für vertretbar, sondern für die einzige sichere Lösung.


    Eine Lösung, deren potentielle Sicherheitslücken in der Zukunft nicht mehr behoben werden, kann nicht als "sichere Lösung" bezeichnet werden. Firefox ESR 52 wurde durch Firefox ESR 60 abgelöst.


    Ich muss mich immer wieder über die Prioritätensetzung mancher Menschen wundern und kann nur den Kopf schütteln.


    PS: Ich nutze Firefox Nightly 63 und habe keine Werbung in YouTube…

  • Und ich nur uBlock Origin mit den standardmäßig aktivierten Listen und habe dort keine Werbung. Achja, Drittanbietersoftware ist da auch keine installiert, die sich da einmischen könnte. Weder Sicherheitssoftware noch Malware in Echtheit ;)

  • Jedem das seine, wenn Du die Kollaboration unterstützen willst…


    Ich habe keine Ahnung, was du damit mitteilen möchtest, gehe aber davon aus, dass es unbegründetes Bashing sein soll, was du dir schenken kannst. Wir können uns gerne per PN darüber unterhalten, wenn du ein Problem mit meiner Wahl des Werbeblockers hast. Dann kann ich deine Vorurteile mit Fakten ergänzen. Das gehört aber nicht in dieses Thema.

  • Ich muss das Thema nochmal aufgreifen. Selbes Problem besteht bei mir leider immer noch:
    FF60.3.0esr
    Meine beiden Addons, "UBlock Origin" und "NoScript", laufen gelegentlich nicht richtig.
    Es kommt relativ selten vor (ca. 1mal/Monat). Ich bemerke es idR wenn ich auf Youtube plötzlich Werbung angezeigt bekomme. Die beiden Addon-Symbole werden in der oberen Leiste zwar angezeigt, aber die Addons funktionieren nicht und lassen sich auch nicht konfigurieren. Das NoScript Symbol wird mit Fragezeichen angezeigt. Die Benutzeroberflächen beider Addons werden nur unvollständig angezeigt und haben keine Funktion(siehe Bildanhänge).
    Nach FF Neustart funktionieren die Addons idR wieder problemlos.


    Ich vermute, da diese beiden Addons momentan die einzigen sind, die ich installiert habe, und somit "alle" installierten Addons betroffen sind, warscheinlich auch alle betroffen währen wenn ich mehr Addons installiert hätte.


    Gibt es bzgl dieses Problems irgendwelche Erkenntnisse und Abhilfe ?


    freundliche Grüße, Martin

  • Versuche es doch einmal gänzlich ohne NoScript... eigentlich reicht uBlockOrigin im Profimodus komplett allein aus... Wenn dir diese Möglichkeiten nicht reichen, dann verwende lieber zusätzlich uMatrix, das arbeitet mit uBlockOrigin besser zusammen, denn es kommt vom gleichen Entwickler...
    Nutze vor allem mal ein neues Profil, damit wäre sicher gestellt, das keine Änderungen, die NoScript vorgenommen hat, nach der Deinstallation weiter wirken...

  • Ich hab eigentlich keinen Grund zur Annahme, daß es entweder an "NoScript" oder an "uBlock origin" liegt. Wie gesagt, wenn's hängt, dann hängen beide Addons, mit dem selben Fehlerbild, sodaß ich eher FF selbst als Fehler-Verursacher in Verdacht habe.
    Leider tritt der Fehler jetzt auch wieder relativ häufig, ca. 1 mal täglich, auf.
    Zuvor, nach Neuinstallation des aktuellen FF ESR, lief es scheinbar einige Wochen ohne Fehler.


    Edit:
    Ich hab gelesen, daß FF zum Updaten die Addons deaktiviert. Kann es sein, daß es damit zusammenhängt ?
    Hab zwar die automatischen Browser Updates deaktiviert, aber vieleicht versucht FF ja trotzdem ein Update und deaktiviert dabei versehentlich die Addons.

  • Du hast einen Vorschlag bekommen, gehst aber überhaupt nicht darauf ein... :?
    Drum nochmal: Entferne NoScript, bereinige danach dein Profil und teste nur mit uBlock Origin im Profimodus..