userChrome.js Scripte für den Fuchs (Diskussion)


  • Ich habe inzwischen dieses Skript gefunden, das Aris vermutlich meint:
    https://github.com/Aris-t2/Cus…s/addonbar_vertical.uc.js


    Ich krieg die Krise - ich wusste gar nicht, dass Aris auch ein Skriptprojekt hat.


    Im Moment funktioniert dieses Skript aber noch nicht, obwohl es sich unter Anpassen in die Symbolleisten eingetragen hat.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook


  • Ich las aber auch, das dieser nur EINMAL benutzt werden muss..


    Warum hast du denn dann gefragt, ob du entfernen musst? Da war doch alles klar, oder nicht?

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • Nein, war und ist es nicht....
    Ich gehe aber davon aus, das das entsprechende Script ständig laufen muss...
    @ edvoldi: Auch hier reichen nun 500... :)
    BTW: Mein portabler ist nun auch "richtig"... ein komplett neues Profil half...
    Für mich ist diese Sache nun erledigt... :D
    Ich danke allen, die dabei hilfreich waren!


  • ...


    Hat bitte jemand einen Link zu einem Skript für eine Seitenleiste?
    Es funktioniert bei mir auch bei drei und vier waagrechten Leisten.


    Ich glaube ich habe mich missverständlich ausgedrückt. Es geht nicht um die Anzahl der Leisten (zumindest nicht in dem Kontext), sondern um die Anzahlt der Scripte.


    Die Scripte sind alle von hier: https://github.com/Aris-t2/CustomJSforFx/tree/master/scripts


    addonbar.uc.js + addonbar_vertical.uc.js + dein Fix in beiden Dateien = Erweiterungen, die eigene Fenster öffnen, funktionieren.


    addonbar.uc.js + addonbar_vertical.uc.js + ein weiteres Script wie space_and_separator_restorer.uc.js oder additional_top_toolbars.uc.js inklusive deines Fixes in jeder Datei = Erweiterungen, die eigene Fenster öffnen, funktionieren nicht.
    (Kann natürlich auch an meinen Scripten liegen. Sie waren nicht mit dem Hintergrund erstellt worden auf leistenlosen Erweiterungsfenstern zu funktionieren).


    Ich krieg die Krise - ich wusste gar nicht, dass Aris auch ein Skriptprojekt hat.


    Im Moment funktioniert dieses Skript aber noch nicht, obwohl es sich unter Anpassen in die Symbolleisten eingetragen hat.


    Ich hatte mit dem "Scrollbar"-Script angefangen und der Rest hat sich mit der Zeit ergeben. In sehr unregelmäßigen Abständen veröffentliche ich das ein oder andere Feature von CTR, wenn es "funktioniert". Ich habe hier auch noch unveröffentlichte Scripte rumliegen. ;)


  • Und was hältst du für die Originalquelle? Ich kenne nur die Seiten von Ardiman und Endor und wenn die noch nicht aktualisiert sind, weil es, wie wir gesehen haben, auch mal sein kann, dass Skripte aufhören zu funktionieren. An anderer Stelle habe ich dir ja auch grundsätzlich recht gegeben, nur ist dein Tipp nicht immer machbar.


    Ja, „Originalquelle“ ist unsauber formuliert, weil ein erheblicher Anteil der Skripte bei Ardimn/Endor übersetzte Versionen chinesischen oder japanischen Ursprungs sind. Ich meinte schon Ardiman/Mithrandir oder Endor (ursprünglich war es ja so, dass Endor aktualisierte Versionen zu Mithrandir rübergeschoben hat, bitte hier nicht an technischen Details aufhängen). Wenn, wie zuletzt oft geschehen, hier im Forum eine neuere Version präsentiert wurde, dann kann man auf diese verlinken. Das sollte es auch Endor oder Mithrandir leichter machen, wenn sie die Zeit finden sollten, selbst die Updates einzupflegen.



    Ich krieg die Krise - ich wusste gar nicht, dass Aris auch ein Skriptprojekt hat.


    Ich hatte hier im Thread einst (vor dem Großen Vaterländischen Krieg) darauf hingewiesen … ;)


    Dann mal schnell die Gelegenheit genutzt, auf diese hinzuweisen:

    • Alice0775, japanisch, Quelle vieler bekannter Skripte.
    • Harv, chinesisch, mindestens OpenNewTab bei Ardiman ist eigentlich von dort.
  • addonbar.uc.js + addonbar_vertical.uc.js + dein Fix in beiden Dateien = Erweiterungen, die eigene Fenster öffnen, funktionieren.


    addonbar.uc.js + addonbar_vertical.uc.js + ein weiteres Script wie space_and_separator_restorer.uc.js oder additional_top_toolbars.uc.js inklusive deines Fixes in jeder Datei = Erweiterungen, die eigene Fenster öffnen, funktionieren nicht.


    (Fettmarkierung durch mich.) Aris, der Fix darf nur einmal pro Skriptsammlung eingetragen werden – entweder in einem der Skripte ergänzt oder separat als eigenes Skript. Mit Aborix’ Worten:



    Man kann den Code in ein eigenes Skript geben oder in ein anderes einfügen. Er soll nur einmal ausgeführt werden und daher wenn, dann in nur einem Skript, hinzugefügt werden.


    Nebenbei: Aborix’ Vorgabe von 1500 ms funktioniert hier gut, 1000 ms waren dagegen zu kurz.

  • Ach Leute, warum sagt denn das keiner! Klar funktiontioniert das Skript addonbar_vertical.uc.js! Es hat jetzt bei mir endlich klick gemacht; der Eintrag unter Anpassen --> Symbolleisten war da, das Symbol war da (das von der Sidebar, vielleicht könnte man da ein anderes Symbol festlegen) und, wenn ich im Anpassen-Fenster war, habe ich oben bei aktivem Skript eine weitere gestrichelte Leiste gesehen. Jetzt gerade hat es klick gemacht: Man muss nur mal ein Symbol in diese gestrichelte Leiste ziehen, dann ist die Leiste auch in der Normalansicht sichtbar! Das war wieder eine Geburt.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • Ja, „Originalquelle“ ist unsauber formuliert, weil ein erheblicher Anteil der Skripte bei Ardimn/Endor übersetzte Versionen chinesischen oder japanischen Ursprungs sind. Ich meinte schon Ardiman/Mithrandir oder Endor (ursprünglich war es ja so, dass Endor aktualisierte Versionen zu Mithrandir rübergeschoben hat, bitte hier nicht an technischen Details aufhängen). Wenn, wie zuletzt oft geschehen, hier im Forum eine neuere Version präsentiert wurde, dann kann man auf diese verlinken. Das sollte es auch Endor oder Mithrandir leichter machen, wenn sie die Zeit finden sollten, selbst die Updates einzupflegen.


    Die Optimallösung wäre, das in einer Art Wiki zu pflegen, was das Einspielen von Updates einfach macht. Dann hätte man auch alle Scripts an einem Ort und wenn man immer auf den Wiki-Eintrag verlinkt, bekommt man immer die aktuelle Version, ohne sich im Forum durch die zig verschiedenen Versionen suchen zu müssen. Natürlich eng verzahnt mit dem Forum. Das heißt, kein zusätzlicher Account notwendig, eigene Artikel wie Forenbeiträge über das Profil erreichbar und so.


    Sehe ich das richtig? ;)

  • Das wäre eine super Idee :klasse:

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Unstable Debian-Channel ( Sid, pending) und ESR 102.3.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • // 3.Q 19 diesmal :P?

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Unstable Debian-Channel ( Sid, pending) und ESR 102.3.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Alles gut ... Gut Ding braucht Weile oder wie es so schön heisst ... :)

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 105 (Stable Channel) - Linux Debian Bullseye: Firefox Unstable Debian-Channel ( Sid, pending) und ESR 102.3.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)


  • Für mich ist diese Sache nun erledigt... :D

    Hm, doch noch nicht..... :(
    Ich erhalte nun in 65.0 und 67.0 zu meinen mitstartenden Tabs noch jeweils einen Leertab an 1. Stelle.
    Als Scripte bzw Codes laufen dazu die in Beitrag 2127 geposteten mit der Änderung im 2. Script in der Laufzeitbegrenzung auf 500.
    Wie kann ich das beheben?

  • Dann erhöhen noch einmal auf den Grundwert von 1500 was passiert dann?
    Löscht Du auch immer den Cache beim Neustart?

    WIN10 pro Version & WIN10 Home Version 22H2
    (Build 19045.2311)

    Firefox 107.0.1 (64-Bit)
    Thunderbird 102.5.1 (64-Bit)
    Meine Erweiterungen