Firefox 127 automatisch Starten mit Windows

  • Firefox-Version
    127
    Betriebssystem
    Windows 11

    Ich habe den Haken für das automatische Starten des FF gesetzt. Es zeigt aber keine Wirkung.

    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:128.0) Gecko/20100101 Firefox/128.0, Windows 11 Pro Version 24H2 (Build 26100.1150)

  • Dann erzähl doch mal was über deinen Firefox? Regulär installiert? Portable?

    Ach ja, Profile, Profilordner und vermutlich die profiles.ini spielen eine wichtige Rolle.

    ok, es ist der Profilordner, der muss sich wohl zwingend im Benutzerprofil befinden. Wo Firefox liegt, ist egal.

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • Hallo,

    ich habe es mehrfach getestet und bei mir hat die Einstellung auch nicht immer funktioniert. Mein Gefühl ist aber, dass es zuverlässig funktionierte, wenn ich ausreichend Zeit zwischen dem Beenden von Firefox und Herunterfahren von Windows ließ. Eine Theorie ist, dass in den Fällen, in denen es nicht funktionierte, vielleicht noch ein Firefox-Prozess offen war, weil ich teilweise in meinen Tests recht schnell war. Aber jetzt kann ich das auch mit Beeilen nicht mehr reproduzieren.

    Firefox 127 auf Windows 11 23H2 für ARM64.

  • .DeJaVu, den FF habe ich regulär installiert bzw. aktualisiert. Ich habe nur ein Profil und dieses befindet sich standartmäßig im Benutzerprofil.

    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:128.0) Gecko/20100101 Firefox/128.0, Windows 11 Pro Version 24H2 (Build 26100.1150)

  • Bei mir gibt es diesen Eintrag in den Einstellungen noch gar nicht, weder in Fx 127 noch im NIghtly. Muss ich noch irgendeine Einstellung in about:config setzen?

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress

  • Der Eintrag ist vorhanden, aber es gilt dann zu ergründen, warum es nicht in den Einstellungen gezeigt wird. Und da halte ich mich an meine Tests - nicht im Benutzerprofil: kein Autostart.

    PS mein Benutzerprofil liegt auf C

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • Die Einstellung gibt es nicht, wenn Firefox so konfiguriert ist, dass er nicht mit dem letzten Profil startet, man also mit dem Profilwähler starten würde.

    Ah danke, das muss man erst einmal wissen. Ich starte über den Profilmanager.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress

  • Die Einstellung gibt es nicht, wenn Firefox so konfiguriert ist, dass er nicht mit dem letzten Profil startet, man also mit dem Profilwähler starten würde.

    Kann ich nicht bestätigen.

    Kein Eintrag.

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • War ein neues Profil bzw ein leerer Profilordner als minimale Vorgabe. profiles.ini nicht vorhanden, bestehenden Ordner auf E ausgewählt, mit/ohne Standardprofil, beide Male keine Option sichtbar. Ich bekomme die Option erst, wenn der Profilordner in meinem Benutzerordner liegt, ob nun Standard oder nicht. Mehr kann ich grad nicht sagen, ausser, dass ich diese 4 Kombinationen inklusive einem virtuellem Test mit Installation getestet habe. Daher kann ich nur vorschlagen, dass jeder Betroffene ein neues Profil erstellt und dort nachschaut.

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • Irgendwie keine Chance. Ich habe ja immer mit dem Schalter -p gestartet und hatte kein Häkchen im Kästchen, ob mit dem zuletzt ausgewählten Profil gestartet werden soll. Ich habe in den Eigenschaften der Desktop-Verknüpfung den Schalter entfernt und das Häkchen im Profil-Manager gesetzt, sowohl im Nightly als auch in Fx 127, nix da, Eintrag bleibt weg.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress

  • Natürlich könntest du selbst die Option in about:config manuell geändert haben

    Hat einen Moment gedauert, das zusammenzusetzen. Der Inspector zeigt hidden=false, weil browser.startup.windowsLaunchOnLogin.enabled auf false steht. Nochmal ein neues Profil, auch auf E, diesmal ist der Eintrag vorhanden als auch der andere auf "true". Alles andere, wie du aufgezeigt hast: StartWithLastProfile
    Im vorhandene Testprofil steht der Eintrag im about:config auf false, warum auch immer, aber dort bringt "true" aufgrund der Struktur nichts, ist aber nicht tragisch, wollte ich eh nie haben ;)

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • So die Einstellung browser.startup.windowsLaunchOnLogin.enabled war entscheidend, auf true gesetzt und jetzt hat es geklappt. Schalter in der Desktop-Verknüpfung weg, Häkchen im Profilmanager rein und diese Einstellung auf true gesetzt. Jetzt muss ich nur noch testen, ob die Einstellung bei mir tut, was sie tun soll.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress

  • So, auch der automatische Neustart hat geklappt. Vorerst im Nightly.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress

  • So, auch mit Fx 127 hat der automatische Neustart geklappt. Beide Versionen gleichzeitig und mein „Rentner“ hier ist nicht einmal in die Knie gegangen.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress

  • Bei mir klappt es aber trotzdem nicht.

    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:128.0) Gecko/20100101 Firefox/128.0, Windows 11 Pro Version 24H2 (Build 26100.1150)

  • hallo,

    was bewirkt denn die Option "Firefox automatisch öffnen, wenn der Rechner gestartet wird"? Wird der FF nach dem Reboot im Hintergrund geladen oder öffnet sich gar ein Firefox Browser-Fenster im Vordergrund nach den PC Neustart?