Falsche Schriftdarstellung seit Firefox 89

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Firefox-Version
    89
    Betriebssystem
    Windows 8.1 Pro 64 Bit

    Hallo zusammen,


    seit dem Update auf Firefox 89 habe ich auf einigen Webseiten eine falsche Darstellung von Schriften. Sie sind noch lesbar, aber die Buchstaben sind fetter und laufen teilweise ineinander. Beispiel (Anmeldeseite meines Webmailers):



    So sollte es aussehen:



    Die Anzeige ist korrekt, wenn ich Firefox im Fehlerbehebungsmodus starte, also scheint es an einer Einstellung in meinem Profil zu liegen. Wenn ich das Profil jedoch manuell bereinige (= prefs.js umbenenne, Ordner chrome umbenenne, alle Erweiterungen manuell deaktiviere), tritt das Problem nach wie vor auf. Nicht einmal der Start mit einem ganz leeren Profilverzeichnis behebt das Problem. Das Theme ist "System-Theme 1.2".


    Hat sonst noch jemand dieses Problem und evtl. eine Idee, wo ich noch suchen könnte? Danke.

  • Hallo,


    du hast vergessen, den Link zu nennen. Ohne den kann natürlich niemand prüfen, ob das Problem für andere reproduzierbar ist, was auch bei der Eingrenzung der Ursache helfen könnte.


    Da das Problem im Fehlerbehebungsmodus nicht auftaucht, hast du schon diese Schritte durchgearbeitet?

    https://support.mozilla.org/de…cherten-modussf-nicht-auf

  • Yepp, habe ich - insbesondere das, was im dort verlinkten Artikel https://support.mozilla.org/de…nd-hardwarebeschleunigung steht: Alle Erweiterungen abgeschaltet, am Theme habe ich nie etwas verändert, sogar die Hardwarebeschleunigung habe ich testweise abgeschaltet, obwohl die Grafikkarte samt Treiber seit Jahren dieselbe ist (Chipgrafik eines Intel Core i5-4570). Sogar mit einem ganz neuen Profil habe ich es versucht, ohne Änderung: Im Fehlerbehebungsmodus tritt das Problem nicht auf, sonst schon.


    Noch stärker als in den gezeigten Screenshots ist es bei der mobilen Version derselben Seite zu sehen: https://mobimail.kasserver.com/ - bei Standardansicht (100%) ist ganz oben statt "E-Mail" "E-Mall" zu lesen, weil der i-Punkt mit dem Rest des Buchstaben zusammenläuft. Ab 110% ist zumindest das "i" als solches lesbar, doch auch dort sehen die Texte anders (fetter und unruhiger) aus als im Fehlerbehebungsmodus.


    Sehe gerade: Auch http://www.ebay.de zeigt das Phänomen. http://www.heise.de und dieses Forum hingegen nicht.

  • mobimail

    Code
    html, body, input.text, select, option, textarea {
    font-family: helvetica,arial,tahoma,verdana,sans-serif;
    color: #333;
    font-size: 1em;
    }


    Und Ebay hat sowas nicht, das funktioniert anders

    font-family: Arial,Helvetica,sans-serif;


    Hast du in den Firefox-Einstellungen das Verwenden von Schriftarten in Webseiten abgeschaltet?

    Siehe auch

  • Gerade geprüft: Nein, habe ich nicht, das Häkchen bei "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" ist gesetzt. Überdies würde ich ja erwarten, dass diese Einstellung irgendwo im Firefox-Profil gespeichert wird (prefs.js?) und bei Benutzung eines leeren Profilverzeichnisses wieder auf Default zurückgesetzt wird. Doch damit alleine ist es ja nicht getan, nur der "Fehlerbehebungsmodus" behebt den Fehler...

  • nur der "Fehlerbehebungsmodus" behebt den Fehler...

    Auch die Verwendung von CSS und Benutzerskripten wird im Fehlerbehebungsmodus deaktiviert ...

    das Häkchen bei "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" ist gesetzt

    Die falsche Wiedergabe der Schriftarten kann auch von der Website verursacht werden. Mache also hier mal das Häkchen raus und teste.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Auch die Verwendung von CSS und Benutzerskripten wird im Fehlerbehebungsmodus deaktiviert ...

    Wird im Fehlerbehebungsmodus tatsächlich jegliches CSS deaktiviert? Das würde ja die Darstellung nahezu jeder Webseite kaputtmachen...

    Die falsche Wiedergabe der Schriftarten kann auch von der Website verursacht werden. Mache also hier mal das Häkchen raus und teste.

    Bingo :thumbup: Jetzt ist es in Ordnung, sowohl beim Webmailer als auch bei Ebay! Doch macht das vermutlich andere Webseiten kaputt, die eigene Schriftarten verwenden - und warum tritt das Problem genau seit dem Update auf Firefox 89 auf?

  • Wird im Fehlerbehebungsmodus tatsächlich jegliches CSS deaktiviert? Das würde ja die Darstellung nahezu jeder Webseite kaputtmachen...

    Der Fehlerbehebungsmodus ist nur zum Testen bzw. zum Finden der Problemursache da. Man surft nicht dauerhaft im Fehlerbehebungsmodus. Findet man dadurch ein Problem, muss man das Problem lösen, um es nicht mehr zu haben.


    und warum tritt das Problem genau seit dem Update auf Firefox 89 auf

    Tritt es denn mit einem anderen Browser auf?

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

    Einmal editiert, zuletzt von milupo () aus folgendem Grund: Ein Beitrag von milupo mit diesem Beitrag zusammengefügt.

  • Es geht um CSS, welches (vorwiegend) in Firefox angewendet wird (userChrome.css), nicht in Webseiten, das ist davon nicht betroffen.

    Nö, es geht um Webseiten, siehe Beitrag #1. Das betrifft dann auch nicht die userChrome.css, sondern die userContent.css. Aber wie es scheint, liegt das Problem nicht bei CSS, sondern bei der Website.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Tue das. Eigentlich wünscht man ja dann: „Morgen wieder, in alter Frische.“ Aber wenn das dann die Frische von jetzt ist, ist das auch nicht so optimal. :)

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Ja, das Problem tritt nur in Firefox auf und nur seit der Installation von Version 89. Und ein kaputtes userChrome.css sollte bei einem nackten Profilverzeichnis ja auch weg bzw. auf Default sein, oder nicht?


    Ich habe jetzt noch einen anderen Verdacht, nach einigem Herumspielen im Entwicklerwerkzeug mit "font-family" des genannten Webmailers: Wenn ich das "Helvetica" da rauslösche, funktioniert es auch mit gesetztem "Eigene Schriftarten"-Häkchen. Und auf meinem Notebook tritt das Problem nicht auf, es dürfte also an meinem PC liegen. Doch was hat das mit Firefox 89 zu tun?

  • Möglicherweise habe ich die Ursache nun gefunden. Auf meinem PC ist eine Schriftart namens "Helvetica-Bold" installiert. Wo die herkommt, weiß ich nicht, möglicherweise mit einer irgendwann installierten Anwendung, vielleicht sogar mal absichtlich vor längerer Zeit, irgendwo aus dem Internet heruntergeladen, was weiß ich. Deinstalliere ich diesen Font, ist alles in Ordnung.


    Offen bleibt, warum dieser Font erst mit Firefox 89 zum Störenfried wurde. Ich habe definitiv nicht zeitgleich mit dem Firefox-Update irgendeine Anwendung installiert.


    Danke an alle Mitdiskutanten, insbesondere an @.DeJaVu, der mich mit seiner CSS-Analyse auf das richtige Gleis geschickt hat.

  • Möglicherweise habe ich die Ursache nun gefunden. Auf meinem PC ist eine Schriftart namens "Helvetica-Bold" installiert. Wo die herkommt, weiß ich nicht, möglicherweise mit einer irgendwann installierten Anwendung, vielleicht sogar mal absichtlich vor längerer Zeit, irgendwo aus dem Internet heruntergeladen, was weiß ich. Deinstalliere ich diesen Font, ist alles in Ordnung.


    Offen bleibt, warum dieser Font erst mit Firefox 89 zum Störenfried wurde. Ich habe definitiv nicht zeitgleich mit dem Firefox-Update irgendeine Anwendung installiert.


    Danke an alle Mitdiskutanten, insbesondere an @.DeJaVu, der mich mit seiner CSS-Analyse auf das richtige Gleis geschickt hat.

    Danke für den Hinweis mit der Schriftart. Nach Löschung scheint das Problem verschwunden zu sein.


    Bei "Häkchen rein" / "Häkchen raus" wurden immer einige Seiten nicht so dargestellt wie vorher.

  • Das eigentliche Problem dahinter dürfte eine Substitution sein. Wenn ein bestimmter Font nicht gefunden wird, wird ein möglichst ähnlicher Ersatz gesucht. Ob das jetzt was neues in Firefox ist, oder Adobe das so in Windows hinterlegt hat (das gibt es schon sehr lange unter Windows), müsste man so herausfinden.

    https://social.technet.microso…ther-font?forum=w7itproui


    Im besagtem Zweig

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes

    steht unter Windows 10 zB "Helvetica"="Arial"


    Ergo müsste Adobe dort was verändert haben. Somit wird der Fehler nicht von Firefox verursacht, sondern nur angezeigt.


    Man könnte es händisch korrigieren, oder auch Helvetica (Normal) installieren.