Ton Aus auf Tab funktioniert nicht

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Firefox-Version
    79
    Betriebssystem
    Windows 10/64 - 2004

    Habe bemerkt dass "Ton Aus" auf einen Tab nicht funktioniert.

    Damit meine ich das Lautsprecher-Symbol, welches sich auf dem Tab befindet. Klicke ich drauf, passiert nichts.

    Das Problem zeigt sich auf allen Seiten.



    Es liegt an diesem Script:

    Das nennt sich Tabs_mehrzeilig.uc.js

    Aber aufgrund des Umfangs vermute ich, dass in diesem Script noch andere Funktionien enthalten sind und nicht nur, dass die Tabs mehrzeilig dargestellt werden.

    Die Höhe eines Tabs wird auf jeden Fall noch beeinflusst. Mit Script ist ein Tab etwas höher als ohne Script.



    Hat jemand eine Idee, wo der Fehler liegt?


    edit:


    Habe jetzt noch mal getestet, was ohne dieses Script nicht mehr funktioniert.

    Es ist die mehrzeilige Tableiste und es ist die Tabhöhe, die sich ohne Script etwas verringert.


    Vielleicht kann mir jemand ein Script für die mehrzeilige Tableiste geben und ein Script, damit ich die Höhe eines Tabs bestimmen kann.

    Dieses benutzte Script ist auch schon älter und müsste evt. erneuert werden.


    edit 2:


    So sieht es mit der Anordnung der Leisten aus. Das stellt sich auch ohne besagtes Script so dar und das ist korrekt und soll so bleiben.


  • Ich bin mir nicht sicher, aber wenn du magst teste bitte mal:/


  • Habe jetzt bemerkt, dass bei der Nightly-Vers.

    81.0a1

    Build-ID 20200808213325


    die mehrreihige Tableiste mit obigen Script aus Beitrag #2 nicht funktioniert. Wenn die erste Reihe voll ist und ich einen weiteren Tab versuche zu öffnen, passiert nichts. Ton An und Aus funktioniert aber.


    Kann das jemand nachvollziehen bzw. gibt es eine Lösung?

  • Ich würde mir aber noch keine Gedanken machen, im Nightly kann es morgen schon wieder funktionieren.


    Wobei ich gerade auch sehe, Alice hat schon neue Versionen für Fx 81, die müsste Endor aber erst wieder übersetzen.

  • Wobei ich gerade auch sehe, Alice hat schon neue Versionen für Fx 81

    Wie kommst Du darauf?

    Habe bei Alice nichts gefunden.

    Aber der Autor meiner Quelle hat neue Versionen im Angebot.

    Sei es CSS Versionen oder Scripte dafür. :wink:

    Melde mich bei gleich mal per PN bei Dir 2002Andreas.
    :wink:

    Mfg.

    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Hallo zusammen.

    Die CSS Codes habe ich alle aktualisiert.

    Es sind jetzt 6 verschiedene.
    https://github.com/Endor8/user…ee/master/Mutirowtabs/CSS


    Readme muss ich noch überarbeiten - erweitern.


    Was die Scripte betrifft, da muss ich mich erst noch darum kümmern.

    Hoffe, dass ich da bald mal dazu komme.

    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Besten Dank!


    Habe gleich die 1. Ausgabe genommen und die funktioniert einwandfrei.

    Passt auch für die Release- und Beta-Version.


    https://github.com/Endor8/user…ultiRowTabLiteforFx.uc.js


    Vielleicht kann ich hier noch für die Nightly-Vers. eine Lösung bekommen:


    Im Tab-Kontextmenü sieht es so aus



    Wie bekomme ich den oberen Eintrag "In Tab-Umgebung öffnen" entfernt?


    Zeigt sich nur in der Nightly-Vers.

  • Teste bitte mal:


    CSS
    context_reopenInContainer {
    display: none !important;
    }

    Ansonsten, hast du hier evtl. den Haken drin?


    Mit freundlichem Gruß
    Andreas
    Mein Laptop    Meine Add-ons

    Einmal editiert, zuletzt von 2002Andreas () aus folgendem Grund: Ein Beitrag von 2002Andreas mit diesem Beitrag zusammengefügt.

  • Habe ja schon ein CSS für das Kontextmenü

    Wenn ich deinen Code unten anfüge, funktioniert das Ausblenden aber nicht


    Hier komplett


  • context_reopenInContainer

    Da fehlt die Raute:


    #context_reopenInContainer

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Die # fehlte auch schon bei dir......

    Bei mir? Schaue mal richtig nach.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Sorry - falsch zitiert.

    Kein Problem - bei den Temperaturen ... :) Das gilt für dich und für Andreas.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook