Empfehlungen ausblenden

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Firefox-Version
    76.0. 64bit
    Betriebssystem
    Win10 64bit Home

    Hallo

    Habe in "userContent.css" diesen Code drinnen der nicht mehr funktioniert.



    CSS
    /******************* in about:addons die Empfelungen ausblenden *************************/
    #category-discover {
    display: none !important;
    }

    Gibt es eine Lösung?


    Danke im voraus hwww

    Firefox 82.0 - 64 Bit / Windows 10 - 20H2 - 64 Bit - Home

  • Hi hwww,


    das sollte jetzt damit ↓ funktionieren.


    CSS
    .category[is="discover-button"] {
    display: none !important;
    }

    Es grüßt euch,

    Ralf

  • das sollte jetzt damit ↓ funktionieren.

    Hallo Dharkness

    Besten Dank! Funktioniert!


    Wünsche dir noch eine schöne Corona frei Woche hwww

    Firefox 82.0 - 64 Bit / Windows 10 - 20H2 - 64 Bit - Home

  • Die Empfehlungen im Reiter "Erweiterungen" von about:addons kann man in about:config mit


    extensions.htmlaboutaddons.recommendations.enabled=false


    ausblenden. Und den eigenen Reiter "Empfehlungen" mit


    extensions.getAddons.showPane=false


    Letzteres ist eine versteckte Option, die man erst anlegen muss.


    Ich habe gerade beide Optionen im Firefox 76 ausprobiert. Momentan funktionieren sie. Ob die versteckte Option irgendwann einmal entfernt wird, weiß ich nicht.

  • Hi geminus,


    merkwürdig, die 2te Pref zeigt hier keine Wirkung, auch nach einem Neustart von Fx nicht.

    Es grüßt euch,

    Ralf

  • Möglicherweise ist das ein Fehler in Firefox 76, der zwischenzeitlich behoben worden ist. :/ Denn laut Quellcode wird diese Einstellung bei bereits angedeuteter Enterprise Policy auch in Firefox 76 entsprechend gesetzt. Aber ich kann bestätigen, dass es in Firefox 76 nicht funktioniert, in Firefox Nightly jedoch schon. Denkbar wäre ein Fehler in Firefox 76 schon, da Firefox 76 die Version ist, in welcher die Sidebar des Add-on Managers von XUL in HTML konvertiert worden ist, und dabei wurde definitiv auch dieser Code angefasst. Dabei könnte sich natürlich ein Fehler eingeschlichen haben. Ich habe jetzt aber auch nicht die Zeit, das genauer zu untersuchen. Vielleicht später. Aber wie gesagt: In der Nightly-Version funktioniert das auf jeden Fall (wieder).

  • Hallo Sören,


    ich habe die → extensions.getAddons.showPane Pref jetzt nochmal im Testprofil mit Fx 76, der war es natürlich auch beim ersten Test mit meinem Hauptprofil, überprüft, im Testprofil zeigt die Pref ihre Wirkung. :(

    Es grüßt euch,

    Ralf

  • Hallo @all,


    nun muss ich in der Tat zurückrudern, bei mit hat ein Eintrag ↓ in der userContent.css dafür gesorgt, das die Pref ihre Wirkung nicht zeigen konnte.

    CSS
    #categories .category[hidden=""] {
    -moz-appearance: none !important;
    opacity: 1 !important;
    }

    Was man so alles im Kopf behalten muss. :saint:

    Es grüßt euch,

    Ralf

  • im Testprofil zeigt die Pref ihre Wirkung

    Interessant. Tatsächlich habe ich nach der Installation von Firefox 76 das bisherige Profil durch ein neues ersetzt. Ich habe meinen Tipp sicherheitshalber vor dem Posten ausprobiert, weil ich diese Option schon lange nicht mehr verwendet habe, und sie hat funktioniert.

  • kann man in about:config...

    Besten Dank! Mein css-Code tat es nicht mehr und beide deiner Vorschläge klappen in 77.0b2 bestens! :thumbup:

    Gruß
    Manfred


    FF in aktueller Betaversion, auf MacBook Pro 15" Late 2015 unter macOS Mojave 10.14.6