Suchmaschinen-Leiste deaktivieren

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hallo,


    es wäre nett, wenn mir jemand sagen könnte, wie ich diese Leiste mit den darin aufgeführten Suchmaschinen komplett enfernen kann. Evtl. mit einem Script?

    Vielen Dank im Voraus


    Ogi

  • Rechtsklick in der Titelleiste, Anpassen auswählen und die Suchleiste in das freie Feld ziehen. Dann unten rechts Fertig klicken.

    MfG
    Geldhügel

  • Danke für die Antwort, ich nutze die Adressleiste mittels Schlüsselworten, deswegen keine extra Suchleiste. Win7, Quantum, letzte Version.


    Danke, Ogi

  • Um es vielleicht etwas verständlicher zu machen, ich gebe z.B. in die Adressleiste "G Test" ein. Daraufhin öffnet sich darunter eine dunkelblaue Leiste mit div. Suchmaschinensymbolen. Diese Leiste möchte ich gerne entfernen.


    mfG, Ogi

  • Hallo und Willkommen hier im Forum.


    In Beitrag Nr. 5 in dem gegebenen Link, war der Code dafür enthalten:


    CSS
    #urlbar-results,
    #urlbar:not(.megabar) .search-one-offs {
    display: none !important;
    }

    Einzutragen in die userChrome.css Datei.

    Sieht dann so aus:



    Es wird keine Suchleiste mehr angezeigt.

  • Danke für die Antwort, ich nutze die Adressleiste mittels Schlüsselworten, deswegen keine extra Suchleiste. Win7, Quantum, letzte Version.

    Nur zur Klarstellung. Die Suchleiste ist das:


    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Rechtsklick in der Titelleiste, Anpassen auswählen und die Suchleiste in das freie Feld ziehen. Dann unten rechts Fertig klicken.

    Hallo geldhuegel, ist zwar hier doch nicht relevant, aber mit eingeblendeter Titelleiste klappt das nicht. Du verwechselst das sicher mit der Menüleiste, weil du die Titelleiste ständig ausgeblendet hast.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Hallo und Willkommen hier im Forum.


    In Beitrag Nr. 5 in dem gegebenen Link, war der Code dafür enthalten:


    CSS
    #urlbar-results,
    #urlbar:not(.megabar) .search-one-offs {
    display: none !important;
    }

    Hallo Andreas,


    kurze Frage zu deinem Code.

    Ich habe u. a. diesen hier in meiner userCrhome.css eingetragen:

    CSS
    #urlbar-results {
    display: none !important;
    }

    Inwiefern unterscheidet sich deiner in der Wirkung zu meinem?

    Muss dazu sagen, dass ich auch Aris' CustomCSSforFx verwende und dort mögicherweise auch eine Option gegen dieses Suche-PopUp gewählt hab (hab jetzt nicht extra nachgesehen). Kann es sein, dass mein obiger Code tatsächlich wirkungslos ist?

    Gruß
    Manfred


    FF in aktueller Betaversion, auf MacBook Pro 16" unter macOS Catalina 10.15.3 + MacBook Pro 15" Late 2015 unter macOS Mojave 10.14.6

  • #urlbar:not(.megabar) .search-one-offs


    megabar ist schon für spätere Fx Versionen, search-one-offs für die Suchleiste nur mit der eingestellten Suchmaschine.


    Bei nur:

    #urlbar-results


    wird trotzdem die dicke Suchleiste eingeblendet, wenn man ein Zeichen in die Adressleiste eingibt.

  • 2002Andreas,


    vielen Dank für deine Hilfe, der Ansatz war wohl richtig, nur ganz geklappt hat es noch nicht, siehe Bild. Ich habe immer noch einen blauen Balken, der die Lesezeichen-Leiste verdeckt. Vielleicht hast du ja noch eine Idee, danke im Voraus. Beste Grüsse Ogi