Ansicht "Erweiterungen verwalten"

  • Das Menü mit den drei Punkten wird es weiterhin geben, darin befindet sich ja auch ein Link zu den Einstellungen und eine Melden-Funktion, was eine komplett neue Funktion des neuen Add-on Managers darstellt. Mozilla musste sich hier zwingend aus Platzgründen was überlegen. Der Beschreibungstext konnte schlecht noch weiter gekürzt werden, sonst wäre der ganz weg gewesen. Nur ist eben jetzt der Kompromiss, diese zwei häufigen Aktionen zurück in die erste Ebene zu holen.

  • Ich wüsste jedenfalls nicht, wozu. Die Melden-Funktion ist ganz neu, die gab es zuvor 15 Jahren lang nicht und fehlt auch in eurer jetzigen Anpassung. Bleiben nur die Einstellungen. Aber ich kann mich nicht erinnern, jemals den Weg über den Add-on Manager gegangen zu sein. Alle Erweiterungen, die ich nutze, haben in ihrer eigenen Oberfläche einen Zugang zu den Einstellungen, den ich bisher immer genutzt habe. Aber wer das unbedingt haben muss, ja, der muss weiterhin anpassen.

  • Ja, andere arbeiten halt anders...:)

    Ich arbeite viel im Addons-Manager und möchte gerne dort direkt auf Aktualisieren, Einstellungen, Aktivieren/Deaktivieren und Deinstallieren schauen.. die Melden-Funktion wäre mir nicht so wichtig...

  • Hallo!

    Den Code aus Beitrag #20 habe ich für die Auflösung 1920x1080 meines Laptop angepasst (siehe Bild). Sieht sehr gut aus, finde ich. Aber ich habe festgestellt, dass es doch drei "Schönheitsfehler" gibt. Ich möchte diese hier mal auflisten, eventuell gibt es ja doch Lösungen dafür.


    1. Bei > hover < sollen die Button auf der rechten Seite, wenn ich es richtig deute, eigentlich blau sein, sie sind aber rot. Ist mir auch egal

    welche Farbe da kommt, aber der Code stimmt dann wohl nicht.


    2. Die Schrift der rechten Button liegt nicht zentriert.


    3. Beim Anklicken der rechten Buttons und auch des Button mit dem Zahnrad (siehe Bild) erscheint ein Hintergrund (rechts grau), der

    nicht mit den Größen der sichtbaren Teile übereinstimmt (eckig).



    Wer kann Abhilfe schaffen?


    Grüße

    FuchsFan


    Edit:

    Hier dann noch der verwendete Code:


    Bilder

    • Hintergrund.PNG
    • Hintergrund.PNG

    Einmal editiert, zuletzt von FuchsFan ()

  • Zu 1:

    Die linken Button und der mit dem Zahnrad, sollen und sind bei hover blau.


    Zu 2:

    Das liegt an deiner eingestellten Auflösung.


    Ändern musst du das ab Zeile 28 ( bzw. ab Zeile 21 in deinem Code) bei dem Eintrag


    .more-options-menu addon-options panel-list panel-item[action="remove"]


    und den anderen Button, incl. der hover Einträge.

    mit den Werten für padding.


    Zu 3:

    Hier ist kein weiterer Hintergrund zu sehen.

  • So, Punkte 1. und 2. sind abgearbeitet. Sehr schön!!! 👍


    Nun aber zurück zu Punkt 3. Hier, Andreas, ist doch was im Argen. Rufe ich den Manager auf, dann ist alles bestens. Klicke ich aber z.B. auf Verwalten und halte die Maus gedrückt, so ist im Hintergrund eine rechteckige Formation (ich sage mal Farbe Grau) zu erkennen.

    Das passiert auch bei dem Zahnrad-Symbol, siehe dazu das Bild oben, deswegen hatte ich es eingefügt.


    Hast du da noch was auf Lager, wie das abzuändern wäre. Dann bin ich wieder glücklich, denn ich habe den Code bis zur aktuellen Nightly probiert, und läuft.


    Grüße

    FuchsFan

  • licke ich aber z.B. auf Verwalten und halte die Maus gedrückt, so ist im Hintergrund eine rechteckige Formation (ich sage mal Farbe Grau) zu erkennen.

    Das passiert auch bei dem Zahnrad-Symbol, siehe dazu das Bild oben, deswegen hatte ich es eingefügt.

    Meines Erachtens liegt der Grund in den Zeilen 249 - 257. Dort legst du u.a. für die Zahnradschaltfläche (preferencesbutton) Silber als Hintergrundfarbe fest, die so ähnlich wie Grau aussieht. Lösche die Zeile 254 oder kommentiere sie aus, um zu sehen, ob das die Ursache ist.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

    Einmal editiert, zuletzt von milupo ()

  • @milupo


    Danke, für deine Unterstützung. Die Reihenfolge entspricht z.Z. nicht mehr meinem eingestellten Code. Ich kann aber sagen, dass ich den von dir angesprochene Block vollkommen gelöscht habe, weil er nicht gebraucht wird , besser gesagt keine Reaktion auslöst. Bisher kommen noch zwei weitere dazu. Das sind die drei:


    Grüße

    FuchsFan

  • Bitte auch wieder testen:

    War kurz weg, und siehe da, der Andreas wirft den neuen Code rein.

    Suuuuuuuupeeeeeeeerrrr!!!

    Danke, Andreas, Hintergrund ist beim Anklicken weg, sehr schön gelöst.


    In der Zwischenzeit bin ich aber noch auf ein Problem gestoßen, und zwar bei Plugins. Ich habe da vorher nie hingeschaut, jetzt durch Zufall entdeckt. Siehe Bild. Auch fehlen die Button zum Aktivieren (usw.) , obwohl sie im Code eingetragen sind.

  • Das liegt daran, dass ich keine Plugins verwalten muss ausser openh264 und widevine. Der Style von mir blendet die "..." aus, bindet aber nicht die Funktionen dahinter ein wie bei Erweiterungen. Daher auch nie einen Gedanken daran verschwendet und kontrolliert. Wenn man weiss, wie der Button heisst, kann man den bestehenden Style auf das unbekannte umsetzen. Mach(t) was draus.