FX 68: Überflüssige "Empfehlungen" abschalten

  • Moin zusammen,


    ich nutze seit heute den FX 68.0, dabei ist mir leider aufgefallen, daß trotz angeblich nicht vorhandener Datenauswertung nun alle möglichen Einstellungs- und Addon-Seiten mit "Empfehlungen" zugemüllt werden. Dadurch leidet die Übersichtlichkeit doch erheblich und ich finde nirgends eine Möglichkeit, diese Belästigung erfahrener Benutzer abzuschalten. Sind Euch diesbezüglich irgendwelche Kniffe (gerne auch in about:config) bekannt, um wieder die Übersicht zu bekommen? :thumbdown:

    Aloha, Uli
    Firefox Tete009 - immer letzte Version (die mit den neuen Fehlern in der Oberfläche)
    Trottel werden nicht geboren, schöne Frauen stellen sie in ihrer Freizeit her.
    Note to myself: Never argue with morons, they pull you down on their level and beat you with experience!

  • Hallo,


    du musst extensions.htmlaboutaddons.recommendations.enabled in about:config auf false setzen.


    PS:

    Belästigung erfahrener Benutzer


    Man mag Empfehlungen haben oder mag diese nicht, das hat aber nichts mit Erfahrung der Benutzer zu tun. Ich kenne genauso erfahrene Nutzer, die das toll finden, wie auch unerfahrene, die das nicht brauchen. ;)

  • Funktioniert! Super, besten Dank! :thumbup:


    [edit]

    Habe eben noch zusätzlich bemerkt, daß sich Firefox 68 mal wieder einen extra großen Schluck aus der RAM-Pulle gönnt und zuviel CPU-Zeit verballert, obwohl ich ihm das doch erst vor Kurzem schon mal abgewöhnt hatte. X(

    Da bin ich bei der Websuche auf Folgendes gestoßen: You can’t turn off e10s (Multi-Process) in Firefox 68

    Dank des Tricks konnte ich Firefox zum Glück wieder in seine Schranken verweisen. 8o

    Aloha, Uli
    Firefox Tete009 - immer letzte Version (die mit den neuen Fehlern in der Oberfläche)
    Trottel werden nicht geboren, schöne Frauen stellen sie in ihrer Freizeit her.
    Note to myself: Never argue with morons, they pull you down on their level and beat you with experience!

    3 Mal editiert, zuletzt von UliBär () aus folgendem Grund: Weitere Auffälligkeiten entdeckt

  • Das mag durchaus so sein, aber wenn auf einem echten Vierkerner der parallel laufende Maven-Build-Prozess eines größeren Eclipse-Projektes durch einen auf dem gleichen Rechner in Benutzung befindlichen Firefox extrem ausgebremst wird, hört für mich der Spaß auf.


    Jedenfalls läuft der Firefox so gefühlt deutlich schneller, geschmeidiger und ohne die 3-5 Sekunden "Denkpausen", die mich irgendwie an die Garbage-Collection von Java im klassischen Sinne erinnern. Auch der RAM-Verbrauch geht nicht mehr in die mehrere GBs, sondern bleibt unterhalb der 1GB Marke.


    Ich konnte durch den ganzen bisherigen multithread-Umbau jedenfalls keinerlei Steigerung der Geschwindigkeit von Firefox feststellen, eher fiel mir das Gegenteil so unangenehm auf, daß ich mich an die Erforschung der Ursachen gemacht habe und eine Lösung (für mich!) gefunden habe. Wer weiß allerdings, wie lange die noch funktioniert...


    [edit]

    Apropos Sandboxing: Eine parallel laufende Virtual-Box-Installation mit einem kompletten Linux und laufendem Docker-Image einer größeren Anwendung bremst nicht annähernd so stark, wie ein normal konfigurierter Firefox, der parallel läuft... :/

    Aloha, Uli
    Firefox Tete009 - immer letzte Version (die mit den neuen Fehlern in der Oberfläche)
    Trottel werden nicht geboren, schöne Frauen stellen sie in ihrer Freizeit her.
    Note to myself: Never argue with morons, they pull you down on their level and beat you with experience!

  • Wenn der Firefox "exclusiv" läuft, dann auch bei mir.

    Mein Rechner existiert aber nicht ausschließlich um Firefox zu dienen, der macht auch noch Anderes nebenher und das geht mit den neueren Füchsen nicht mehr richtig...

    Aloha, Uli
    Firefox Tete009 - immer letzte Version (die mit den neuen Fehlern in der Oberfläche)
    Trottel werden nicht geboren, schöne Frauen stellen sie in ihrer Freizeit her.
    Note to myself: Never argue with morons, they pull you down on their level and beat you with experience!

  • Wie gesagt, kann ich nicht bestätigen. Und wenn es nicht klappt, das wird sich auch in Zukunft nicht ändern - entweder trennen sich eure Wege oder du freundest dich mit der Fehlersuche bzw der Code-Suche an, wie man das entsprechend ausblendet

    -> Browser-Werkzeuge.


    Du hast nach Hilfe gefragt, du hast Antworten erhalten, es liegt nicht an uns, wenn sie dir nicht gefallen. Und wenn du nicht mitarbeiten willst, muss du letztlich auch selbst nach der Lösung suchen, denn die Antwort von Sören ist schon die ultimative Antwort, das funktioniert sogar aktuell bis v70.

  • Auf die Frage von .Dejavu, bitteschön:


    Falls Du damit etwas anfangen kannst, nur her mit den Infos.

    Jedenfalls hilft selbst kein neues Profil, sondern nur das Abschalten der e10s.

    Aloha, Uli
    Firefox Tete009 - immer letzte Version (die mit den neuen Fehlern in der Oberfläche)
    Trottel werden nicht geboren, schöne Frauen stellen sie in ihrer Freizeit her.
    Note to myself: Never argue with morons, they pull you down on their level and beat you with experience!

  • Kann man unter about:addons in der linken Spalte die Rubrik Empfehlungen auch ausblenden?

    Probiere mal das:


    CSS
    1. #category-discover {
    2. display: none !important;
    3. }

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Das gehört in die userContent.css... ;)

    Ja, habe ich vergessen hinzuzufügen. Sorry. Alle about:-Seiten gehören in die userContent.css, sie sind Seiten, obwohl sie zu Firefox gehören.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Edit: Siehe Nachtrag!

    Ich habe diese Regel seit Jahren in Gebrauch, im neuen Design (ab Fx 68) wurden mir aber zusätzlich am unteren Ende Empfehlungen angezeigt, die man mit

    CSS
    1. recommended-extensions-section,
    2. recommended-themes-section
    3. { display: none !important; }

    ausblenden kann. Man kann die drei Selektoren auch kombinieren:

    CSS
    1. #category-discover,
    2. recommended-extensions-section,
    3. recommended-themes-section
    4. { display: none !important; }


    Nachtrag: Zufällig habe ich an anderer Stelle mitbekommen, dass es dafür mit dem neuen Interface Konfigeinstellungen gibt:


    extensions.htmlaboutaddons.discover.enabled

    extensions.htmlaboutaddons.recommendations.enabled