userChrome.js Scripte für den Fuchs (Diskussion)

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Die Diskussion ist ja schon längst weiter, aber ich möchte mich hier trotzdem noch für das verbesserte WordHighlightToolbar-Skript bedanken, das ich nach einer Reise vorgefunden habe. Vielen Dank an alle Beteiligten. :klasse:

  • Hallo miteinander,
    bei mir funktioniert (schon seit einer Weile, nicht erst seit FF 50) OpenBookModoki.uc.js nicht mehr richtig.

    • Die Schaltfläche "Lesezeichen löschen" erscheint nur beim ersten Aufrufen des Dialogfensters nach einem Start von FF, danach fehlt sie
    • Wenn ich nach dem Speichern eines Lesezeichens den Ordner auswählen will (rechter Pfeil, alle Lesezeichenordner anzeigen) schließt sich das Dialogfenster. Um einen Ordner zu wählen, muss ich das Dialogfenster ein zweites Mal öffnen


    Kann das jemand bestätigen?
    Danke.

  • zu 1.:


    Bei mir fehlt der Button "Lesezeichen entfernen", wenn eines angelegt wird. Ist es bereits vorhanden, ist der Button da. Das ist also anders, als von dir beschrieben, aber auch nicht richtig, denn der Button muss immer da sein.
    Teste das folgende geänderte Skript. Bei mir ist damit der Button immer vorhanden.



    zu 2.:


    Seit Fx 47 wird beim Anlegen eines Lesezeichens das Panel geöffnet und dann automatisch geschlossen, wenn man darin 3,5 Sekunden nichts oder nichts mehr tut.
    Siehe dazu auch https://www.camp-firefox.de/forum/viewtopic.php?f=1&t=118195
    Mit folgendem Skript kann man die Zeitdauer verändern, sie wird in Zeile 4 in Sekunden eingetragen:


    Code
    (function() {
       if (!window.StarUI)
          return;
       const delaySec = 10;
       eval('StarUI.handleEvent = ' + StarUI.handleEvent.toString()
          .replace(/delay = \d+/, 'delay = ' + (delaySec * 1000).toString()));
    })();
  • Hallo aborix,
    vielen Dank.
    Das Skript für die Zeit scheint zu funktionieren, muss ich noch mit mehr Zeit testen.
    Der Löschbutton wird jetzt wieder immer angezeigt - nur leider funktioniert er nicht :-(
    Das Lesezeichen wird nicht gelöscht.

  • Zitat von aborix

    Kommen beim Öffnen des Panels oder beim Klick auf den Button JS-Meldungen in der Browserkonsole?


    Beim Öffnen des Panels kommen diese Meldungen:

    Code
    TypeError: TreeStyleTabBookmarksServiceEditable.parentRow is null[Weitere Informationen]  OpenBookModoki_fix.uc.js:311:7
    TypeError: TreeStyleTabBookmarksServiceEditable.parentRow is null[Weitere Informationen]  OpenBookModoki_fix.uc.js:319:9
    TypeError: this.menulist is null[Weitere Informationen]  bookmarksOverlayEditable.js:359:7


    bookmarksOverlayEditable.js kommt vom Add-on TreeStyleTabs. Wenn ich TreeStyleTabs deaktiviere, geht der Löschbutton.

  • Sehen die Zeilen 307, 311 und 319 in OpenBookModoki_fix.uc.js so aus:

    Zitat


    TreeStyleTabBookmarksServiceEditable.parentRow.collapsed = true;


    Wenn ja, ersetze sie testweise durch


    Code
    {try {TreeStyleTabBookmarksServiceEditable.parentRow.collapsed = true;} catch(e) {}};
  • Der Löschbutton geht leider noch nicht. Die Meldungen bzgl. OpenBookModoki_fix.uc.js sind verschwunden, die bzgl. bookmarksOverlayEditable.js (TreeStyleTabs) bleibt.
    Habe mal OpenBookModoki_fix.uc.js deaktiviert. Dann funktioniert der Löschbutton und auch die Meldung bzgl. bookmarksOverlayEditable.js taucht nicht mehr auf.

  • Zitat von aborix

    Ich habe in Tree Style Tab etwas geändert.
    Teste die angehängte Version, vorher die Endung .zip in .xpi ändern.


    Vielen Dank.
    Mit dieser Version funktioniert der Löschbutton.
    Jetzt reagiert das bisherige OpenBookModoki auch bei mir so, wie bei dir: Der Löschbutton wird erst bei einem gesetzten Lesezeichen angezeigt, dann aber immer.
    Wie kann's jetzt weitergeh'n?

  • Hallo,


    hat von euch einer eine Idee, warum Load URL In New Tab (Klick mich) nicht mehr funktioniert? Ich meine, dass es mit Fx 49 noch Eingaben in der Adressleiste in einem neuen Tab öffnete.


    Test habe ich bereits (erfolglos) mit anderem Profil durchgeführt.

  • Abend geschätzter Kamerad.
    Richtig beobachtet. Vor 50 war noch alles gut, ab 50 alles wieder für n Arsch, weil Mozilla an den Urlbar- Innereien wohl geschraubt hat :?
    Leider betrifft das jetzt alle Scripte aus unserer Sammlung, die sich mit dem Thema "neuer Tab aus der Adressbar" beschäftigen :roll:


    Ich habe hier mal ein Schnipsel abgegriffen, welches zumindest laut japanischer :!: Beschreibung genau dieses "Fehlverhalten" der Adressbar wieder korrigieren soll. Bin aber leider noch nicht dazu gekommen, es selbst auf Funktionalität zu prüfen.


    1:1 Übersetzung:

    Zitat

    Öffnen Sie in einem neuen Tab aus der URL-Leiste in FX50 oder später funktioniert nicht Fix


    Und der Javascriptcode dazu:

  • Danke, dunkler Gebieter.


    Die letzte Zeile:

    Code
    }());


    musste ich entfernen, jetzt funktioniert es wieder. Wenn man mit gedrückter ALT-Taste abfeuert, wird der neue Tab unterdrückt (also das Gegenteil vom unbehandelten Firefox).

  • Wer das Script "SupportMozilla.uc.xul" nutzt, muss den Code anpassen, da sich die Adresse geändert hat...
    Zeile 9 muß nun so aussehen

    Code
    openUILinkIn("https://support.mozilla.org/t5/Mozilla-Hilfe-Deutsch/ct-p/de?profile.language=de", "tab");
  • AutoPopup funktioniert in Fx 52 bei mir nicht ganz: beim Mouseover auf den kleinen Pfeil rechts in der Adressleiste öffnet sich das Menü nicht.
    Kann das jemand bestätigen?

  • Ja kann ich bestätigen.
    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Danke.


    Damit funktioniert es wieder:
    Die Zeilen 219 - 223:



    werden ersetzt durch


    Code
    if (overElt.localName == 'dropmarker') {
    			if (overElt.classList.contains('urlbar-history-dropmarker'))
    				overElt.click();
    			else
    				PopElt.showPopup();
    		} else if (overElt.localName == 'menulist') {
    			overElt.open = true;
    		} else if (IsNewMenuBtn(overElt)) {
  • Ja funktioniert wieder bestens.
    Vielen Dank.
    PS. Soll ich die beiden Updates an Mitrandir weiter geben,
    also obiges und das hier:
    https://www.camp-firefox.de/fo…ic.php?p=1031227#p1031227?
    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!