µBlock Origin Ad-Blocker -Diskussionsthread

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hätte ich gewusst, dass mein Problem eine so lange Diskussion auslösen würde, hätte ich es nicht gepostet. Für eine einzelne Seite, die dieses Problem glücklicherweise nur als einzelne hat, so viel Suche zu betreiben, ist mir - ehrlich gesagt - zu aufwändig. Darum werde ich lablue nicht mehr so häufig öffnen und dann mit der Werbung leben. Vielleicht werde ich meine Mitgliedschaft bei lablue auch kündigen.


    Ein kleiner Hoffnungsschimmer bleibt mir noch:

    Auf jeden Fall werde ich jetzt mal warten, ob mir lablue antwortet. Möglicherweise liegt das Problem auch dort, z.B. weil lablue einen Code o.ä. integriert hat, der es grundsätzlich verhindert, die Seite mit einem Adblocker zu nutzen.

  • Also das Regelwerk hier (ublock "Meine Regeln") sieht so aus


    Code
    * * 1p-script noop
    * * 3p noop
    * * 3p-frame block
    * * 3p-script block
    * * inline-script noop
    www.lablue.de www.lablue.de * allow
    www.lablue.de privacymanager.io * allow

    Die ersten 5 Einträge sind allgemein gültig und deshalb sehen die nächsten zwei genau so aus. Die könnten bei anderen Grundeinstellungen auch "noop" (grau in der Matrix) statt "allow" (grün) haben.


    "i-dont-care-about-cookies" darf nicht angeschaltet sein, bzw. lablue.de als Ausnahme setzen. Das ist mit ublock für mich nicht (mehr) einstellbar, weil ich diese Anti-Cookie-Listen in ublock nicht mehr nutze und auf die entsprechende Erweiterung gewechselt bin.


    Aber allein dieses Anti-Cookie verhindert den Seitenaufbau und bleibt beim Ladebalken (ganz oben) hängen.


    "privacymanager.io" verwaltet die von dir gezeigte Einstellungen zu Werbung etc. Da IO-Domänen hier prinzipiell gesperrt sind, wäre das mit eine Ursache für "allow" in den Regeln - es baut alles aufeinnder hier auf.

  • .DeJaVu


    Bei allem Respekt, aber Du müsstest mittlerweile wissen, dass ich kein Profi bin, Deinen Vortrag schon theoretisch nicht verstehe und daher praktisch schon mal gar nicht umsetzen kann.


    Da bleibt mir nichts Anderes übrig, als die Seite mit deaktiviertem uBlock zu nutzen.

  • Das hängt wohl mit der Änderung zusammen, die ich neulich hier erwähnt hatte. Du musst für die Matrix zweimal STRG drücken, dann erst kannst du allow/grün anwählen, vorher bleibt es bei noop und block.

  • privacymanager.io habe ich zwar grün bekommen, aber nicht mit dem Plus-Zeichen links, sondern mit einem Minus-Zeichen rechts. Aber die Werbung ist jetzt wieder verschwunden.


    Vielen Dank für Deine geduldige und kompetente Hilfe .DeJaVu .

  • Das mit dem STRG STRG fällt weg, sobald man das klassische UI eingestellt hat uiFlavor classic. Er wollte dieses UI eh irgendwann abschalten, aber genau diese Kontrolle geht nicht mehr in das UI ein, sondern ist nur im neuen UI vorhanden. Alternativ kann man die obigen Zeilen auch im Reiter "Meine Regeln" hinzufügen, deswegen schreibe ich die ja hin.

  • Hier mal der Screenshot vom Banner (immer wechselnd) - erscheint, auch wenn ich dort nicht angemeldet bin...


    M.f.G.
    Fx 81.0.2 ; WIN 10 Pro

  • Also das einzige geblockte DOM hier sind: ##div[id^="div-gpt-ad"] (Easylist) und ###overlay (eigene Filter).


    Ansonsten jenes, weil Werbehoster

    aus der gleichen Liste. Evtl. mal die Filterlisten ändern/erweitern. Selbst, wenn ich auf der Seite von der seite Script erlaube, kommt da nichts, wegen obiger Liste. Die Standardlisten von ublock sind ein guter Anfang, aber mehr auch nicht.