Alle in Tabs öffnen

  • Bitte testen..


    Code
    1. @-moz-document url-prefix(chrome://browser/content/browser.xul){
    2. menuitem[label="Alle in Tabs öffnen"]{
    3. visibility:collapse !important;}}


    Einzutragen in die Erweiterung Stylish oder der userChrome.css


    https://addons.mozilla.org/de/firefox/addon/2108


    Sollte der Ordner chrome nicht vorhanden sein musst du ihn dir erst erstellen, und in ihm dann eine userChrome.css
    Du mußt dir im Profilordner einen neuen Ordner chrome erstellen und in diesem dann eine Textdatei ( mit einem Editor ) in die du den Code kopierst, bzw. einträgst.
    Hier kopierst du als erstes folgenden Text rein:


    Code
    1. /*AGENT_SHEET*/
    2. @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
    3. @namespace html url("http://www.w3.org/1999/xhtml");


    anschließend folgt der von dir gewünschte Code.


    Dann schließt du die Datei und speicherst sie als userChrome.css ab.
    Danach mußt du den Fx neu starten.


    Wo finde ich meinen Profilordner


    Hilfe zu Stylish

  • funktioniert leider nicht :(
    Ich habe ja schon eine userCrome.css, weil ich schon einige andere Anpassungen gemacht habe.



    "Alle in Tabs öffnen" ist aber immernoch vorhanden.


    Den header

    Code
    1. @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
    2. @namespace html url("http://www.w3.org/1999/xhtml");


    Habe ich nicht drin, weil dann manche Einstellungen nicht mehr greifen.
    z.B. die Einstellung welche ich mit ".ac-emphasize-text " gemacht habe, greift nur wenn der header (mit dem namespace) nicht drin steht.


    Ich habe aber auch testweise die @namespace Zeilen rein geschrieben. "Alle in Tabs öffnen" ist aber auch dann immer noch noch sichtbar.

  • also ich habe jetzt folgendes probiert: ich habe alles aus der userChrome.css rausgeschmissen und nur noch diesen code drin:


    "Alle in Tabs öffnen" wird immer noch angezeigt. Mit einem anderen Eintrag kann es sich also nicht beissen. Kann das an einem addon liegen? Ich benutze z.B. den Chlassic Theme Restorer. Den brauche ich aber unbedingt.

  • Ich nutze den Classic Theme Restorer selbst und Dein Code funktioniert hier auch in der userChrome.css. Ob eine andere Erweiterung sich quer legt kann ich nicht sagen.


    Vorschlag: erstelle ein zusätzliches neues Profil und teste den Code darin. Klappt es dann, liegt es mit Sicherheit an einer Erweiterung oder Einstellung in Deinem Fuchs.

  • Verwendest Du eventuell die Erweiterung, Add Bookmark Here 2?
    Wenn ja, diese Erweiterung hat einen eigenen Einstellungspunkt für diesen Menüpunkt.


    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

    OS: Windows 7 H. P. 64 Bit
    Kein Support per PN. Fragen bitte im Forum stellen!

  • ich habe den Firefox natürlch neu gestartet :roll::mrgreen:
    Selbst wenn ich ein neues Profil anlege funktioniert es nicht. Habe ich gerade getestet.


    das addon, welches Endor vorgeschlagen hat funktioniert. Da wird "Alle in Tabs öffnen" ausgeblendet.
    Brauch ich halt wieder ein neues addon. Wäre mir lieber wenn das über die userChrome.css funktioniert. Seit ich erfahren habe, dass immer mehr addons verkauft und dann zum spionieren benutzt werden versuche ich möglichst wenige addons einzusetzen.

  • Zitat von alpha-nbg

    Seit ich erfahren habe, dass immer mehr addons verkauft und dann zum spionieren benutzt werden versuche ich möglichst wenige addons einzusetzen.


    Wo hast du das denn gehört? Das will ich jetzt aber mal ausschließen, dass irgendein Add-on, welches du über die Mozilla-Webseite beziehst, zum Spionieren benutzt wird. Von anderen Quellen würde ich mir grundsätzlich keine Add-ons installieren.

  • @ Sören Hentzschel


    Ich habe jetzt auch keine Erklärung, warum das bei mir nicht funktioniert. Aber jetzt weiss ich ja zumindest wie es funktionieren müsste vielleicht komme ich ja noch drauf woran es liegt.


    Vielen dank schonmal für euere Antworten :)

  • Ich habe mal testhalber Deinen ganzen Code aus Beitrag 2 in eine neue userChrome.css kopiert. Alle Codes funktionieren bei mir, auch der für das Verschwinden lassen des Tab-Eintrags.


    Wenn es bei Dir sogar in einem neuen Profil nicht klappt, vermute ich den Störenfried außerhalb von Firefox. Nur woran es genau liegen könnte weiß ich leider nicht.

  • Beim Neustart des Browsers wird doch der scriptcache Standardmäßig nicht gelöscht - oder?


    Geh ma deine Verknüpfung auf dem Desktop bearbeiten und füge ein -purgecaches hinten an.

  • Ich hab den Fehler gefunden. Ich habe die userChrome.css im ANSI Format gespeichert. :roll::shock: Und weil da ein "Ö" vorkommt (Alle in Tabs Öffnen) klappt das nicht. Einfach die userChrome.css im utf-8 Format abspeichern und schon funzt es.


    Problem gelöst. Vielen Dank nochmal für eure Hilfe!