Beiträge von alpha-nbg

    2002Andreas,

    Nein tut es nicht, der nicht aktive Tab müsste einen Ramen haben, das Menue in deinem zweite screenshot hat runde Ecken, sollte aber eckig sein (radius 0).


    milupo

    Bin ich mir nicht sicher ob das so gewollt war. Ich habe die Einstellungen teilweise selbst herausgefunden über die Entwicklerwerkzeuge, teilweise habe ich die hier im Forum erfahren.


    Hier nochmal die komplette userChrome – vielleicht ist ja irgend ein Fehler drin, der vorher toleriert wurde, jetzt aber nicht mehr:


    Da sind teilweise auch Einträge auskommentiert. Die userChrome wurde immer wieder mal verändert, wenn es erforderlich wurde. Vielleicht steht ja noch Zeug drin, das nicht mehr drin stehen sollte.

    Hallo,

    Seit dem Update auf die Version 96 funktionieren fast alle meine userChrome Einstellungen nicht mehr.
    D.h. ich darf nochmal komplett von vorne Anfangen. Die geposteten css Anweisungen haben vorher funktioniert und funktionieren jetzt nicht mehr.


    menues eckig (nicht abgerundet)

    CSS
    :root {
      --arrowpanel-menuitem-padding: 4px 8px !important;
      --arrowpanel-border-radius: 0 !important;
      /*--arrowpanel-menuitem-border-radius: 4px !important;*/
      --arrowpanel-menuitem-margin: 0 2px !important;
      /*font-size: 14px !important;*/
    }


    Alle in Tabs öffnen ausblenden

    CSS
    @-moz-document url-prefix(chrome://browser/content/browser.xhtml){
    menuitem[label="Alle in Tabs öffnen"]{
    visibility:collapse !important;}}
    
    .openintabs-menuitem{
      visibility:collapse !important;
    }

    Lautsprecher Symbol größer

    CSS
    .tab-icon-overlay {
      fill: blue !important;
      transform: scale(2.0, 2.0) !important;
    }


    Tab Rahmen anzeigen


    URLbar Schatten entfernen

    CSS
    #urlbar > #urlbar-background {
      box-shadow: none !important;
    }


    Menueelemente im Kontextmenue ausblenden

    CSS
    #appMenu-fxa-status2, #appMenu-fxa-separator {
      display: none !important;
    }
    
    #context-navigation {
      display: none !important;
    }


    Das ist erst mal das was mir sofort aufgefallen ist. Ich bin mir nicht sicher, ob noch mehr verdreht ist. Ich hoffe es lässt sich einiges davon wiederherstellen. Ich habe bereits selbst versucht herauszubekommen ob sich die css Bezeichner alle geändert haben konnte aber keine Bestätigung dafür finden. Die userChrome wird aber prinzipiell ausgeführt, weil ein paar Einstellungen greifen noch. z.b die verringerten Abstände in den Menues.
    Ich hoffe ihr könnt mir da ein wenig weiterhelfen.

    Viele Grüße,
    Armin

    Ich habs gerade auch nochmal verglichen. Es war früher deutlich erkennbar, ob der Tab gemutet ist. Bei der neuen Version ist das nicht mehr so deutlich erkennbar. – Selbst mit Brille :)



    (Oben: altes Design, Unten: neues Design)
    Beide sind gemutet.

    Hallo,

    Ich habe gerade ein paar Anpassungen am FF89 durchgeführt – u.a habe ich da z.B. den Zeilenabstand in den Menüs wieder auf einen angemessenen Wert reduziert. Da gibt es ja genug Dokumentationen im Netz. Wo ich aber leider noch nichts gefunden habe ist das Lautsprecher Symbol, welches im Tab eingeblendet wird wenn ein Medium abgespielt wird. Das ist in der neuen Version viel zu klein. Gibt es eine Möglichkeit dieses wieder zu vergrößern?
    Ich befürchte, dass dies möglicherweise nicht so einfach geht, da jetzt das Favicon ersetzt wird. Früher war das ein separates Icon.
    In meinem Screenshot wird im zweiten Tab ein Video abgespielt – Da ist das winzige Lautsprecher Symbol zu sehen, wie es bei mir aussieht.


    Viele Grüße,
    Armin

    Hallo,


    Ich habe festgestellt, dass ich bei der Linux Version vom Firefox Textfelder in der Höhe nicht schmäler als 32px machen kann.

    Code
    <input type="text" id="fname" name="fname" style="height: 20px">

    Wenn ich einen größeren Wert als 32 eingebe, funktioniert es. Ab 32 ist Schluss, schmäler wird es nicht.

    Ich habe auch schon Firefox mit einem nagelneuen Profil gestartet – Fehler immer noch vorhanden.

    Die Windows Version (gleiche Version: 77.0.1) hat den Fehler nicht.

    Kennt jemand dieses Verhalten, oder ist das wirklich ein Bug, den ich melden sollte?


    Gruß,
    Armin

    Hallo,


    Im neuen firefox 77 funktioniert mein css code nicht mehr richtig.

    Ich habe im Moment diese Einträge für die Wiederherstellung der urlbar gemacht:


    Hat in der Version 76 noch funktioniert.


    beim firefox 77 wird jetzt die urlbar nach links-oben verschoben wenn ich sie anklicke.

    Wie kann ich meinen css code verbessern damit die urlbar dieses Verhalten nicht mehr zeigt.


    Gruß,

    Armin

    Hallo,

    Mir gefällt die neue Adressleiste nicht so gut und das meiste konnte ich
    bereits über die userChrome.css wieder rückgängig machen.
    Was ich noch nicht wegbekommen habe ist der Schatten, welcher um die Adressleiste
    angezeigt wird, wenn ich sie anklicke oder einen neuen tab öffne.
    Kennt jemand den css Bezeichner für diesen Schatten, damit ich den über die
    userChrome.css deaktivieren kann?

    Gruß,
    Armin

    Also ich habe jetzt herausbekommen, dass zwischen dem 38er und dem 45er von Gstreamer auf FFmpeg gewechselt wurde. (Ich glaube beim 43er). Das ist die Änderung nach der ich gesucht habe. die Einstellung:


    Code
    media.ffmpeg.enabled


    Gibt es beim 38er noch nicht. Setze ich diesen Parameter auf "false", dann ist die Videoqualität sofort wieder verbessert. Das ist also erst mal ein Workarround. Ich könnte mir aber vorstellen, dass der Gstreamer Support irgendwann eingestellt wird, da Mozilla FFmpeg bevorzugt. FFmpeg sollte jedoch die gleiche Qualität liefern, da es ja die gleichen codecs verwendet. Im Falle von YouTube sollte das der libx264 sein. Ich denke dass da irgendwas mit der Parametrisierung schief läuft. Die Frage ist jetzt ob ich in diese Eingreifen kann (über about:config?). Ansonsten könnte ich nur darauf hoffen, dass es irgendwann von den Entwicklern gefixt wird. Das Problem betrifft ja nur die Linuxversion von Firefox.


    FFmpeg enabled (Standardeinstellung):
    https://abload.de/img/ffmpeg_enableduwq6d.png


    FFmpeg disabled:
    https://abload.de/img/ffmpeg_disabledapz8w.png

    Hallo,


    Ich habe vor kurzem vom Firefox 38 ESR zum Firefox 45 ESR gewechselt. (Aktuell 45.1.1 ESR). Ich habe festgestellt, dass die Videoqualität auf YouTube bei HD Videos im 45er erheblich schlechter ist als es noch beim 38er der Fall war. (Ich benutze den HTML5 Videoplayer). Auch wenn ich ein YouTube Video zum Beispiel im VLC Player ansehe sieht es erheblich besser aus als im Firefox 45.
    Ich verwende Linux Mint 17.2 (Xfce).


    Die Frage ist hat sich zwischen dem Firefox 38 und 45 etwas grundlegendes am Videorendering geändert? Kann ich das durch eine Einstellung wieder verbessern?


    Gruss,
    Armin

    Zitat

    oder (zumindest noch) über about:config durch ändern auf false bei diesem Wert:


    browser.urlbar.unifiedcomplete


    Ich werde das auch erst mal so machen. Funktioniert ja im ESR 45. Wenn ich dann in einem Jahr auf den ESR 52 wechsle kann ich mir erneut Gedanken darüber machen, wie ich die ganzen Verbesserungen wieder hinbiegen kann :D

    Zitat

    Das war mein Fehler, Einstellung verwechselt. :) browser.urlbar.autoFill meinte ich!


    Ja, das funktioniert. Damit habe ich dann zumindest meinen Workflow wieder. Das unsinnige anzeigen des "http://irgendwas/ aufrufen" muss ich dann versuchen über userChrome.css noch weg zu bekommen.

    Zitat

    Okay, ich weiß, was du meinst. Das ist wieder was anderes. Suche in about:config nach browser.urlbar.autocomplete.enabled und schalte das auf false


    Dann bekomme ich aber gar keine Vorschläge mehr. - Das möchte ich natürlich nicht.

    Code
    browser.urlbar.unifiedcomplete


    Das ist schon die richtige Variable, welche mir das korrekte Verhalten der Adresszeile zurück gibt.
    Wenn das aber nicht mehr dauerhaft funktioniert, wird die css Lösung wohl das beste sein. Dann muss ich nur noch herausbekommen wie das geht.

    Da ich ja den ESR 45 weiter benutze geht es ja noch ein Jahr :)
    Die about:config Einstellung ist


    Code
    browser.urlbar.unifiedcomplete


    Hast du evtl. ein Beispiel, wie ich das in die userChrome.css eintragen kann. Das wäre super.



    Zitat

    Das kann ich nicht bestätigen, damit habe ich keine Probleme. Ich nutze aber auch keine Add-ons, welche die Adressleiste in irgendeiner Weise verändern


    Also vorher war es so: wenn ich z.B. die Zeichenkette "lin" eintippe. (ohne Anführungsstriche natürlich) dann klappt die Liste mit den Vorschlägen auf. Ich kann dann mit den Cursortasten nach unten scrollen um zu sehen was da noch so Vorgeschlagen wird. Ich habe in meinem Beispiel viele Treffer mit Linux. Wenn ich jetzt wieder ganz noch oben scrolle (mit den Cursortasten) dann lande ich wieder in der Adresszeile und es steht "lin" drin und der Cursor ist am Ende der Zeichenkette. Jetzt kann ich einfach noch ein weiteres Zeichen eingeben. z.B. ein "g" (wenn ich etwas mit "ling" suchen will).


    Und genau das geht beim 45er nicht mehr. Ich komme nicht mehr in die Adresszeile zu meiner Zeichenkette "lin" um noch ein weiteres Zeichen eingeben zu können. Weil da immer ein kompletter Treffer in die Adresszeile übernommen wird. Ich muss also erst mit Backspace alle Zeichen löschen um wieder zu meiner Zeichenkette "lin" zu kommen und ein weiteres Zeichen eingeben zu können.