Kontextmenü in Eingabefeldern

  • Windows 10 | FF 62.0 (64-Bit) / FF 61.0 (64-Bit) / FF 63.0 (64-Bit)

  • Das wäre zu schön um war zu sein.
    Das habe ich schon alles getestet.
    Außer einen gelben Streifen oben im Bild keine Funktion.
    Wo würdest Du das den einsetzen, in der userChrome.css oder in der userContent.css
    Gruß EDV Oldi

    WIN11 Home Version 23H2 (Build 22631.3447)

    Firefox 124.0.2 (64-Bit)

    Thunderbird 115.9.0 (64-Bit)

    Meine Erweiterungen

  • In der userChrome.css. Aber beachte bitte, das ich inzwischen nur noch FF 57 benutze und auch nur dort teste.
    Und im FF 57 funktioniert das. :)

    Windows 10 | FF 62.0 (64-Bit) / FF 61.0 (64-Bit) / FF 63.0 (64-Bit)


  • In der userChrome.css. Aber beachte bitte, das ich inzwischen nur noch FF 57 benutze und auch nur dort teste.
    Und im FF 57 funktioniert das. :)


    Bei mir leider nicht. :-???
    Wenn man die Datei richtig speichert funktioniert das auch. :oops:
    Aber der gelbe Streifen oben bleibt.
    Gruß EDV Oldi

    WIN11 Home Version 23H2 (Build 22631.3447)

    Firefox 124.0.2 (64-Bit)

    Thunderbird 115.9.0 (64-Bit)

    Meine Erweiterungen

    2 Mal editiert, zuletzt von edvoldi (4. November 2017 um 18:50)


  • Und im FF 57 funktioniert das. :)


    Hier nicht... da sehe ich einen gelben Streifen oben im Anpassenfenster..
    [attachment=0]Unbenannt.PNG[/attachment]

  • So ich habe es.


    So funktioniert es bei mir.
    Gruß EDV Oldi

    WIN11 Home Version 23H2 (Build 22631.3447)

    Firefox 124.0.2 (64-Bit)

    Thunderbird 115.9.0 (64-Bit)

    Meine Erweiterungen

  • Ja, ich hab's gerade gesehen. Komisch nur, das mein Code nicht funktioniert, obwohl #customization-palette-container bzw. #customization-panel-container nur Teilbereiche von #customization-container sind. Also der ID, die ich deklariert habe.
    Naja, vielleicht spielt das Thema ja doch eine Rolle dabei. Ich werde es jedenfalls nicht weiter verfolgen. :)

    Windows 10 | FF 62.0 (64-Bit) / FF 61.0 (64-Bit) / FF 63.0 (64-Bit)

  • Wenn man diesen Code nimmt,

    CSS
    #customization-container,
    	#customization-palette-container,
    	#customization-panel-container {
        background-color: red !important;
    	}


    Sollte es mit oder ohne Thema funktionieren.
    Gruß EDV Oldi

    WIN11 Home Version 23H2 (Build 22631.3447)

    Firefox 124.0.2 (64-Bit)

    Thunderbird 115.9.0 (64-Bit)

    Meine Erweiterungen

  • Bitte mal testen:

    CSS
    menu[label="Screengrab!"]{
    	-moz-binding:
    	url("chrome://global/content/bindings/menu.xml#menu-iconic") !important;
    	list-style-image: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAACXBIWXMAAA3XAAAN1wFCKJt4AAAABGdBTUEAALGOfPtRkwAAACBjSFJNAAB6JQAAgIMAAPn/AACA6QAAdTAAAOpgAAA6mAAAF2+SX8VGAAAC+0lEQVR42mL8//8/AyUAIICYGCgEAAHEMn/+fIZfv34x6OrqMnz58oXhw4cPDD9+/GD4+fMnw8mTJxmEhIRqzM3Nm0Fi3759Y9i/f38lUK7j5cuXYAMAAgivCz59+sRgY2PTLCUlxcDFxcWgoKDAoKGh0Q6yEAYAAogFqlD+48ePRV+/fn0PpBm+f//O8Pnz50/KysoRN27cYDh06BDD79+/Gf78+QOmgS65BdSjx8fH9wMggFhev37Nn5qa+kBQUBDFdqBhYC+BXPEBaOi3r9/BBrCxsQC9Jai6fv2G76tXr+YCCCAWQ0PDVJDCmzdvgv394sULhufPn4MNYGRkZPj95y/Dmxf3GZ4/u8bAJyDCwMenzPCPgZGBg4ONgZ2dPRMggJiATnoH8hPI2Xfv3mV48OABmM3BwQE05BvDmeM7GH7/52TQsuhmYONxY3j96jJQzR2Gz0BLgRZ8AAggFqDt/9jY2BgePnzI8PfvXwZhYWEwzQC05dbNiwyKaiYMDv4TGZ69YGC4/86W4TMjF4Oo8AYGhr//GIAp6B9AADH9+/eP4d69e2BbmZiYwFEKCqgvQC98en+fQUQ6jOEpUPPObacYPj4/ysDIpg+U+8/w9fsXhn9AiwACiOndu3dMoDgGaQbZDPI3yFBQCuXk5GN48ew8w8nzDAzMjH8ZuNj/Mfz8ep7h35+fYPk/f/4yAQQQ06lTp/hFRETAIQ/SCAppEGZnY2Xg5JVn+Pp6C8Pnx7MY/jGyMXx4f5WB9ddGhr8M7Aw8PLxA9X/5AQKIGejcy/r6+lWioqJgA1hYWBiYmZnBLhEWFmH4+PkHAx/LBQbW/8cYuJiuAf3NxMDLK8rw5MkTBmCaCQYIIEZgygKaxmMpLi5eCDTsA8gbMJcAwX+g15i+//jJxMHO/P/nz7+Mv3//+gd0Pj8wyvs5OTmPAwQQo7GxMQ8wZX0BpQGYzSAAYoPTOjBs0MXASRjoUqBBPAABxAIkvoDSORATzJnIWR/I/gekvgAEGACtXXxs5eDnPAAAAABJRU5ErkJggg==") !important;
    	margin-left:5px !important; }
    
    	menu[label="Screengrab!"]>.menu-iconic-text{
    	margin-left:10px !important;}


    Werte wenn dann noch für dich apassen.
    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/124.0.2
    OS: Windows 10 pro 64 bit und Windows 10 Home 64 bit
    Meine Scripte Sammlung: https://github.com/Endor8/userChrome.js
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Das Icon taucht zwar in den CSS Eigenschaften des Menueintrages auf, wird aber durch den xul Eintrag image="moz-....png" überlagert.
    Auch ein Versuch das Icon mit "background" einzufügen scheitert durch das selbe verhalten.

  • Mal etwas kleines:

    Damit werden die schwarzen Icons in bei Firefox - Einstellungen bei Datenschutz usw.

    etwas bunter.

    Mfg.
    Endor

    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/124.0.2
    OS: Windows 10 pro 64 bit und Windows 10 Home 64 bit
    Meine Scripte Sammlung: https://github.com/Endor8/userChrome.js
    Kein Support per PN. Fragen bitte im Forum stellen!

    2 Mal editiert, zuletzt von Endor (11. Februar 2020 um 20:23)