Ubuntu installiert, aber.........

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Ist zwar kein Ubuntu-Forum hier, aber ich versuche es mal:


    Habe gerade Ubuntu 5.04 installiert. Das Programm hat zum Schluss gesagt, es müsse neu starten, um Ubuntu dann laden zu können. Gestartet hat das System, jedoch im Windows-Modus. Warum? Was nun? Danke für die Hilfe

    iMac 20", 2.4 GHz, Intel Core 2 Duo, 2 GB 667 MHz

  • Hast du zwei Festplatten? Ist auf der einen Windows und auf der anderen Ubuntu drauf? Wenn ja, dann hast du das gleiche problem wie ich es mal mit fedora hatte, ich habe es umgangen, indem ich einfach fedora auf die erste platte installiert habe :lol:

    Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060202 Firefox/1.5.0.1 8)
    Jabber: WasCostas[at]jabber.org

  • Eigentlich sollte im Bootpromt sich Grub zu Wort melden und Dir die Auswahl bieten welches OS gestartet werden soll. Was hast Du denn bei der Installation von Ubuntu ausgewählt als Du nach Grub gefragt wurdest?

    Hinweis!!!
    Die Durchführung von meinen Tips ist freiwillig und obliegt dem Administrator oder Besitzer des Rechners.
    Für Fehler, Datenverlust oder Beschädigungen übernehme ich keinerlei Verantwortung!!!
    Kein Support per Mail oder PN!!!

  • wolf, jetzt hast du mich erwischt, mit den begriffen kann ich derzeit noch nicht viel anfangen :oops::oops::oops:

    iMac 20", 2.4 GHz, Intel Core 2 Duo, 2 GB 667 MHz

  • Grub ist der Bootmanager, der Dir die Möglichkeit bietet auszuwählen welches OS Du booten möchtest
    Standartgemäß bietet Dir Ubuntu die Installation im MBR der ersten Platte an. Wahrscheinlich hast Du diese Möglichkeit abgewählt.

    Hinweis!!!
    Die Durchführung von meinen Tips ist freiwillig und obliegt dem Administrator oder Besitzer des Rechners.
    Für Fehler, Datenverlust oder Beschädigungen übernehme ich keinerlei Verantwortung!!!
    Kein Support per Mail oder PN!!!

    Einmal editiert, zuletzt von LonesomWolf ()

  • Versuche mal diese Anleitung: http://www.ubuntuusers.de/wiki/system%253agrub-reinstall
    Eventuell schaffst Du damit Dein Ubuntu zu starten. Allerdings müßtest Du erstmal die LifeCD runterladen.

    Hinweis!!!
    Die Durchführung von meinen Tips ist freiwillig und obliegt dem Administrator oder Besitzer des Rechners.
    Für Fehler, Datenverlust oder Beschädigungen übernehme ich keinerlei Verantwortung!!!
    Kein Support per Mail oder PN!!!

  • Zitat von LonesomWolf

    Grub ist der Bootmanager, der Dir die Möglichkeit bietet auszuwählen welches OS Du booten möchtest
    Standartgemäß bietet Dir Ubuntu die Installation im MBR der ersten Platte an. Wahrscheinlich hast Du diese Möglichkeit abgewählt.


    Ich möchte es nicht behaupten, aber ich kann mich nicht erinnern, solch eine Frage beantwortet zu haben :o

    iMac 20", 2.4 GHz, Intel Core 2 Duo, 2 GB 667 MHz

  • Glaube es mir....die Frage kommt bei der Installation als Multisystem.
    Übrigens ist es vollkommen egal ob Du eine oder zwei Platten hast. Win ist bei mir auch noch auf der erstem Platte und Ubuntu ist auf der Zweiten. Es kommt nur auf den Bootmanager an.

    Hinweis!!!
    Die Durchführung von meinen Tips ist freiwillig und obliegt dem Administrator oder Besitzer des Rechners.
    Für Fehler, Datenverlust oder Beschädigungen übernehme ich keinerlei Verantwortung!!!
    Kein Support per Mail oder PN!!!

  • Dann musst du aber im Bios einstellen, dass es von der 2.Platte bootet, und das habe ich nicht geschafft ;)

    Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060202 Firefox/1.5.0.1 8)
    Jabber: WasCostas[at]jabber.org

  • Zitat von LonesomWolf

    Glaube es mir....die Frage kommt bei der Installation als Multisystem.
    Übrigens ist es vollkommen egal ob Du eine oder zwei Platten hast. Win ist bei mir auch noch auf der erstem Platte und Ubuntu ist auf der Zweiten. Es kommt nur auf den Bootmanager an.


    Ich wurde gefragt, ob der GRUB ins WIndows geschrieben werden soll, da ein Betriebssystem schon vorhanden ist (oder so ähnlich). Diese Frage habe ich mit JA beantwortet. Starten tut er aber ohne zu fragen mit WIN

    iMac 20", 2.4 GHz, Intel Core 2 Duo, 2 GB 667 MHz

  • Zitat

    Dann musst du aber im Bios einstellen, dass es von der 2.Platte bootet, und das habe ich nicht geschafft


    Also ich weiß ja nicht was Du für ein komischen Rechner hast, Ich habe hier nichts im BIOS umgestellt. Warum auch...ich boote ja weiterhin von der ersten Platte. Denn wie Snake schon geschrieben hat, dort sitzt der MBR und Grub.


    Zitat

    Ich wurde gefragt, ob der GRUB ins WIndows geschrieben werden soll, da ein Betriebssystem schon vorhanden ist (oder so ähnlich). Diese Frage habe ich mit JA beantwortet. Starten tut er aber ohne zu fragen mit WIN


    Hast Du Die Anleitung aus dem Ubuntu Wiki schon mal ausprobiert? Du mußt jedenfalls sehen, dass Du den Grub zu sehen bekommst. Sonst wird das nichts mit dem Auswählen.

    Hinweis!!!
    Die Durchführung von meinen Tips ist freiwillig und obliegt dem Administrator oder Besitzer des Rechners.
    Für Fehler, Datenverlust oder Beschädigungen übernehme ich keinerlei Verantwortung!!!
    Kein Support per Mail oder PN!!!

  • Sorry fürs nochmal Hochholen des Threads, aber es besteht aktueller Anlass.


    Ich hab mich jetzt entschlossen ubuntu noch mal ne Chance zu geben und hab dafür erstmal meine Longhorn beta gekickt... OK, mögen einige sagen, endlich wird er vernünftig...


    Da ich natürlich dann auch gerne ins Internet gehe, brauche ich natürlich noch nen passenden Treiber für meine WLAN-Karte (WG 311T von Netgear bzw. WG 511T beim Notebook). Dann hab ich mich bei linuxforen.de mal umgeschaut, was es denn da für Möglichkeiten gibt, die ans Laufen zu bekommen. Im wesentlichen sind's derer 2:


    1. mit madwifi
    2. mit ndiswrapper


    ndiswrapper nutzt Windows-Treiber, und da ich von solchen System-Crossovern nicht viel halte, hab ich mir zuerst madwifi runtergeladen. Dann ubuntu installiert, gestartet - wieso ist eigentlich das Bild weiter rechts als bei Windows? - und gleich der erste Schreck: Das Bild ist 1024x768, ich hatte aber ausdrücklich 1280x1024 ausgewählt. Sieht nämlich sonst auf einem TFT einigermaßen blöd aus. Na ja.


    Weiter im Text: madwifi sollte ganz einfach zu installieren sein: erst make im Verzeichnis und dann make install. Klappte aber aus irgendeinem Grund nicht.


    Dann hab ich den PC angebrüllt und wieder Windows gestartet, ich musste ja nochmal ins Internet, vielleicht hatte ich irgendwas übersehen. War aber nicht so. Also ndiswrapper gesaugt, und deren ganze Webseite gleich mit, sonst vergesse ich wieder was.


    Also, wieder in Linux, erstmal die Webseite aufrufen. Aha, in Firefox, interessant. Aber in was auch sonst?


    Nun ja, jedenfalls steht da so ziemlich das selbe wie bei madwifi: tar entpacken, make und make install machen. Klappt aber auch hier nicht.


    Diesmal aber mit vernünftiger Fehlermeldung "Can't find kernel files in /lib/modules/2.50.../..." und so weiter. Aha, wo sind sie denn, die Kernel-Files.


    Da fällt mir auf: Da steht, man soll das als root machen. Bin ich denn überhaupt root oder zumindest su? Glaube nicht, aber andererseits hab ich auch kein root-Passwort... naja, wird schon stimmen.


    Also, was läuft hier falsch? Wieso findet dieses blöde Programm meinen Kernel nicht? Weg kann er ja schlecht sein ;)


    Mit Dank im Voraus,
    wupperbayer

    Quis custodit custodes?

  • Zitat von wupperbayer


    Weiter im Text: madwifi sollte ganz einfach zu installieren sein: erst make im Verzeichnis und dann make install. Klappte aber aus irgendeinem Grund nicht.


    Fehlermeldung wäre hier hilfreich. Vermutlich benötigst du noch irgendne Abhängigkeit, also ein Programm auf dem madwifi aufbaut.


    Ansonsten hilft es meistens sich die Doku auf der Webseite oder im Readme-File durchzulesen oder auch mal nach der Fehlermeldung zu googlen. Und wenn du hier Fehlermeldungen postest, an besten bitte vollständige.

  • Hi Wupperbayer!
    Mein Rat:
    Bevor du irgendwas machst: Warte bis zum 13. Oktober, dann kommt die neue UbuntuVersion raus und das mit dem Wlan soll um einiges einfacher funktionieren.
    Also bevor du dir jetzt den Stress machst und 8 Tage lang rumprobierst, warte lieber erstmal solange, evtl. löst sich ja dann das Problem von alleine :D


    BTW: Schau dir mal das Wiki im Ubuntuuserforum an, hilft enorm bei einen geplanten Umstieg.
    --> http://www.ubuntuusers.de/wiki/

    Gruß SuiRIS


    Arch Linux

    Einmal editiert, zuletzt von SuiRIS ()

  • Zitat von SuiRIS

    Hi Wupperbayer!
    Bevor du irgendwas machst: Warte bis zum 13. Oktober, dann kommt die neue UbuntuVersion raus und dann soll das mit Wlan um einiges einfacher funktionieren.
    Also bevor du dir jetzt den Stress machst und 8 Tage lang rumprobierst, warte lieber erstmal solange, evtl. löst sich ja dann das Problem von alleine :D


    Ich experimentiere ja gerne, und es soll ja eigentlich nicht kompliziert sein, mit madwifi / ndiswrapper. Vielleicht ist die Lösung ja ganz einfach.


    Also, hier mal die Fehlermeldungen, zuerst madwifi:


    Code
    Makefile.inc:94: *** KERNELPATH must be defined.  Schluss.


    Und jetzt die etwas ausführlichere ;) von ndiswrapper:


    Code
    make -C driver
    make[1]: Gehe in Verzeichnis »/home/sebastian/Desktop/ndiswrapper-1.4rc4/driver«Can't find kernel sources in /lib/modules/2.6.10-5-386/build;
      give the path to kernel sources with KSRC=<path> argument to make
    make[1]: *** [prereq_check] Fehler 1
    make[1]: Verlasse Verzeichnis »/home/sebastian/Desktop/ndiswrapper-1.4rc4/driver«
    make: *** [all] Fehler 2


    Was ich gemacht habe:


    - tar-Archive entpackt
    - im entpackten Ordner mit der root-Konsole "make" aufgerufen

    Quis custodit custodes?