openSUSE-Update sorgt für deaktivierte Erweiterungen in Firefox

  • Workaround wäre ein Zurücksetzen von mozilla-nss und mozilla-nss-cert auf eine Vorgängerversion.

    Sollte dies nicht ausreichen (wie bei mir und Leap 15.5) hilft noch das Setzen dieser Variable:

    export NSS_IGNORE_SYSTEM_POLICY=1

    Danach läuft der Fx erst einmal wieder sauber.

    Viele Grüße,
    reni
    ----------------------------
    OS: Leap15.4 / FF immer aktuell ;)

  • Dem würde ich ernsthaft widersprechen, denn ich nutze openSuse und habe vorgestern, nach eim Update auf Plasma 6 einige Probleme gehabt, die sich wiederherstellen ließen; nur der Firefox war bei mir nicht betroffen, auch kein anderer Browser in Bezug auf Erweiterungen. Alles noch vorhanden, aktualisiert sich selbstständig und arbeitet korrekt.

    Mutmaßlich sei das Update auf Plasma 6 hierfür verantwortlich, so ist es in diversen Linux-foren zu lesen. Man arbeite daran. Verwundert mich insofern, dass es hier nicht vorhanden ist.

    no sweat :S

    greetz Jörgen

  • Verwundert mich insofern, dass es hier nicht vorhanden ist.

    Das kommt darauf an, welchen Firefox zu benutzt.

    Betroffen war das Repo "Mozilla". Wenn du keine Installation von da hast, dann hast du auch kein Problem.

    Inzwischen aber ist das Problem gefixt. Es gibt Updates und es läuft wieder.

    Viele Grüße,
    reni
    ----------------------------
    OS: Leap15.4 / FF immer aktuell ;)

  • Dem würde ich ernsthaft widersprechen

    Da gibt es nichts zu widersprechen. Die Ursache ist bekannt und real, außerdem sowohl durch Mozilla als auch den Mozilla-Maintainer von openSUSE offiziell bestätigt.

    Mutmaßlich sei das Update auf Plasma 6 hierfür verantwortlich

    Im Artikel steht, was dafür verantwortlich ist, nämlich das crypto-policies-Paket.

    Aber wie reni schon schrieb, wurde in der Zwischenzeit ein weiteres Update für das betroffene Paket veröffentlicht, welches das Problem behebt.

  • Betroffen war das Repo "Mozilla". Wenn du keine Installation von da hast, dann hast du auch kein Problem.

    Dann dumm gelaufen, dass es bei mir nicht vorhanden war, obwohl ich seit Ewigkeiten die Mozilla-Repo eingepflegt habe ;)

    Aber wie reni schon schrieb, wurde in der Zwischenzeit ein weiteres Update für das betroffene Paket veröffentlicht, welches das Problem behebt.

    Hat hier nicht verändert, bzw. da kein Fehler vorhanden war, somit auch keinen behoben. FF läuft nach wie vor ohne Fehler, und dies seit Wochen. in der aktuellen Vs. 123.0.1 (64-Bit)

    Schönen Abend noch.


    no sweat :S

    greetz Jörgen

  • Ein von mir unterstützter Linux-User hatte - im Gegensatz zu mir - dieses Problem auch. Wie sich herausstellt, hat er den Umstieg auf Plasma6 einen Tag vor mir gemacht. Nach einem gestrigen "zypper dup" hat sich dieses Problem in Luft aufgelöst.

    Manchmal ist es schon gut, große Updates nicht gleich und sofort zu machen.

    vy 73 de Peter

  • Vielleicht war das betroffene Paket-Update bei dir gar nicht erst installiert.

    Ja, diese Option besteht womöglich. Vielleicht auch deshalb, wie es WismutKumpel erklärt hat.

    Manchmal ist es schon gut, große Updates nicht gleich und sofort zu machen.

    Das habe ich nun auch herausgefunden und werde dann einige Tage abwarten, bevor ich beim zypper dup etwas größeres aktualisieren lasse :)

    Zur Freude läuft wieder /fast/ alles im Normbereich.

    no sweat :S

    greetz Jörgen