Aktualisierung im Hintergrund ausschalten

  • Firefox-Version
    98.0 Ubuntu
    Betriebssystem
    Ubuntu 20 Mate

    seit einigen Wochen erlebe ich, dass Firefox im Hintergrund aktualisiert wird.
    Dies ist oft sehr unangenehm, da ich / wir dann unsere Arbeit unterbrechen müssen für den Neustart und ich zB. während einer Videokonferenz überraschend für 5 Minuten nicht erreichbar bin.
    Wie kann ich dies abschalten?

    Dank für zielführende Hinweise - GW

  • Ist Firefox bei dir über die Paketverwaltung installiert?

    Falls ja, da hat Mozilla keinen Einfluss drauf, nur über die verteilte Version von Mozilla direkt, weil die nicht darüber läuft.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Wie wurde Firefox installiert? Über apt/ Paketverwaltung kann ich mir gar nicht vorstellen, denn da wirst du vorher gefragt ob du aktualisieren willst. Oder als Snap? Würde genauso wie über apt laufen. Bleibt also nur, dass du Firefox manuell, also "firefox_98.tar.bz2", entpackt hast und daraus startest. In letzteren Fall macht Firefox die Updates, wenn sie von Mozilla freigegeben wurden. Wie auch bei Windows Systemen.

    Zitat


    Wie kann ich dies abschalten?

    Der Ausweg würde nur über eine Firefox Installation via Paketverwaltung oder Snap führen. (Sollte ich mit meiner Vermutung recht behalten.)

    Ansonsten würde ich die Settings zum Update Verhalten von Ubuntu selbst überprüfen.

    Firefox 105.0.2 | Lubuntu 22.04.1 | Kernel: 5.15.0-48-generic

  • Bleibt also nur, dass du Firefox manuell, also "firefox_98.tar.bz2", entpackt hast und daraus startest. In letzteren Fall macht Firefox die Updates, wenn sie von Mozilla freigegeben wurden. Wie auch bei Windows Systemen.


    Auch dann würde nur der Download automatisch geschehen und der Nutzer nicht dazu gezwungen werden, seine Arbeit zur Installation des Updates zu unterbrechen.

  • Auch dann würde nur der Download automatisch geschehen und der Nutzer nicht dazu gezwungen werden, seine Arbeit zur Installation des Updates zu unterbrechen.

    Dann bleiben nur die Settings von Ubuntu selbst übrig. Komisches Verhalten. Hatte ich selbst noch nie.

    Firefox 105.0.2 | Lubuntu 22.04.1 | Kernel: 5.15.0-48-generic

  • Wie wurde Firefox installiert? Über apt/ Paketverwaltung kann ich mir gar nicht vorstellen, denn da wirst du vorher gefragt ob du aktualisieren willst. Oder als Snap? Würde genauso wie über apt laufen. Bleibt also nur, dass du Firefox manuell, also "firefox_98.tar.bz2", entpackt hast und daraus startest. In letzteren Fall macht Firefox die Updates, wenn sie von Mozilla freigegeben wurden. Wie auch bei Windows Systemen.

    Zitat


    Wie kann ich dies abschalten?

    Der Ausweg würde nur über eine Firefox Installation via Paketverwaltung oder Snap führen. (Sollte ich mit meiner Vermutung recht behalten.)

    Ansonsten würde ich die Settings zum Update Verhalten von Ubuntu selbst überprüfen.

    Das Update hat nichts mit Ubuntu bzw. mit apt zu tun - installiert wurde es vor ca. 2 Jahren, nachdem ich den Laptop gekauft hatte.
    Bei den Ubuntu-Updates (> apt) habe ich IMMER die Wahl, ob ich sie sofort oder erst in einem halben Jahr ausführen lasse.
    Die Aktualisierung im Hintergrund mit erzwungenem Neustart geht von Firefox aus.
    Und ich weiss bisher nicht, wo ich sie abstellen kann.
    Wenn ich das nicht finden kann, sehe ich mich gezwungen, den Browser zu wechseln.

  • Die Aktualisierung im Hintergrund mit erzwungenem Neustart geht von Firefox aus.
    Und ich weiss bisher nicht, wo ich sie abstellen kann.

    Weil es vielleicht niemals von Firefox kam?

    Ist dir eigentlich nie aufgefallen, dass du der einzige mit diesem Problem bist?

    Vor allem braucht Firefox selbst kein Systemneustart, nur für sich selbst, dahingehend waren deine Beschreibungen immer ungenau. Und selbst auf älteren System braucht es keine 5 Minuten, hat Sören ja schon geschrieben.

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Wie kann ich die Einstellungen so verändern, dass keine automatischen Updates gemacht werden?

    Hallo :)

    Die Verwendung veralteter Software stellt ein erhebliches Sicherheitsrisiko dar - nicht nur für den betroffenen Nutzer selbst, sondern auch für andere Menschen. Aus diesem Grund ist es in diesem Forum nicht möglich, Support bei Verwendung einer veralteten Firefox-Version zu erhalten. Das Team behält sich die Schließung von Themen vor, sofern seitens Themenersteller keine Bereitschaft besteht, eine aktuelle Firefox-Version einzusetzen. Hinweise, welche dem alleinigen Ziel dienen, Hilfestellung für die dauerhafte Verwendung einer veralteten Firefox-Version zu geben, können vom Team kommentarlos gelöscht werden.

    Gruß Ingo

  • Er will ja, nur nicht so, wie es bei ihm passiert ;)

    [ ] Danke [ ] Gehts noch?! [ ] Ich glaub, es hackt!
    Warum ist die "Eigenart" mancher Menschen größer als dieses Universum?

  • Das Problem ist vor allem, dass die Schilderungen des Themenerstellers nicht passen. Weder dauert ein Firefox-Update fünf Minuten noch zwingt einen ein Firefox-Update zum sofortigen Neustart. Klarstellungen erfolgten bisher keine. Vermutlich sind das maßlose Übertreibungen, aber das hilft in einem Support-Thema halt überhaupt nicht. Davon gehe ich vor allem auch aus, da uns der Themenersteller ja auch einen Browserwechsel "androht" und dieser in einem zweiten Thread von Bevormundung sprach. Diese Verhaltensmuster wiederum passen natürlich sehr gut zusammen.


    Wenn Firefox über die Distribution installiert wurde, gehen Updates jedenfalls auch nicht von Firefox aus, sondern von der Paketverwaltung. Firefox wäre in den Update-Prozess nur involviert, wenn Firefox via mozilla.org heruntergeladen wurde. Will man nicht, dass Update-Dialoge von Firefox erscheinen, gibt es also eine naheliegende Lösung. Auch wenn ich sonst immer davon abrate, Firefox aus einer Paketverwaltung zu verwenden, ist das gerade für so jemanden vielleicht dann doch die beste Lösung, weil es funktioniert und man sich eine größere Diskussion spart.