Sitzungswiederherstellung beim Start von Firefox

  • Firefox-Version
    96.0.2
    Betriebssystem
    Windows 10 - 64 bit

    Hallo,


    ich habe auf einem von drei PCs das Problem, dass Firefox bei jedem Start mit der Meldung "Entschuldigung, beim Wiederherstellen Ihrer Seiten ist ein Problem aufgetreten" geöffnet wird. Unter "Tabs der letzten Sitzung anzeigen" wird dann "Fenster 1 -> neuer Tab" angezeigt. Das Verhalten besteht auch, wenn ich unter "Startseite" die Punkte "Internetsuche" und "Verknüpfungen", sowie alle AddOns deaktiviere. Das Verhalten wird vermutlich durch das Schließen von Firefox verursacht, denn wenn ich bei geöffnetem Firefox ein zweites Firefox öffne, wird die reguläre Startseite angezeigt.


    Ein neues Profil anzulegen ist nicht die Lösung. Ich habe es jetzt mehrfach probiert und neue Profile angelegt, ab dem dritten Start von Firefox, ohne irgendwelche Änderungen, nur "Öffnen" und "Schließen" von Firefox kommt die Meldung wieder.


    Ich habe in den letzten beiden Stunden die verschiedenen Firefox-Version installiert und deinstalliert. Ich kann das Verhalten auf die Firefox-Versionen 96.0, 96.0.1 und 96.0.2 eingrenzen. Mit den Version 95.0.1 und 95.0.2 tritt das Verhalten nicht auf.


    Gruß

    aGizmo

  • Wie bereits anderweitig geschrieben: teste ein neues Profil



    Firefox-Profile mithilfe der Profilverwaltung erstellen und löschen
    https://support.mozilla.org/de…le-erstellen-und-loeschen

    Zitat

    Sie können mehrere Profile mit jeweils unterschiedlichen Benutzerinformationen anlegen und mithilfe der Profilverwaltung neue Profile erstellen...

    Hier sollte etwas stehen, aber ich befürchte, du könntest es nicht ertragen. Daher ist dein Einfallsreichtum gefragt, überrasche mich.

  • Wie bereits anderweitig geschrieben: teste ein neues Profil


    Ein neues Profil anzulegen ist nicht die Lösung. Ich habe es jetzt mehrfach probiert und neue Profile angelegt, ab dem dritten Start von Firefox, ohne irgendwelche Änderungen, nur "Öffnen" und "Schließen" von Firefox kommt die Meldung wieder.

    Chromebook Lenovo IdeaPad Flex 5 - chromeOS 109 (Stable Channel) - Linux Debian Bullseye: Firefox Unstable Debian-Channel ( Sid, pending) und ESR 102.7.0 (Main Release) - Android 11: Firefox Nightly und Firefox (Main Release)

    Smartphone - Firefox Main Release, Firefox Nightly, Firefox Klar (Main Release)

  • Wie bereits anderweitig geschrieben: teste ein neues Profil

    Zitat von .DeJaVu

    Manchmal hilft es, genau das Thema vollständig zu lesen, wo man was reinschreiben möchte

    Vielleicht mal den eigenen Rat zu Herzen nehmen. Ich denke, ich habe eine sehr ausführliche Fehlerbeschreibung geliefert, die es verdient, komplett gelesen zu werden, bevor sie eine Antwort bekommt.

  • Danke :S


    Dann eben ganz einfach.

    Zitat

    auf einem von drei PCs

    Suche die Unterschiede, sei es in Firefox bzw Profil, kann man ja untereinder kopieren, sei es sonstige Software. Denn wie du vermutlich sehen wirst, bist du aktuell nur einer von Zweien unter ganz ganz vielen, die das Problem haben, es ist eben selten. Ich würde sagen, dass irgendeine andere Software in die Sitzungsdaten pfuscht, das kann auch von einem Antivirus herrühren.


    Eines ist unklar


    Zitat

    denn wenn ich bei geöffnetem Firefox ein zweites Firefox öffne, wird die reguläre Startseite angezeigt.

    Was ist 'ein zweites Firefox'?

    Eine zweite Installation?

    Ein zweites Profil?

    Ein neues Fenster aus dem anderen hinaus?


    Dass die Startseite angezeigt wird, sollte bei letzterem klar sein, denn das ist keine neue Sitzung, nur ein neues Fenster. Dahingehend wäre es eine falsche Schlussfolgerung.


    Nachtrag. Es könnte auch schon ein defektes Benutzerprofil (das von Windows) sein. Erstelle einen neuen Benutzer, erstelle eine Sitzung. Tritt dort der Fehler auch auf, wird es ganz sicher nicht von Firefox erzeugt. Ansonsten bleibt nur noch das defekte Benutzerprofil.

    Hier sollte etwas stehen, aber ich befürchte, du könntest es nicht ertragen. Daher ist dein Einfallsreichtum gefragt, überrasche mich.

    Einmal editiert, zuletzt von .DeJaVu ()

  • Hallo,

    ich möchte bestätigen, was der User aGizmo hier schildert.

    FF96.0.2, Win Prof10 64bit (aber auch testweise mal auf Win7 Prof 64 bit probiert).

    Antivirus ist der MSDefender. Arbeitsrechner, also nur lizensierte Software (Office, CAD) und keine Tweaking/Tuning-Tools drauf.

    Hardware alle Dell Precision 5810/5820 ohne Mods.

    Ich habe das jetzt auf 4 Rechnern in der Domäne. Es ist unabhängig von den (servergespeicherten) Userprofilen, d.h. unterschiedliche Domänenuser haben mit dem selben Profil nur an denjenigen Computern das Problem, sobald der Client auf 96.0.2 ist.

    Das identische Profil funktioniert klaglos an Clients mit FF 95.x.x


    Eine weitere Erscheinung ist, dass sich Downloadhistorie und Chronik nicht mehr löschen lassen.

    Neue Profile wurden testweise eingerichtet, lösen diese Erscheinung aber nicht.


    bye

  • ich möchte bestätigen

    Ist ja toll, aber dennoch könnte dein Problem eine ganz andere Ursache haben.

    Zitat

    5.1 Eigene Themen eröffnen


    Während es in manchen Foren üblich ist, sich an bestehende Themen dranzuhängen, bitten wir Nutzer in diesem Forum, für ihre Probleme jeweils eigene Themen zu erstellen. Nur so kann jedem Nutzer zielgerichtet und effizient geholfen werden, ohne dass die Probleme eines Nutzers untergehen. Auch könnte eine bereits vorgenommene "Erledigt"-Markierung ansonsten dafür sorgen, dass man nicht die Hilfe erhält, die man sonst erhalten würde, weil nicht jeder Helfer zwingend in Hilfe-Themen liest, welche bereits als erledigt markiert sind.

    Hier sollte etwas stehen, aber ich befürchte, du könntest es nicht ertragen. Daher ist dein Einfallsreichtum gefragt, überrasche mich.

  • OT:

    Eigentlich wollte ich was zu dem schreiben, was pivili zu der Forenregel "Eigenes Thema eröffnen" und "Synergie-Effekte" geäußert hat, aber der Beitrag ist über Nacht "verschwunden"... :/ .


    Ich sehe das ähnlich wie pivili, nämlich, dass in diesem konkreten Fall ein Abweichen von der Forenregel der effektivste Weg ist, das Problem zu lösen. Wenn man die betroffenen Systeme vergleicht und die Gemeinsamkeiten zueinander analysiert und im Gegenzug auch überlegt, wo sich die beiden Systeme von der Mehrzahl der funktionierenden Installationen unterscheidet, dann lässt sich das eben am besten in einem Thread ermitteln. Es ist doch für die Fehlersuche schon mal ein hilfreicher Ansatz, wenn es (potentiell) mehrere Installationen betrifft, bei denen sich der Fehler zeigt. Was soll denn an diesem Ansatz und dem (gelöschten) Beitrag von pivili so falsch gewesen sein?

  • Ich hab das Problem auch seit FX 96.01, Win10-64, und wir sind hier nicht alleine, siehe Mozillazine.

    Es tritt bei mir unregelmässig auf, lässt sich nicht reproduzieren. Hab hier einiges gelesen, hilft aber nicht. Ich sitze das jetzt mal aus, ich hoffe, irgendwann ist es wieder weg.

    "Krieg ist ein zu ernstes Geschäft, als daß man ihn den Generälen überlassen dürfte." Georges B. Clemenceau (1841-1929), Französischer Journalist und Politiker/Ministerpäsident

  • Eigentlich wollte ich was zu dem schreiben, was pivili zu der Forenregel "Eigenes Thema eröffnen" und "Synergie-Effekte" geäußert hat, aber der Beitrag ist über Nacht "verschwunden"... :/ . […] Was soll denn an diesem Ansatz und dem (gelöschten) Beitrag von pivili so falsch gewesen sein?


    Ich bitte um Verständnis, dass ich moderative Entscheidungen nicht im Detail öffentlich diskutiere. Der betroffene Nutzer wurde informiert und weiß Bescheid. Nur so viel: Es hatte nicht alleine damit zu tun, dass er sich an dieses Thema rangehängt hat, sonst wäre sein erster Beitrag ja auch gelöscht worden. Es gab dafür inhaltliche Gründe. Und mein Ziel ist es, dass wir hier zu einer Lösung kommen. Es ist vor allem dem Themenersteller gegenüber nicht fair, wenn hier mehr Diskussion als Lösungsfindung stattfindet. Darum habe ich die Diskussion ins Private verlagert.


    Selbstverständlich können wir bei der Auslegung von Support-Richtlinien, die durchaus aus gutem Grund bestehen, im Einzelfall auch etwas flexibler sein, sofern dies denn sinnvoll ist. Den originalen Beitrag von pivili habe ich ja auch weder gelöscht noch in ein neues Thema abgetrennt - eben auch, weil dieser Beitrag zusätzliche Informationen liefert. Wenn ich merke, dass es durcheinander geht und die Unterstützung für den Themenersteller, sollte er sich wieder aktiv zeigen, untergeht, kann ich immer noch nachträglich abtrennen.

  • So, dann wollen wir mal zum Problem selbst kommen:

    Da es bei mir auf privaten Rechnern mit lokalen Profilen in FF 96.0.2 (inzwischen 96.0.3) nicht auftritt, sondern im Netzwerk auf der Arbeit mit roaming Profilen, vermute ich ein Problem im Bereich Pfadangaben und Profilspeicherort.

    Ich habe mit verschiedenen Speicherorten des Profiles gespielt. Solange das Profil mit relativer Pfadangabe lokal liegt, funktioniert alles einwandfrei.

    Verschiebe ich dieses Profil unverändert auf ein Netzwerkshare und passe die Pfadangabe in den *.ini Dateien absolut dahin an, funktioniert es reproduzierbar nicht mehr. Das Verhalten ist immer gleich, unabhängig, ob es sich um ein völlig frisches oder ein jahrealtes Profil handelt.

  • Hallo,


    ich werde morgen etwas ausführlicher meine Beobachtung hier niederschreiben. Hatte die letzten Tage leider 12 Stunden Arbeitstage und will heute nur aufs Sofa


    Gruß

    aGizmo

  • Ich hatte es zur Abtrennung gemeldet, weil hier mit einer Domäne gearbeitet wird, die etwas anders tickt, nicht nur, weil zusätzlich ja immer ein lokales Notfall-Profil des Benutzers existiert. Hier muss erst mal ganz klar festgestellt werden, was ja auch offensichtlich wurde mit der INI, dass kein Mischmasch vorhanden ist von lokalen und serverseitigen Dateien besteht.


    Das Problem bei mzine ist ja noch anders gelagert:

    Zitat


    Every time I click on a desktop shortcut, that site comes up along with a Session Restore tab.

    Von einer URL-Verknüpfung hat hier noch gar keiner geschrieben. Mag die gleiche Ursache haben, ist für mich aber vornehmlich ein ganz anderer Vorgang.


    Ich nutze auch rechnerübergreifend Profile (im Netzwerk) - nicht gleichzeitig, das ergäbe Murks - aber da gab es nie solche Probleme, nicht mal lokal.

    Hier sollte etwas stehen, aber ich befürchte, du könntest es nicht ertragen. Daher ist dein Einfallsreichtum gefragt, überrasche mich.

  • Hallo,


    ich werde dann mal versuchen, meine Beobachtungen niederzuschreiben. Aber zuerst einmal die Antwort auf:

    Was ist 'ein zweites Firefox'?

    Damit meine ich "rechte Maustaste" auf das Taskleisten-Symbol des geöffneten Firefox und Auswahl von "Firefox".


    Alle vorgeschlagenen Lösungsansätze haben nichts gebracht. Ich habe den Virenscanner "Windows Defender" und auch die Firewall deaktiviert. Ich habe alle nicht Windows-Programme beendet und alle nicht Windows-Dienste deaktiviert. Ich habe ein neues Windows-Benutzerprofil angelegt. Immer spätestens beim dritten Start von Firefox kam der Fehler wieder. Installiere ich nach dem Auftreten des Fehlers wieder die 95.0.2, auch ohne vorher die 96.x zu installieren, muss ich zwar ein neues Profil anlegen, aber der Fehler tritt dann trotzdem, auch nach etlichen Programm-Starts auf.

    Von daher würde ich schon behaupten, dass in der 96er Version irgendwas geändert wurde, was sich mit meiner Hardware/Software-Kombination nicht verträgt.


    Ich habe dann den Rechner formatiert und Windows 10 neu installiert. Sowohl mit dem frisch installierten Windows wie auch nach der Installation aller Updates, lässt sich das Verhalten nicht reproduzieren. Installiert habe ich die Version 96.0.2 und das automatische Update deaktiviert. Ich habe dann nach und nach alle zuvor installierten Programme häppchenweise installiert und immer wieder versucht das Verhalten zu reproduzieren. Lief alles super. Als letzten Schritt, bevor ich das Verhalten wieder reproduzieren konnte, hatte ich auf der Startseite die Webseiten-Verknüpfungen in drei Zeilen konfiguriert und „iTunes“, sowie die „Logitech Gaming Software“ installiert. Zwischen allen Tests wurde der Rechner natürlich immer wieder neu gestartet.


    Beim Testen ist mir dann folgendes aufgefallen: Das Verhalten ließ sich reproduzieren, wenn Firefox schnell hintereinander geöffnet und geschlossen wurde. Habe ich zwischen jedem Schritt ca. 15 Sekunden gewartet, trat das Verhalten nicht auf. Nachdem ich dann das Update auf die Version 96.0.3 gemacht habe, gab es aber keinen Unterschied mehr, egal ob ich zwischen den Schritten lange gewartet habe oder nicht.


    Auch die Deinstallation von „iTunes“ und „Logitech Gaming Software“, sowie dem Entfernen der Webseiten-Verknüpfungen hat nichts mehr an dem Verhalten geändert.


    Ich habe jetzt erstmal wieder die Version 95.0.2 drüber installiert und das automatische Update deaktiviert. Noch einmal mit der Formatierung und Installation anzufangen, wollte ich jetzt nicht.


    Gruß

    aGizmo

  • Ich habe jetzt erstmal wieder die Version 95.0.2 drüber installiert und das automatische Update deaktiviert


    Sicherheit ist dir also vollkommen egal?


    Liste der in Firefox 96 geschlossenen Sicherheitslücken:



    Und in etwas mehr als einer Woche wird wieder ein Haufen neuer Sicherheitslücken geschlossen werden.

  • Hallo,


    was hat diese Antwort denn jetzt mit dem eigentlichen Thema zu tun und warum wird das Thema auf „erledigt“ gesetzt, ohne dass auch nur ansatzweise auf meine wieder recht ausführliche Beschreibung des Verhaltens eingegangen wird?


    Da mir dieses Verhalten doch keine Ruhe gelassen hat, habe ich mich heute noch eine Weile damit beschäftigt. Ich habe für mich zwei evtl. funktionierende Lösungen gefunden. Vielleicht helfen diese ja anderen Leuten mit diesem Problem, die über eine Internet-Suche auf dieses Forum stoßen.


    1. Lösung: Ich habe in den Firefox-Einstellungen unter „Allgemein -> Start“ den Haken „Vorherige Fenster und Tabs öffnen“ aktiviert.

    Diese Lösung hat den Nachteil, dass ich immer daran denken muss, alle Tabs zu schließen, damit ich meine Startseite mit den Webseiten-Verknüpfungen beim nächsten Firefox-Start angezeigt zu bekommen.


    2. Lösung: Ich habe in der „about:config“ das „Crash Recovery Feature“ über „browser.sessionstore.resume_from_crash = false“ deaktiviert.

    Diese Lösung hat den Nachteil, dass Firefox nun auch bei einem tatsächlichen Crash nicht wiederhergestellt wird.


    Mit beiden Lösungen hatte ich bisher keine weitere Sitzungswiederherstellung-Meldung. Bei der 2. Lösung ist das auch zu erwarten, denke ich.


    Folgendes möchte ich auch noch loswerden: Dafür, dass dieses Forum laut der offiziellen Mozilla-Seite das deutschsprachige Forum für Firefox sein soll, ist meine Erfahrung hier ziemlich enttäuschend. Ausführliche Beschreibungen werden nicht wirklich gelesen und mit Lösungen beantwortet, die in der Beschreibung schon als nicht funktionierend aufgeführt sind. Und dann wird das Thema auf erledigt gesetzt, ohne weiter Lösungsvorschläge zu machen.


    Gruß

    aGizmo

  • was hat diese Antwort denn jetzt mit dem eigentlichen Thema zu tun


    Du hattest geschrieben, das Problem für dich damit gelöst zu haben, ein Downgrade auf Firefox 95 durchgeführt zu haben. Hätte das aus deiner eigenen Sicht nichts mit dem Problem zu tun, hätte es keinen Grund gegeben, das zu erwähnen. Und da sich meine Antwort ganz direkt auf deinen Beitrag bezieht, verstehe ich die Frage nicht, was das mit dem Thema zu tun haben soll. Denn dann hätte deine eigene Aussage ja auch nichts mit dem Thema zu tun. Das ergibt also keinen Sinn.


    Völlig unabhängig davon ist es im Sinne eines verantwortungsvollen Supports unbestritten wichtig, darauf einzugehen, auch wenn es vielleicht nicht das primäre Thema ist. Die Nutzung von Firefox 95 stellt zu diesem Zeitpunkt ein erhebliches Sicherheitsrisiko dar. Statt dich über die Antwort zu beklagen, hättest du auch einfach die dir gestellte Frage beantworten können. Das wäre zielführender gewesen.


    warum wird das Thema auf „erledigt“ gesetzt, ohne dass auch nur ansatzweise auf meine wieder recht ausführliche Beschreibung des Verhaltens eingegangen wird? […] Ausführliche Beschreibungen werden nicht wirklich gelesen


    Wegen genau dieser Aussage. Du hast laut eigener Aussage ein Downgrade auf Firefox 95 durchgeführt und abgesehen davon, dass das Problem mit der Version ja nicht aufgetreten ist und das Thema damit ja tatsächlich erledigt war, bekommst du in diesem Forum keinen Support für eine veraltete Firefox-Version. Auch über diese Frage muss ich mich wundern, immerhin steht genau das ja in den Nutzungsbedingungen dieses Forums, denen du ausdrücklich zugestimmt hast. Oder hast du diese etwa überhaupt nicht gelesen und unterstellst uns dann tatsächlich, dass wir deinen Beitrag nicht gelesen hätten?


    Ich habe für mich zwei evtl. funktionierende Lösungen gefunden. Vielleicht helfen diese ja anderen Leuten mit diesem Problem, die über eine Internet-Suche auf dieses Forum stoßen.


    Es freut mich, dass du eine für dich funktionierende Lösung gefunden hast, und ich bedanke mich dafür, dass du deine Ansätze geteilt hast. Vielleicht helfen diese ja tatsächlich auch anderen.


    Folgendes möchte ich auch noch loswerden: Dafür, dass dieses Forum laut der offiziellen Mozilla-Seite das deutschsprachige Forum für Firefox sein soll, ist meine Erfahrung hier ziemlich enttäuschend.


    Es tut mir leid für dich, wenn dir dieses Forum nicht helfen konnte. Dieses Forum hat eine extrem hohe Erfolgsquote, aber selbstverständlich können wir auch nicht immer eine Lösung anbieten oder erster sein. Hier sind auch nur Menschen aktiv, die unbezahlt und ihrer Freizeit ihr Bestes dafür tun, so vielen anderen Firefox-Nutzern zu helfen wie nur möglich.


    Aber: Es haben sich Menschen mit deinem Problem auseinandergesetzt und die Tatsache, dass du selbst schneller auf eine Lösung gekommen bist, ist keine Rechtfertigung dafür, uns Vorwürfe zu machen, zumal sich dir gegenüber niemand falsch verhalten hat. Wie gesagt: Wir sind alle nur Menschen.