Addons Hintergrundfarbe

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Firefox-Version
    91.1.0esr
    Betriebssystem
    Linux Debian Sid

    Hallo zusammen,


    ich bin auf der Suche nach dem Bezeichner, welcher in der Addons Ansicht - weitere Optionen - die Hintergrundfarbe ändert.

    Ich habe ein dunkles Systemtheme, da ist der weiße Hintergrund absolut störend.

    Alles andere habe ich nach meinen Vorstellungen eingerichtet, aber diesen einen finde ich in den Browser-Werkzeugen einfach nicht.

    Hat da jemand mehr Glück als ich?

    Ein Screenshot verdeutlicht die Sache:


  • Hat da jemand mehr Glück als ich?

    CSS
    #main > addon-list:nth-child(1) > section:nth-child(2) > addon-card:nth-child(2) > div:nth-child(1) > addon-options:nth-child(5) > panel-list:nth-child(1) { background: red !important; color: white !important; }

    Besser so:


    CSS
    #main > addon-list:nth-child(1) > section:nth-child(2) > addon-card:nth-child(n+2) > div:nth-child(1) > addon-options:nth-child(5) > panel-list:nth-child(1) {
      background: red !important;
      color: white !important;
    }
  • Erstmal Danke für die Schnipsel.

    Leider aber bleibt der Hintergrund weiß mit schwarzer Schrift, wie auf meinem Screenshot.

    Ich habe beide Varianten probiert, eine neue userContent.css angelegt nur mit Deinem Code, damit da nichts anderes zwischenfunken kann.

    Ebenfalls die userChrome.css auskommentiert, auch habe ich den roten background gelassen zwecks besserem Kontrast, aber nichts zu machen, es bleibt unverändert.

    Ich vermute mal, daß es wieder so eine Besonderheit in Linux ist. Sonst habe ich keine andere Erklärung.


    Nun ja, allzu oft ruft man das ja auch nicht auf, daher ist es weiter nicht tragisch.

    Aber seltsam ist es schon...


    Trotzdem vielen Dank für Deine Mühe.

  • Also unter Windows funktioniert Andreas' Lösung hier in der 91.1esr!


    Wenn du ein dunkles Theme ausgewählt hast, dann sollte doch das ausgeklappte Panel eigentlich auch dunkel sein? Versteh ich nicht. :/


    Alternativ:

    CSS
    addon-options panel-list {
      background: blue !important;
      color: white !important;
    }
  • Ich habe den Fehler gefunden.

    Der steckte in der prefs.js und nicht etwa in der userContent oder userChrome, und schon gar nicht im Firefox für Linux.

    Wie immer zu suchen vor dem Bildschirm...

    Da es sonst keine Fehler gab und nur dieses einzige Menü fehlerhaft war, bin ich darauf nicht gekommen, und habe mich in den

    Browser-Werkzeugen fast zu Tode gesucht.

    Vielen Dank an euch beiden für die Schnipsel und für den Stupser in die richtige Richtung.

  • So, nochmal ein Nachtrag für interessierte Mitleser, die ebenfalls über solch ein Verhalten stolpern.


    Auch in meiner prefs.js war kein Fehler, sondern der Verursacher ist folgende Einstellung:

    Sprache und Erscheinungsbild - Farben - Oben ausgewählte Farben anstatt....

    _IMMER_

    Wenn das ausgwählt ist, kann man sich auf den Kopf stellen, dann greifen teilweise andere Vorgaben nicht mehr.


    Ich erinnere mich, letztens noch etwas darüber gelesen zu haben, daß diese Einstellung "unerwünschte Nebenwirkungen" haben kann.

    Aber wenn ich die besuchten Webseiten in meinen dunklen Farben haben will, bleibt mir gar nichts anderes übrig, da ich mit meinen Augen

    keinen hellen Hintergrund haben kann.

    Da beißt sich die Katze in den Schwanz...


    Gottseidank ist es nur dieses eine kleine Menü, der Rest ist so wie gewünscht. Damit kann ich gut leben,

    und ich weiß ja jetzt, woher es kommt.

  • Danke für den Code aus Beitrag #2.

    Freut mich wenn auch andere user den Code nutzen möchten, gern geschehen :)


    ich weiß ja jetzt, woher es kommt.

    Danke für die Erklärung, hilft evtl. anderen auch mal :thumbup:

    Mit freundlichem Gruß
    Andreas
    Mein Laptop    Meine Add-ons

    Einmal editiert, zuletzt von 2002Andreas () aus folgendem Grund: Ein Beitrag von 2002Andreas mit diesem Beitrag zusammengefügt.