Beiträge von clio

    Die Endung müßte .xpi sein. Bei einem Klick darauf sollte sich die Erweiterung öffnen, dann schaust Du in die manifest.json nach dem Titel. So sollte es auch in Windows funktionieren, in Linux geht es zumindest so...

    Tja, wir sind schon gut ...;-)

    Wahrscheinlich freuen wir uns aber nur darüber...denk dran, immer von den geänderten Dateien auch ein Backup zu machen,

    wäre doch ärgerlich, wenn man wieder von vorne beginnen müsste.

    Das ist auch ein Grund, warum ich nur die esr-Versionen nutze, da kann ich mein CSS länger mitschleppen, da dort so oft keine deutlichen Änderungen kommen.

    Viel Spaß noch beim Tüfteln.

    Ich wollte auch gerade noch was schreiben, da habe ich Deinen Eintrag gesehen.

    Schön, daß Du es gelöst hast. Ich wollte u.a. noch die Tastenkombi Strg+Umschalt+Y erwähnen.

    Ich sehe aber, daß wir die Funktion doch sehr unterschiedlich nutzen. Ich habe z.B. keine Icons in der Leiste, habe überhaupt nur eine einzige Leiste mit Inhalt, meine Tableiste ist links angeordnet, also von der Standardansicht ist nicht mehr viel übrig.

    Ich habe auch für mich die perfekte Lösung gefunden, eben abgestimmt auf meinen persönlichen Geschmack.

    Ein Bild:


    und mein CSS-Schnipsel:


    Hm, so ganz verstehe ich Dich jetzt nicht.

    Ich beschreibe mal, wie ich das eingerichtet habe:

    Variante 1

    1. browser.download.alwaysOpenPanel steht auf true

    2. Der Download startet, das runde Icon erscheint mit der %Anzeige, ebenso das darunterliegende Fenster mit dem Balken der Fortschrittsanzeige. Nach dem Ende erscheint noch das Icon mit dem nach unten zeigende Pfeil, dann ist das Downloadfenster

    (Icon und Fenster) wieder verschwunden.


    Variante 2

    1. browser.download.alwaysOpenPanel steht auf false

    2. Der Download startet, das runde Icon erscheint mit der %Anzeige des Fortschritts. Das darunterliegende Fenster öffnet sich nicht.

    Nach dem Ende des Downloads erscheint das Icon mit nach unten zeigenden Pfeil und bleibt auch an der Stelle. Erst nach einem Klick darauf verschwindet das Icon und der Bereich ist wieder leer.


    Diese beiden Möglichkeiten sind abhängig von dem Eintrag in about:config. Irgendwas muß man also auswählen.

    Immer auch mit den Einträgen in der userChrome.css

    Sonst wüßte ich keine andere Variante.

    Etwas einfacher geht es, wenn man in about:config den Parameter

    browser.download.alwaysOpenPanel auf true setzt.

    Zusätzlich in die userChrome.css diesen Eintrag:

    #downloads-button:not([attention="success"], [progress], [attention="warning"],
    [attention="severe"])
    { display: none !important; }

    Dann verschwindet der Button nach Ende des Downloads automatisch ohne Klicks.

    Zitat

    da ich (soweit ich weiß) nur ALLE "flexibler Leerraum" Buttons damit ändern kann und nicht nur einen.

    Schon richtig, aber wenn man z.B. die Breite auf zwei oder drei Pixel setzt, kann man damit gut jonglieren. Man setzt dann halt soviele Leerräume wie man braucht. Damit ist man dann wirklich flexibel.

    Der TE schreibt ja in Beitrag #45 wie er den FF nach einer Änderung startet, nämlich im Fehlerbehebungsmodus, und das mehrfach.

    Wie man auf die Idee kommen kann, ist allerdings sehr seltsam. Denn wenn man sich den Text mal durchliest, wird man feststellen, daß dieser Modus auf Extensions und Javascript Einfluß nimmt, was ja so auch gewollt ist.

    Daher wundert es nicht, daß beim TE selten was auf Anhieb funktioniert. Vielleicht sollte er dies nochmal aufmerksam lesen:


    Probleme analysieren im Fehlerbehebungsmodus von Firefox | Hilfe zu Firefox


    Zitat

    Zusätzlich zur Deaktivierung der Add-ons (Erweiterungen und Themes) und dem Abschalten der Hardwarebeschleunigung deaktiviert der Fehlerbehebungsmodus von Firefox die Seitenisolierung (Informationen in englischer Sprache), den JavaScript Just-in-time (JIT) Compiler und ignoriert die optionalen Dateien userContent.css und userChrome.css (sofern vorhanden). Die Datei xulstore.json (dort werden die an Symbolleisten, Steuerelementen oder der Fenstergröße vorgenommen Änderungen gespeichert), wird ebenfalls ignoriert, allerdings bleiben die im Konfigurationseditor geänderten Einstellungen in Kraft.

    So, ich habe nochmal sämtliche Einstellungen und Varianten überprüft und habe jetzt ein Endergebnis.

    Erstmal vorweg, diese Aktion betrifft wohl nur Linux-User wegen der Abhängigkeit zu Gtk3. Ob Mac-User ebenfalls betroffen sind, weiß ich nicht, da Mac ja auf FreeBSD basiert und Gtk3 evtl. gar nicht genutzt wird.

    Windows-User sind wohl außen vor, von diesem OS habe ich aber keine Ahnung.


    Was ich festgestellt habe:

    1. Wenn die o.a. neue Funktion im 99er aktiviert ist, in den Einstellungen bei Farben - Oben ausgewählte Farben.... "Immer" und der Haken für "Systemfarben verwenden" gesetzt ist, passiert Folgendes:

    Die Ansicht erscheint bei einem dunklen Theme wie in meinem Screenshot oben, der CSS-Code funktioniert nicht mehr, ebensowenig wie ein Javascript (von Aris bzw. Andreas' aus diesem Thread Scrollbar geht bei vielen seiten nicht mehr). Die Scrollbar verschwindet komplett, mit der Maus kann aber noch gescrollt werden.


    2. Wenn ich die neue Funktion deaktiviere, funktioniert das Javascript wieder, leider aber nicht der CSS-Code.


    In meinem Fall muß ich aber die Einstellungen bei den Farben beibehalten, damit die aufgerufenen Webseiten ebenfalls die voreingestellten Farben haben und nicht etwa einen hellen Hintergrund (Augenprobleme).


    Ich habe auch mal die Nightly 101.x angesehen, dort ist ja die neue Auswahl von Themes für die Anzeige von Webseiten.

    Aber auch das hat nicht weitergeführt. Aber vielleicht tut sich da noch was, mal abwarten.


    Ich hoffe, ich konnte den Linuxern etwas helfen und Klarheit in die Sache bringen.

    Das Addon und auch ein Script bzgl. der Scrollbar funktioniert halt nicht mehr, das hatte ich in meinem ersten Beitrag vergessen zu schreiben. Hast Du denn die Version 99.0 im Einsatz und diesen Parameter aktiviert?

    Denn mit Version 98 funktioniert ja noch das alte Verhalten.

    Über die neue Scrollbarfunktion bzgl. Linux Gtk3 freue ich mich sehr.

    Hier noch eine kurze Info dazu aus https://linuxnews.de/2022/04/f…k-overlay-scrollbars-ein/

    Zitat

    Firefox 99, das von Mozilla am heutigen Dienstag freigegeben wird, führt unter Linux als optisches Highlight GTK Overlay Scrollbars ein. Damit wird ein Bugreport geschlossen, der bereits vor sieben Jahren erstellt wurde. Dabei geht es um die in GTK-Umgebungen oft verwendeten kaum sichtbaren Scrollbalken, die sich erst bei Berührung des Mauszeigers verbreitern und danach wieder zu einem dünnen Strich werden. Noch ist diese Funktion aber nicht standardmäßig aktiviert. Dazu muss in about:config der String widget.gtk.overlay-scrollbars.enabled auf true gesetzt werden.

    Ich habe diese Funktion aktiviert und sehe nun die Scrollbar wie im restlichen System in jeder Anwendung. Sehr schön...aber

    bei Mauskontakt hat der Slider richtigerweise die Farbe des Systemthemes, der Hintergrund ist aber weiß.

    Das ewige Problem bei einem dunklen Systemtheme. Ein Screenshot verdeutlicht das:



    Ich weiß wohl, das ist eigentlich nicht der Rede wert, da dies ja nur bei Mauskontakt erscheint, aber ich wüßte doch gerne, ob sich der Hintergrund noch anpassen läßt.


    Der alte CSS-Code zur Farbgebung der Scrollbar funktioniert leider nicht mehr:

    :root
    { scrollbar-color: #191F21 transparent !important; }


    Vielleicht hat ja jemand eine Idee, würde mich sehr freuen.

    In Einstellungen - Allgemein - Farben sollten auch die von Dir gewünschten Farben eingetragen sein und nicht nur der Haken bei Systemfarben. (s. mein Beitrag zuvor)

    Da kannst Du mit den Einstellungen probieren.


    Welche Distro und welcher Desktop ist im Einsatz?

    Firefox nutzt Gtk3, wenn Du Qt nutzt, sollte im Paketmanager ein Paket zur Angleichung von Gtk an Qt sein. Da mußt Du mal suchen.

    Möglich, daß da die Unterschiede herkommen.

    Nur als Hinweis:

    In meinem Linux Debian Sid werden in der Nightly 99.0a1 die Farben des Systemthemes richtig dargestellt.

    Ich habe ein eigenes, dunkles Gtk3-Theme, in den FF-Einstellungen habe ich:

    1. layout.css.prefers-color-scheme.content-override -> 2

    2. Einstellungen - Allgemein - Farben

    angehakt sind "Systemfarben verwenden" "Links unterstreichen"

    Oben ausgewählte Farben anstatt ........ "immer"

    In den vorgegebenen Bereichen habe ich auch meine eigenen Farben eingetragen

    3. about:addons - Themes -> Systemtheme automatisch

    Nach den Änderungen im 95er u.a. an den Themes, hatte ich mal den 96.0beta getestet. Der kann das jetzt alles, was mir so vorschwebte, wirklich sehr schön.

    Alle Farben passen nun zum Systemtheme, auch an den richtigen Stellen. Das läßt hoffen für den neuen ESR, aber bis dahin dauert es noch eine Weile.

    Hier mal ein Bild:


    Im Gegensatz zu anderen sieht es bei mir sehr minimalistisch aus, aber genau so soll es sein.

    Zitat

    Bei uns liegt ein Problem mit den Intel-Graka-Treibern vor – der i915-Treiber ist zwar installiert, von xorg wird aber der standardmäßige modesetting aufgerufen.

    Ich nutze den Treiber auf meinem Debian Sid ebenfalls.

    Du solltest in /etc/X11/xorg.conf.d eine xorg.conf anlegen mit diesem Inhalt:

    Zitat

    Section "Device"

    Identifier "Intel"

    Driver "intel"

    EndSection

    Dann wird auch der Intel für i915 statt des modesettings verwendet.