Beiträge von BarbaraZ-

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.

    Emil Mangelsdorff, ein hervorragender Jazz-Musiker ist im Alter von 96 Jahren gestorben.


    https://www.deutschlandfunk.de/der-saxophonist-emil-mangelsdorff-ist-tot-104.html

    .DeJaVu

    Danke für die Aufschlüsselung. Ich werde, da es, wie ich finde, übersichtlicher ist, das Ganze nochmal anpassen.

    Und ja, da ich mich erst langsam einarbeite, wird es noch ein wenig dauern, ehe ich da einigermaßen Durchblick habe.

    Aber solche Hinweise finde ich sehr wertvoll.

    grisu2099,

    Danke damit klappt es. Danke Euch für die Hilfe.

    Habe hier für mich viel gelernt. Nun heißt es, sich mit den Entwicklerwerkzeugen zu beschäftigen, damit ich solche Sachen auch zuordnen kann.


    Verständnisfrage. Kann ich -appearance dann generell weglassen, wenn ich oben mit @-moz-document den Aufruf erzeuge?

    Hier klappt es leider nicht.


    Statt des Icons und background red bei hover wird als Symbol ein Häkchen gesetzt und der Hintergrund bleibt schwarz. :/


    Es sollte eigentlich dieses Icon statt des Häkchens erscheinen.


    Selbst die Konstellation mit background-image und background-color (siehe unten), bringt nicht den gewünschten Effekt.

    CSS
     #menu_tabsSidebar:hover{
        -moz-appearance:none !important;
        margin-right: -1px !important;
        background-image url("file:///F:/ICONS/Firefox/Menue-Icons/Ansicht-Sidebar-Lesezeichen.png") no-repeat !important;    
        background-color: #f44336 
        border-width: thin !important;
        min-height: 24px !important;
        padding-left: 35px !important;
        background-position: 10px 10px !important;
        }

    milupo

    Ja, das mit den doppelöten Symbolen habe ich auch. Lupe und Häkchen. Habe es aber so definieren können, das die Lupe den Haken fast überdeckt. Also nicht so tragisch und für mich okay.


    Nun habe ich den code mal etwas geändert:

    Habe nun oben background-color gesetzt. Nun macht er das, was er machen soll.

    Eigentlich - Allerdings zeigt es mir nun das Icon nicht bei "aktiv" an, dafür bei hover.


    Ist schon irgendwie eigenartig aber ich probiere weiter.

    Mit background-color zusätzlich bei hover ändert sich nichts.


    Vielleicht haben Endor oder 2002Andreas ja noch eine Idee.

    Wobei, ich versuche mal die Farbe, Anregung von Dharkness aus Beitrag #22, mit #f44336 zu setzen. Mal sehen.


    Jepp das ist die Lösung!


    So sieht es aus und klappt tadellos.

    Nun würde mich interessieren, warum es sorum klappt und andersrum nicht?

    milupo


    Danke für den Hinweis. Nun klappt es.

    Allerdings verschiebt er mir nun hier das Icon bei hover:


    CSS
    #menu_zoomReset:hover{
        -moz-appearance:none !important;
        margin-right: -1px !important;
        background: red url("file:///F:/ICONS/Firefox/Menue-Icons/Ansicht-Zoom-Tatsächliche Größe.png") no-repeat !important;    
        border-width: thin !important;
        border-style: solid !important;
        min-height: 15px !important;
        padding-left: 35px !important;
        background-position: 10px 10!important;
        }

    in die obere linke Ecke.


    Und mit background-color bleibt es bei hover zwar bestehen aber färbt sich nicht ein.


    Ich gebe aber nicht auf.

    So geschehen.

    Allerdings greift background-color: red nicht bei hover.

    Selbst wenn ich aus background-color nur background mache. klappt es nicht.

    Dachte über diesen Trick schaffe ich es.

    So, ich habe jetzt die erste Zeile auskommentiert und den Code versetzt.

    So weit, so gut.


    Nun hat er mir aber mein Icon stibitzt.


    Hier der Codeschnipsel:

    CSS
     /*#viewFullZoomMenu menuitem[label="Nur Text zoomen"],*//*Zoom-Nur Text zoomen*/
        #viewFullZoomMenu menuitem[label="Nur Text zoomen"][type="checkbox"][checked="false"] > .menu-iconic-left { 
        appearance: none !important;
        background: url("file:///F:/ICONS/Firefox/Menue-Icons/Ansicht-Zoom-Nur Text zoomen.png") no-repeat !important;
        margin-left: 5px !important;
        min-height: 24px !important;
        padding-left: 10px !important;
        background-position: 5px 5px !important;
        }

    Das ist schon mal großartig. :thumbup:

    Jetzt weis ich, welche Auswirkungen das hat. Danke für den Hinweis


    Habe die Zeile entfernt. Nun ist der Text auch wieder zu lesen, allerdings nicht rot unterlegt bei hover, was er eigentlich sollte .

    Damit blendet er mir komplett den Eintrag: "Nur Text zoomen" incl. Icon aus.

    Ach ja, ursprünglich wurde das auch in Zeile so angesprochen.


    Sogar in beiden Zeile, siehe Zeile 157 und 158 in Beitrag #1.

    So, den Fehler gefunden.

    Es hängt mit folgendem Eintrag zusammen:


    CSS
    #viewFullZoomMenu menuitem[label="Nur Text zoomen"]{ /*Zoom-Nur Text zoomen*/
        #viewFullZoomMenu menuitem[label="Nur Text zoomen"][type="checkbox"][checked="false"] > .menu-iconic-left 
        display: none !important;
        appearance: none !important;
        background: url("file:///F:/ICONS/Firefox/Menue-Icons/Ansicht-Zoom-Nur Text zoomen.png") no-repeat !important;
        margin-left: 5px !important;
        min-height: 24px !important;
        padding-left: 10px !important;
        background-position: 5px 5px !important;
        }

    Normalerweise ist am Ende der 2. Zeile eine offene Klammer.

    Wenn ich diese wieder setze, deaktiviert es alle folgenden Einträge, macht mir aber bei hover genau das, was in Beitrag #8 dargestellt wird.


    Mit dem dargestellten Code ist alles wieder aktiv, nur eben bei hover nicht das Feld "Nur Text zoomen" in rot unterlegt.


    Hier nochmal der komplette jetzige Code mit dem Schnipsel von oben:


    Sieht schon gut aus. Bei Sidebar Lesezeichen (Bildchen 3) fehlt mir noch und die Ausblendung beim Webseitenstil "Kein Stil" (Bildchen 5).

    Ach ja, die Abschlußßklammer für die Zeilen 58 und 159 waren noch notwendig. Die hatten alles außer Kraft gesetzt.

    Bin gerade dabei, die einzelnen "Abschnitte" einzufügen.

    Zum Teil setzen die sich dann gegenseitig außer Kraft. Muss also erst einmal in Ruhe probieren.


    Habe dabei in den Zeilen 58 und 159 noch jeweils einen Klammerfehler gefunden.