Firefox ändert URL wenn in neuen Tab geöffnet wird

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Firefox-Version
    75
    Betriebssystem
    Win10

    Ich öffne oft Links in einem Neuen Tab. Langsam kommen mir Zweifel ob ich wirklich immer das sehe was andere sehen.

    Beispiele im Link, der ab heute 1 Jahr gültig ist

    https://mozhelp.dynvpn.de/past…5kkwyq9JMcsM9oaZm4nGy53a3


    1.) http://help//foo Direktklick -> Server nicht gefunden; öffnen in neuen Tab -> http://www.help.com/foo


    2.) http://http//foo/ Direktklick -> Server nicht gefunden; öffnen in neuen Tab -> http://www.http.com//foo/


    3.) http://https//foo/ Direktklick -> Server nicht gefunden; öffnen in neuen Tab -> http://www.https.com//foo/


    Gibt es eine logische Erklärung warum das so ist. Warum bekomme ich bei Direktaufruf eines Links ein anderes Ergebnis als wenn ich den Link in einem neuen Tab öffne?

    Mir ist bekannt, dass Links ohne Domainangabe (wie .de, .at, it usw) vervollständigt werden durch .com. und ggf auch durch das prefix .www Aber warum nur bei Links in neuen Tabs und nicht bei direkten Klick auf den Link?

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Chromium macht es richtig, aber bei Firefox habe ich in Erinnerung, dass es sich eine Art Komplettierung via Google-Anfrage holt und die wahrscheinlichstes URL nutzt. Ich hab nur keine Idee, mit welcher pref man das abschalten kann.


    #

    Evtl die Einträge mit "fixup".

    https://www.reddit.com/r/firef…lete_com_address_command/


    jup: browser.fixup.alternate.enabled <-- false und dann klappt das auch in Firefox.


    Also ein gewolltes Feature, auch das autocomplete (fixup) mit www oder .com, ist also schon ziemlich alt.

  • nein, das mit der Google Anfrage ist Quatsch.

    Wie man die Vervollständigung grundsätzlich deaktiviert wird, weiß ich auch. Warum Firefox überhaupt vervollständigt (suffix und prefix), das ist vielleicht generell diskussionswürdig, aber darum geht es mir gar nicht. Ich möchte einfach eine logische Erklärung dafür haben warum Firefox es unterschiedlich handhabt wenn etwas im gleichen oder im neuen Tab/Fenster geöffnet wird.

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Das ist kein Quatsch, das ist oder zu mindestens war mal so. Wenn du was eingegeben hast, was keine Url war, wurde da per Google ne Adresse draus. Mit der Omnibar könnte das aber weggefallen sein.

  • Aus einer Eingabe in die Adressleiste von Firefox wurde noch nie "per Google" irgendetwas. Das einzige, worin Google in Bezug auf die Adressleiste jemals involviert war, sind die Suchmaschinen-Vorschläge, sofern entsprechendes Feature aktiviert ist und Google überhaupt als Standard-Suchmaschine genutzt wird. Unabhängig vom Datenschutz-Problem, weil du darüber weder informiert wirst noch eine sichtbare Einstellung zum Abschalten hast, wäre es auch völlig überflüssig, für das, was du meinst, irgendeinen Server zu kontaktieren. Eine solche Logik kann ganz einfach im Produkt implementiert werden - und ist es auch.

  • Ich weiss um die Vervollständigung mit www und com oder auch de. Aber es gab mMn auch eine Zeit, wo solche Anfragen nichts ergaben Firefox da irgendwas reingesetzt hat und das kam nicht von Firefox. Ich kann mich leider nicht mehr erinnern, wann die Omnibar implementiert wurde, bis dahin die Adressleiste nur als solches nutzbar war. Du kannst mich gerne Lügen strafen bei sowas, weil das wirklich zu lange für mich her ist - und dann nehme ich alles zurück und behaupte das Gegenteil :D

    Alles andere macht eben "fixup".

  • Schade, meine eigentliche Frage kann wohl niemand beantworten.

    Ich überlege ob es sinnvoll wäre dafür ein Bugzilla Ticket zu eröffnen.:/

    Oder wo könnte ich noch diesbezüglich Antworten erhalten? irgendwelche Vorschläge?

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Ich denke, da wird wohl nen Ticket für angebracht sein. Ich könnte mir das Verhalten jedenfalls nur so erklären, dass man beim gleichen Tab das Ergebnis direkt sieht. Während bei einem neuen Tab unter Umständen dieser ja im Hintergrund geöffnet wird und man so das Ergebnis nicht sofort sieht.

  • Was ich auf die Schnelle gefunden habe, dass es einst nur für http aktiv war, nicht für https

    https://support.mozilla.org/en-US/questions/1212735


    Eben mit Firefox 75 kontrolliert, ist immer noch so. Firefox 75 unterscheidet anscheinend die manuelle Eingabe und Links, die im selben Tab zu öffnen sind. Klicke ich den ersten Link an, passiert nichts (nicht gefunden) - gebe ich das manuell ein, wird gefixt, selber Tab.


    Persönlich würd ich sagen - das ist so gewollt, dass zwischen Eingabe und Link bei neuem oder selben Tab in vier Möglichkeiten unetrschieden wird

  • AngelOfDarkness Mit sofort sehen und nicht sofort sehen, hat das nichts zu tun. Es wird bei direkten Tab nicht um www. beziehungsweise .com ergänzt

    Außerdem ist das Verhalten bei "Link neuem Tab öffnen" identisch wie "Link in neuem Fenster" öffnen und dort sieht man es ja auch sofort, gnauso auch wenn man eingestellt hat "Tabs im Vordergrund öffnen"

    Einfach mal anhand der Beispiele dort https://mozhelp.dynvpn.de/past…5kkwyq9JMcsM9oaZm4nGy53a3 selbst ausprobieren ;)

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • Hallo

    Ob das in irgend einer Form weiterhilft weiß ich nicht, aber der Hinweis am Rande, dass hier die gleiche URL erscheint, egal ob der Link aus Beitrag 1 direkt aufgerufen wird, oder über das Kontextmenü "Link in neuem Tab öffnen".
    Das gleiche gilt für die Textlinks 1.) bis 3.). Eine Seite mit dem Hinweis "Server nicht gefunden" erscheint jedoch nicht.

    Grüße


  • Du hast garantiert nicht mit einem frischen Profil ohne jeglichen Modifikationen/Erweiterungen getestet, oder bist nicht so vorgegangen wie ich es in Beitrag #1 beschrieb.

    Also nochmal:

    1. Frisches Profil

    2. Link https://mozhelp.dynvpn.de/past…5kkwyq9JMcsM9oaZm4nGy53a3 aufrufen

    3. Den ersten DARIN befindlichen Link anklicken

    4. Zurück Button damit du wieder auf https://mozhelp.dynvpn.de/past…5kkwyq9JMcsM9oaZm4nGy53a3 kommst

    5. Das gleiche mit Link 2 und Link 3

    6. Das gleiche machen aber jetzt mit "Link in neuen Tab öffnen"

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Ich hatte schon vermutet, dass da ein Denkfehler meinerseits vorliegt.
    Da nachgereichte verständliche Anleitung für Experten wie mich hat es bestätigt.


    Gute Nacht