65.0b4 (64-Bit): Suchvorschläge sichtbar, trotz Deaktivierung

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hallo Kollegen,


    seit FF 65b (64-Bit) (auf macOS 10.13.6 High Sierra) wirkt offensichtlich die Einstellung "Suchvorschläge anzeigen" nicht mehr. Sollte "1" nicht "2" verhindern? :-??
    Getestet in einem völlig leeren, neuen Profil.



    [attachment=0]Bildschirmfoto 2018-12-15 um 21.08.03.jpg[/attachment]

  • Das sind aber keine Suchvorschläge die dir da angezeigt werden, sondern (Google-)Seiten aus deiner Chronik.
    Suchvorschläge hingegen haben links eine Lupe als Icon und zeigen rechts auch keine URL an. ( :arrow: siehe Screenshot unten)
    Lösche daher einmal deine Chronik, und die Einträge aus deinem Screenshot sollten nicht mehr angezeigt werden.


    [attachment=0]2018-12-15_21-39-54.png[/attachment]

  • Selbst im privaten Modus und mit gelöschter Chronik erscheint das hier:



    [attachment=1]Bildschirmfoto 2018-12-15 um 21.44.30.jpg[/attachment]



    Ich hab das mit einem neuen Profil getestet, weil diese "Suchvorschläge" (oder was das auch immer ist) in meinem "Arbeitsprofil" erst seit FF65 Beta aufgetreten sind - obwohl ich die gesamte Chronik standardmäßig beim Schließen des Browsers löschen lasse und auch das hier eingestellt ist:



    [attachment=0]Bildschirmfoto 2018-12-15 um 21.51.58.jpg[/attachment]



    Sollte so nicht sein.

  • und wo ist nun der Suchvorschlag? ich sehe keinen. Du gibtst te ein und es wird gefragt ob du nach te suchen willst. Dies ist KEIN Suchvorschlag. Also alles wie es sein soll.

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • Sollte so nicht sein.


    Nein, das ist ganz normales Standardverhalten, denn hier handelt es sich nicht um einen Suchvorschlag, sondern es wird lediglich angezeigt, dass der eingegebene Begriff, für welches es keinen Treffer in der Chronik/Lesezeichen gab, bei Eingabe mit der eingestellten Standardsuchmaschine gesucht wird.
    Wenn du dieses Verhalten gerne deaktivieren möchtest, dann kannst du unter about:config den Schalter keyword.enabled auf false setzen.

  • Gut, anders ausgedrückt: Vor FF65 ist dieses "Pup-up", oder wie auch immer man das bezeichnet, nicht erschienen. Die einzige Änderung war eben das Update auf FF65 Beta. Ich möchte dieses "Pop-up" nicht.


    EDIT: "keyword.enabled auf false setzen" hatte ich überlesen. Danke, versuche ich sofort.

    Gruß
    Manfred


    FF in aktueller Betaversion, auf MacBook Pro 15" Late 2015 unter macOS Mojave 10.14.6

  • keyword.enabled auf false wird bei der Eingabe von te versuchen die Adresse http://te/ aufzurufen, die dann weiter leiten zu http://te.com und dies wiederum zu https://www.te.com und weiter zu https://www.te.com/deu-de/home.html . Ich glaube kaum dass du das willst.


    Und das Aussehen in deinen Screens ist in Firefox 64 völlig identisch und war auch vorher (Firefox 63) schon so.

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)


  • Gibt es schon eine ganze Weile länger, und ist somit nichts neues.

    Bei mir nicht. Tritt hier tatsächlich erst seit FF 65 Beta auf. :-??


    "keyword.enabled" auf false bewirkt:



    [attachment=0]Bildschirmfoto 2018-12-15 um 22.14.47.jpg[/attachment]



    Bekomme ich das auch noch irgendwie weg?


  • Hast du hier auch den Haken entfernt?

    Ja. Bei jeder Option die annährend dafür verantwortlich sein könnte, sind die Häkchen entfernt.



    [attachment=3]Bildschirmfoto 2018-12-15 um 22.26.10.jpg[/attachment]




    [attachment=2]Bildschirmfoto 2018-12-15 um 22.26.36.jpg[/attachment]




    [attachment=1]Bildschirmfoto 2018-12-15 um 22.26.47.jpg[/attachment]




    [attachment=0]Bildschirmfoto 2018-12-15 um 22.27.04.jpg[/attachment]

  • klickman: was keyword.enabled auf false bewirkt hatte ich bereits vor dir geschrieben (wir schrieben ziemlich zeitgleich, deshalb vielleicht nicht gesehen?)
    Und nochmal: nein, diese Anzeige gibt es schon seit x Versionen, da hat sich überhaupt nix geändert.

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Danke Zitronella, ich hatte deine Nachricht später gelesen. Ich kann nicht erklären warum, doch ich kann zu 100% versichern, dass diese Anzeige erst seit 65 Beta bei mir auftaucht. Ich wüsste auch gar nicht, wie ich dieses "Pop-up" nutzen könnte. Und will es ehrlich gesagt auch gar nicht nutzen. Wenn ich etwas suche, dann gebe ich das in das separate Suchfeld neben der Adressleiste ein. Oder auf der Startseite eines neuen Tabs:



    [attachment=0]Bildschirmfoto 2018-12-15 um 22.36.23.jpg[/attachment]

  • Dann browser.urlbar.autocomplete.enabled auf false
    Dann bekommst du da gar nix mehr angezeigt.

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Ist bereits so eingestellt...

    Gruß
    Manfred


    FF in aktueller Betaversion, auf MacBook Pro 15" Late 2015 unter macOS Mojave 10.14.6


  • Ist bereits so eingestellt...


    Jetzt ist mir der Groschen gefallen, weswegen du sagst, dass das Popup bei dir ab Firefox 65 Beta wieder aufgetaucht ist.
    Der Schalter browser.urlbar.autocomplete.enabled gibt es ab Firefox 65 nicht mehr ► siehe auch Bug 1502392


    Wenn man jetzt das Autovervollständigungs-popup ausblenden/deaktivieren möchte, dann geht dies nur noch mittels userChrome.css.
    Wäre beispielsweise mit diesem kurzen CSS-Code möglich:

    CSS
    #PopupAutoCompleteRichResult{
    display: none !important;
    }
  • Jetzt hab ich mir auch mal die 65.0b4 (64-Bit) runter geladen und sehe, dass
    browser.urlbar.autocomplete.enabled
    dort gar nicht mehr existiert, insofern wirkt dieser Wert nicht mehr.


    EDIT: ups, das hat schon einer vor mir gemerkt :mrgreen:

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)

  • Wäre beispielsweise mit diesem kurzen CSS-Code möglich:

    CSS
    #PopupAutoCompleteRichResult{
    display: none !important;
    }

    Das wars! Uff, vielen herzlichen Dank :!::klasse:

    Gruß
    Manfred


    FF in aktueller Betaversion, auf MacBook Pro 15" Late 2015 unter macOS Mojave 10.14.6

  • Wäre nicht auch in about:config
    browser.urlbar.maxRichResults auf 0 eine Möglichkeit? zumindest klappt das bei mir

    Hilfe auch im deutschsprachigen Matrix-Chat möglich oder im IRC-Chat
    Meine Anleitungstexte dürfen gerne "geklaut" und weiter verwendet/kopiert werden
    ;)