Problem "Fenster mit mehreren Prozessen"

  • Moin,


    ich habe das Problem, daß "Fenster mit mehreren Prozessen" auf "0/1 (deaktiviert wegen Add-ons)" steht (na ja, noch stört es mich nicht wirklich). Aber ich wollte doch gerne die Ursache ergründen.


    Mit deaktivierten AddOns starten brachte keinen Erfolg.
    Mit deinstallierten AddOns klappte es jedoch wunderbar.


    Ich habe das Profil gesichert und kann es nach den Spielereien leicht wieder herstellen. Also habe ich die AddOns gesucht, es sind die 4 mit den Sternchen in meiner Liste. Schade, denn besonders PwdHash und auch uc haben es mir angetan:



    Wird das irgendwann mal Auswirkungen haben? Im Moment stört es mich ja nicht...


    Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • Hallo,


    die Auswirkung ist die, welche du selbst erkannt hast: dass du keine Multiprozess-Architektur hast. Und damit auch nicht die Neuerungen, welche die Multiprozess-Architektur voraussetzen (wie Sandboxing für mehr Sicherheit). Darüber hinaus hat das keine direkte Auswirkung. Indirekt natürlich dadurch, dass ab Firefox 57 nur noch WebExtensions unterstützt werden und sich das Problem dann spätestens erledigt hat. Entweder erhalten die betroffenen Add-ons bis dahin ein Update, welches das jeweilige Add-on zu einer WebExtension macht (diese sind grundsätzlich Multiprozess-kompatibel) oder es gibt kein Update, dann funktioniert das entsprechende Add-on ab Firefox 57 nicht mehr. Aber ab Firefox 57 hast du in jedem Fall spätestens die Multiprozess-Architektur. Ob mit oder ohne diese Add-ons.

  • Hallo Sören,


    Deshalb lehne ich mich ja auch noch ruhig zurück, ich habe ja noch ein paar Tage Zeit, aber woran erkenne ich denn überhaupt ob ein AddOn WebExtension benutzt oder nicht? Ich habe lange probiert bis ich die 4 gefunden habe.


    Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • Danke Sören,


    das hat lange gedauert bis ich das kleine Symbol gefunden habe. Aber nun weiß ich für die Zukunft Bescheid.


    Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • Eine Reihe Add-ons haben das Wort "WebExtension" im Namen. Gib auf AMO einfach "webextension" in das Suchfeld ein und nach Enter erhältst du eine Liste dieser Add-ons.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Bei mir sind es 171, aber es haben nicht alle den Begriff auch im Namen. Das mag schon sein, dass es bereits 2000 sind, aber du kannst ja mal alle einzeln nach dem Dreieck durchsuchen. Ehe du da fertig bist, ist Fx 57 erschienen. :)

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Hoffentlich gibt es noch Updates bis 57. Ich denke mal die Entwickler wissen das auch.


    Besonders schön wäre es, wenn das Warndreieck auch gleich in der Übersicht und bei den Suchergebnissen auftauchen würde und nicht erst wenn man das AddOn zur näheren Betrachtung ausgewählt hat.


    Auch vermisse ich seit einiger Zeit den ersten Eintrag (links oben) in der Seite "about:addons" wo man direkt auf die AMO seite zur Auswahl der AddOns kam. Klar, ich habe die in den Lesezeichen, es wird halt überall gespart.


    Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • Ja Andreas,
    der Eintrag "Add-ons entdecken" fehlt bei mir. Ich teste das nochmal mit neuem Profil.


    Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • So direkt finde ich den Code nicht. Deaktivieren und selbst deinstallieren ALLER AddOns bringt den Eintrag nicht. Auch ein entfernen (umbenennen) der "user.js" und des Ordners "chrome" bringt nichts. Aber den ganzen Profilordner löschen und neu anlegen lassen - dann ist der Eintrag da. Gibt es dafür einen Eintrag in "about:config"?


    Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • Nicht das ich wüsste... ggf. meldet sich noch jemand...
    [attachment=1]Screenshot mit Schnipsel - 13, 2017 4.47 PM.png[/attachment]
    [attachment=0]Screenshot ohne Schnipsel - 13, 2017 4.49 PM.png[/attachment]
    Bereinige mal dein Profil.. vielleicht hilft das...

  • Der Tip war jedenfalls nicht schlecht. Folgender Code in Stylish hat das Problem gelöst, !important verhindert ja das weitere verändern:


    /* Addons suchen NICHT ausblenden */
    #category-discover {display: block !important;}


    Damit ist zwar die Ursache nicht gefunden, aber die Auswirkung ist beseitigt. Bis 57 muß das erst mal reichen.


    NACHTRAG:


    Es ist dann zwar die Anzeige vorhanden, aber der Link hat dann keine Funktion. Draufklicken bringt also nichts. Ich werde noch mal drauf rumgrübeln, aber spätestens ab 57 wird es ja ohnehin alles besser.


    Danke, Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE

  • Hast du es denn mal im abgesicherten Modus probiert? Vielleicht ist eine Erweiterung schuld. Das Deinstallieren der Erweiterungen hilft da nicht unbedingt, denn die Einstellungen im Profil bleiben da ja erhalten.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, WordPress und Facebook

  • Ja, im abgesicherten Modus wo alle AddOns deaktiviert sind. Und als 2. Schritt erst alle deinstalliert. Irgend wer/was hat da etwas verändert. Mit einem älteren gesicheten Profil ist dieser Fehler auch weg. Ich möchte das ältere Profil aber nicht benutzen weil inzwischen zu viele Änderungen waren. Nach "bereinigen" ist auch alles OK. Irgendwann mache ich den Schritt, aber noch nicht.


    Danke soweit, Gruß Harry

    FF aktuell, 64Bit, Linux, Manjaro mit KDE