Firefox 3.6pre (Nightly; "Namoroka") in deutsch


  • Ulli ... in der jetzigen Version Firefox "Gecko/20090705 Minefield/3.6a1pre" und der Sprachdatei 0.2.17
    Ist das mit der Ansicht und Lesezeichen / Chronik korrekt.
    Und mit Strg+B bekomme ich auch (ohne Absturz) die Lesezeichen ... Chronik auch.


    Nur so nebenbei :)


    (Ich frage mich eher, wie ich die Rechtschreibprüfung im 3.6 abschalte die hier zudem auch noch jedes Wort markiert, oder ist das das Forum hier ??!? ;) )

    System: Win7/x64 ; Linux Ubuntu, 24" HP LP2475w
    FireFox Info

  • Zitat von gozoc

    Ist das mit der Ansicht und Lesezeichen / Chronik korrekt.

    Danke, stimmt. War mir wegen en-US nicht aufgefallen.


    Zitat von gozoc

    Ich frage mich eher, wie ich die Rechtschreibprüfung im 3.6 abschalte

    Du kannst das Häkchen bei "Rechtschreibung in diesem Feld prüfen" nicht entfernen ?

  • Zitat von .Ulli

    Du kannst das Häkchen bei "Rechtschreibung in diesem Feld prüfen" nicht entfernen ?


    Arg ... ich habe schon überall gesucht, aber den Punkt zuerst übersehen.
    Einstellungen->Erweitert->Allgemein->Browsing/"Rechtschreibung während der Eingabe überprüfen"


    Doch klar ... ;) danke. muss mal die Brille putzen .... hatte mich auch schon gewundert und wollte schon fast im about:config nachsehen :)

    System: Win7/x64 ; Linux Ubuntu, 24" HP LP2475w
    FireFox Info

  • Zitat von gozoc

    hatte mich auch schon gewundert

    Da diese selektive Blindheit bei allen humanoiden Wesen implementiert ist, verwundert mich so etwas schon lange nicht mehr,

  • Zitat von XtC4UaLL

    Versteh zwar immer noch nicht was das mit den en-US builds zu tun hat, aber nun gut, per https://bugzilla.mozilla.org/show_bug.cgi?id=449828#c2 hast du ja eine Antwort erhalten.


    Auch dort hat man meine Frage anscheinend nicht verstanden, was vielleicht auch an meinem schlechten Englisch liegt.


    Aber vielleicht habe ich auch etwas übersehen.
    Wenn ich die Texte zum Thema richtig verstanden habe, gibt es in den l10n-Builds eben diese Funktion, auf die en-US-Strings zurück zu schalten, wenn für eine bestimmte Funktion kein lokalisierter String existiert.
    Das ist natürlich für alle Entwickler toll, die mit den Quelltexten der l10n-Builds über ein Versionsverwaltungssystem (AFAIK Mercurial) arbeiten. Aus diesen Quellen kann nunmehr ein l10n-Nightly-Build erstellt werden, der nicht auf die Nase fällt, wenn die Lokalisierung noch nicht abgeschlossen ist.


    So weit, so toll. Mir persönlich nützt das so aber gar nichts. Ich arbeite nämlich NICHT mit Mercurial, sondern nur mit den originalen en-US Nightly Builds. Im Unterschied zu den l10n-Builds wird bei diesen das Sprachpaket erst über ein separat zu installierendes XPI-Paket nachgerüstet, ist also im Auslieferungszustand noch nicht enthalten.
    Vorteil für mich: Ich muss mich nicht mit Mercurial auseinandersetzen und jeden Tag die gesamten Quellen herunter laden, sondern kann mich ausschließlich aufs Sprachpaket konzentrieren.


    Insofern wäre es eben schön gewesen, wenn die Funktion des Zurückschaltens auf den englischen String auch dann funktionieren würde, wenn ein installiertes Sprachpaket unvollständig ist.
    Das ist kein Hexenwerk, sondern wird so bereits in vielen Programmen gehandhabt. Beispiele: Foxit Reader, Spybot Search & Destroy.


    Beste Grüße
    DAC324

  • Die l10n-Builds fallen nicht zur Laufzeit auf die englischen Strings zurück, das passiert während des Build-Prozesses. Es wäre, so wie die Übersetzungen derzeit eingebunden werden, auch alles andere als trivial das zur Laufzeit zu machen.


    Bzgl. Mercurial: Du müsstest nicht jeden Tag den gesamten Source herunterladen, sondern nur geänderte Dateien. Ob sich der Aufwand, Mercurial und (v.a. unter Windows) das Build-System zu erlernen, lohnt, ist aber natürlich trotzdem die Frage.

  • Hallo,


    sicherlich ist Euch schon aufgefallen, dass es ein paar Wochen recht ruhig hier war. Nun scheinen aber die für die Strings zuständigen Entwickler wieder aus dem Urlaub zurückgekehrt zu sein (vielen Dank an .Ulli für den Hinweis). Könnte also durchaus passieren, dass die Version 0.2.18 des Sprachpaketes morgen bereits nicht mehr funktioniert.


    Bis dahin gibt es wieder das Update an gewohnter Stelle.


    Beste Grüße
    DAC324

  • vllt. eine blöde Frage aber, auf http://www.cczwei.de ist unter dem Blog ein Link zu den Kommentaren
    mit dem 3.5.1 bekomme ich die Kommentare angezeigt,
    mit dem 3.6 seit einiger Zeit (5-10 Tage) nicht mehr


    da ich die Erweiterungen und Logindaten immer nur in ein neues Profil Kopiere, denke ich, das die Versionen vom Grundaufbau gleich seien müssten
    nur warum bekomme ich dann die Fehlermeldung (nur beim 3.6er) von der Seite?


    Zitat von CC2

    Die Seite wurde gelöscht ODER der Zugriff auf diese Seite wurde verweigert.

  • Zitat von Maria-Christine

    vllt. eine blöde Frage aber, auf http://www.cczwei.de ist unter dem Blog ein Link zu den Kommentaren
    mit dem 3.5.1 bekomme ich die Kommentare angezeigt,
    mit dem 3.6 seit einiger Zeit (5-10 Tage) nicht mehr


    da ich die Erweiterungen und Logindaten immer nur in ein neues Profil Kopiere, denke ich, das die Versionen vom Grundaufbau gleich seien müssten
    nur warum bekomme ich dann die Fehlermeldung (nur beim 3.6er) von der Seite?


    Da scheint dann wohl doch etwas bei Dir schiefgegangen zu sein. Ich habe gerade mal getestet - die Kommentare lassen sich hier problemlos aufrufen und werden in einer Art Forenansicht dargestellt.


    Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2a1pre) Gecko/20090722 ID:20090722042136


    Beste Grüße
    DAC324


  • Hallo DAC324,
    seit dem Update vom 22.07.09 werden bei mir alle Bezeichnungen in "Englisch" angezeigt, obwohl in general.useragent.locale "de" eingetragen ist.
    Kann es sein, dass mit dem Sprachpaket von dir etwas nicht stimmt? Mit dem Sprachpaket lies sich nicht richtig das Fenster "Eigene Konfiguration" aufrufen. Das Fenster blieb leer.


    Nachdem ich das Sprachpaket deaktiviert hatte, wurde alles wieder angezeigt.


    edit: Kommando zurück! Habe das neueste Sprachpaket deinstalliert und wieder neu installiert. Siehe da, alles wieder OK. Bezeichnungen in deutscher Sprache, Fenster "Eigene Konfiguration" ist beschriftet.


    Gruß,
    D. Büssen

    Gruß,
    D. Büssen

    Firefox 107.0. + Nightly 109 (WIN 10 - 64 bit)

  • Zitat von DAC324

    Da scheint dann wohl doch etwas bei Dir schiefgegangen zu sein. Ich habe gerade mal getestet - die Kommentare lassen sich hier problemlos aufrufen und werden in einer Art Forenansicht dargestellt.


    stimmt, es war ein 'verstrubbeltes' cookie

  • Bei mir passiert etwas komisches....es heisst zwar Minefield aber sowas habe ich noch nie gehabt.
    Ab und zu bleibt Minefield geöffnet, obwohl ich den geschlossen habe. Merkwürdigerweise ist das Programm zumindest nicht sichtbar, aber in meinem Taskmanager zeigt es an, dass der Prozess noch am laufen ist. Ich muss es manuell beenden und dann geht es wieder.
    Vielleicht bin ich der einzige der dieses Problem hat, aber vielleicht kann mir einer sagen, wie ich es bereinigen kann.

  • Zitat von DAC324

    Hallo,


    Könnte also durchaus passieren, dass die Version 0.2.18 des Sprachpaketes morgen bereits nicht mehr funktioniert.
    Bis dahin gibt es wieder das Update an gewohnter Stelle.


    Beste Grüße
    DAC324


    Hallo, bin gerade bei heutigem Update (02.08.2009) mit folgender Fehlermeldung nieder gekommen:


    [Blockierte Grafik: http://s3.directupload.net/images/090802/temp/4o2j83pr.jpg]


    Auch die Inst des Sprachpaketes 0.2.19 haben keine Besserung gebracht. Nach Deaktivierung des Sprachpaketes hatte ich wieder ein normales Erscheinungsbild.


    Habe im Safe-Mode alle Erweiterungen deaktiviert, danach schrittweise wieder aktiviert. Bis zur Aktivierung des Sprachpaketes war alles i.O., danach siehe oben!


    Installierte Erweiterungen: Adblock plus 1.0.2, MR Tech 6.0.34, Nightly Tester Tools 2.0.2, Silvermel XT 0.2.0pre_trunk_r2432, TMP 0.3.7.4 pre 090726, (Sprachpaket de-DE 0.2.19)


    Gruß,
    D. Büssen

    Gruß,
    D. Büssen

    Firefox 107.0. + Nightly 109 (WIN 10 - 64 bit)

  • Hallo Büssen es liegt am Sprachpaket.


    Nimm das originale Sprachpaket von hier:
    http://ftp.mozilla.org/pub/moz…est-mozilla-central-l10n/


    Achtung direkte Installation!
    http://ftp.mozilla.org/pub/moz…-3.6a1pre.de.langpack.xpi


    diese sind immer Tages Aktuell. Das nicht funktionierende bitte zuerst löschen, dann erst das neue installieren.
    Dieses Sprachpaket muss man leider immer von Hand aktualisieren.


    Endor

    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:108.0) Gecko/20100101 Firefox/108.0
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/109.0

    OS: Windows 7 64 bit - Irgendwann Windows 10 64 bit wenn Firma will.
    Kein Support per PN. Fragen bitte im Forum stellen!

  • Zitat von Büssen


    [Blockierte Grafik: http://s3.directupload.net/images/090802/temp/4o2j83pr.jpg]
    Auch die Inst des Sprachpaketes 0.2.19 haben keine Besserung gebracht.


    Es gibt mittlerweile Version 0.2.20 meines Sprachpaketes :D


    Wie gesagt, jetzt steht wieder die Datei browser.dtd im Mittelpunkt des Interesses, deshalb kann nicht vorher gesagt werden, wie lange die Version 0.2.20 des Sprachpaketes funktionieren wird.


    Aber wenn das unter
    http://ftp.mozilla.org/pub/moz…-3.6a1pre.de.langpack.xpi
    tatsächlich immer tagesaktuell ist, kann ich meine Arbeit hier beenden.


    Vielen Dank also an alle, die durch ihre Rückmeldungen bei der Entwicklung meines Sprachpaketes geholfen haben. Vielleicht sind ja einige der Änderungen auch in das offizielle Sprachpaket unter
    http://ftp.mozilla.org/pub/moz…-3.6a1pre.de.langpack.xpi eingeflossen.


    Aber auch wenn nicht - war trotzdem eine interessante und lehrreiche Zeit. Nochmals vielen Dank an alle und viel Freude jetzt mit dem offiziellen Sprachpaket!


    Beste Grüße
    DAC324

  • Zitat von DAC324


    Aber wenn das unter
    http://ftp.mozilla.org/pub/moz…-3.6a1pre.de.langpack.xpi
    tatsächlich immer tagesaktuell ist, kann ich meine Arbeit hier beenden.


    Errrm, täglich generierte langpack.xpi gibt es aber schon seit einigen Monaten, ist dir das etwa erst jetzt aufgefallen?
    Btw, via http://hg.mozilla.org/l10n-central/de/pushloghtml sieht man die aktuellen Checkins in den "de-DE l10n Zweig".
    Ich dachte immer,dass du den Kram hier nur deshalb machst, weil du "andere Übersetzungen" nutzt?!

  • Zitat von XtC4UaLL

    Errrm, täglich generierte langpack.xpi gibt es aber schon seit einigen Monaten, ist dir das etwa erst jetzt aufgefallen?


    Täglich generiert ja, aber sie waren (zumindest wenn ich die Aussagen hier aus dem Forum und von anderer Stelle richtig interpretiert habe) nicht tagesaktuell, enthielten also mitunter nicht die jeweils letzten Änderungen.
    Das scheint mittlerweile aber kein Problem mehr zu sein, weshalb das hier diskutierte Sprachpaket wie gesagt überflüssig geworden ist.


    Beste Grüße
    DAC324

  • Zitat von DAC324

    Das scheint mittlerweile aber kein Problem mehr zu sein, weshalb das hier diskutierte Sprachpaket wie gesagt überflüssig geworden ist.


    Beste Grüße
    DAC324


    Überflüssig war es nie,
    die Tagesaktuellen Sprachpakete aus I10n funktionieren allerdings (bis jetzt) ganz gut


    PS: Danke für deine bisherige Arbeit DAC324 :klasse: