Firefox lädt m3u8 Dateien nicht mehr herunter

  • Firefox-Version
    125.0.1
    Betriebssystem
    Win 10 Pro

    Hallo, ich habe ein kleines Problem:

    Seit dem gestrigen ( 17.04.24) update auf 125.0.1 lädt Firfox keine m3u8 Daten mehr herunter, sondern es kommt immer eine Warnung, "Datei nicht heruntergeladen: Mögliches Sicherheitsrisiko. Ich muss die Datei dann immer erst selbst freigeben, in dem ich die Datei öffne. Das war vorher nicht der Fall.

    Um welche m3u8 handelt es sich? Ich habe einen Receiver mit WebIf, von welchem ich im Büro 4 Zimmer neben dem Wohnzimmer das TV-Programm via VLC Player streamen kann. Ich klicke im WebIf auf Streamen und der VLC Player öffnet den Sender. Seit dem neuen Update leider nicht mehr.

    Was habe ich selbst gemacht? Nun ich habe in den About:Config die Datei --browser.download.start_downloads_in_tmp_dir-- auf True gesetzt. In den Einstellungen--Anwendungen--Dateityp--m3u8 Files und m3u8 other Files (VLC) --Aktion auf --Mit VLC media player öffnen (Standart)-- gestellt, war ja vorher schon so.

    Da ich zwei Monitore am laufen habe, habe ich mir zu Testzwecken Opera installiert, dort funktioniert es. Andere Browser nutze ich nicht, Opera habe ich auch wieder gelöscht.

    An den Firewalleinstellungen habe ich auch nichts geändert, weil ich nicht weiß wie.

    Bitte um einen Rat.

    Gruß: Nick

    Einmal editiert, zuletzt von Nick Brandt (18. April 2024 um 14:46)

  • Ich muss die Datei dann immer erst selbst freigeben, in dem ich die Datei öffne. Das war vorher nicht der Fall.

    Hallo :)

    ergänzend zu Sören Hentzschel

    Firefox blockiert jetzt standardmäßig alle Downloads, die über http:// anstelle von https:// erfolgen. Bisher war dies nur bei http://-Downloads auf https://-Websites der Fall.

    Bitte um einen Rat.

    Stelle endlich von http auf https um.

    Gruß Ingo

  • Mal sehen wo ich Anfange:

    bitte nenne einen öffentlich erreichbaren Link, wo das Problem nachvollzogen werden kann.

    Einen öffentlichen Link gibt es nicht, es ist von meinem Receiver im Wohnzimmer zu meinem PC im Büro. Hängt am selben Router.

    Ich habe im Browser vom WebIf nur die Zahlenreihe (IP-Adresse) vom Receiver. Da gibt es kein http oder https.

    Stelle endlich von http auf https um. --Super Ingo. Ich wünsche dir auch einen schönen Tag....

    Da vom WebIf der Stream an den PC erfolgt, gibt es keine http oder https Adresse. Und sorry das ich nicht weiß wie und warum man das macht.

    Eben fällt mir auf, vor der IP-Adresse im Browser ist so ein Männchen durchgestrichen. Verbindung ist nicht sicher. Jetzt muss ich nur noch finden wie ich das ändere. War vorher auch nicht. Was soll da auch unsicher sein.

    Ja, Ingo, ich versuche auf https umzustellen. Endlich....

  • Ich habe im Browser vom WebIf nur die Zahlenreihe (IP-Adresse) vom Receiver. Da gibt es kein http oder https.

    Natürlich gibt es das. Jede Adresse wird über ein Protokoll aufgerufen. Kopiere doch mal die vollständige Adresse aus der Adressleiste. Dann steht davor entweder https:// oder http://. Was der Browser standardmäßig vervollständigt, wenn du es nicht explizit eingibst, ist eine Konfigurationsfrage. Aber der Aufruf erfolgt in jedem Fall entweder verschlüsselt oder unverschlüsselt über das HTTP-Protokoll.

    Eben fällt mir auf, vor der IP-Adresse im Browser ist so ein Männchen durchgestrichen.

    Fehlen diesem „Männchen“ Augen, Nase, Ohre, Arme und Beine? Dann ist es vermutlich ein Schloss - als Symbol für Sicherheit. ;)

    Was soll da auch unsicher sein.

    Eine unverschlüsselte Übertragung, das heißt http:// anstelle von https://, ist unsicher.

  • Ja, das ist ein Schloß, sieht für mich so aus, wenn es durchgestrichen ist. Egal.

    Ich habe jetzt mit klicken auf die Adresse keine änderung gefunden. Wenn ich jetzt darauf klicke finde ich unter Sicherheit nur die IP-Adresse. Unter Allgemein finde ich http: 1234.567.89.0, ändern geht hier nichts, klar.

    Also im WebIf gesucht und dort unter den Einstellungen bei https erlauben = ja angeklickt und gespeichert (hier muss man das GUI neustarten). Keine Änderung. Dann habe ich den Port von https an den von http angepasst und anders herum, auch nichts.

    Also habe ich mir gedacht, das WebIf sendet nur in http, das kann ich gar nicht ändern (danke Ingo). Also habe ich das Image des Receivers neu geflasht, somit ist auch das WebIf erneuert, neue Einstellung auf https erlauben gesetzt, auch nichts.

    Ich habe in den FF Einstellungen unter Datenschutz und Sicherheit, Berechtigungen, Automatische Wiedergabe, Einstellungen, Standart für Websites, Audio und Video erlauben gestellt (war schon).

    Kein Plan mehr. Eine Anfrage beim Imagebauer ergab nur, ich soll https erlauben, dann gehts...

    Nun denn, ich werde weitersuchen und versuchen.

  • Sören Hentzschel 18. April 2024 um 14:44

    Hat den Titel des Themas von „Firefox läd m3u8 Dateien nicht mehr runter“ zu „Firefox lädt m3u8 Dateien nicht mehr herunter“ geändert.
  • Wenn es HTTP sein sollte, findest du mit Klick auf das Schloss auch eine Lösung. Und nächstes Mal bitte korrekt zitieren.

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • Wenn ich eine Lösung finden würde, müsste ich wohl nicht Fragen. Wenn ich auf das Schloss klicke und auf Weitere Informationen kann ich alles Mögliche sehen, nur nicht ändern. Aber wenn es ein Geheimnis ist, psssssst, nicht weiter sagen.

    Und wo hatte ich falsch Zitiert? Kann nur was ändern wenn ich den Fehler erkenne.

    Wenn du zu uns in die Werkstatt kommst und sagst, dein Auto läuft nicht mehr, sage ich auch nicht, tja es ist kaputt.

  • Firefox blockiert jetzt standardmäßig alle Downloads, die über http:// anstelle von https:// erfolgen. Bisher war dies nur bei http://-Downloads auf https://-Websites der Fall.

    Die Änderung wird mit Firefox 125.0.2 vorerst zurückgezogen. Ich vermute mal, dass das hier geschilderte Problem dann auch nicht mehr bestehen wird. Das verschiebt die ganze Thematik natürlich nur, denn die Änderung wird erfolgen.

  • Das hat der Kollege wohl vergessen mir mitzuteilen.

    Nur um das für dich festzuhalten - ich bin hier in überhaupt keiner Bringschuld. Und wäre es dir endlich möglich, mal freundlicher zu sein? Du möchtest was von uns, nicht umgekehrt. Wenn dir das Zitieren fremd ist, wird hier niemand deshalb an den Pranger gestellt. Nur weiter unfreundlich sein - das animiert nicht wirklich.

    Das Ticket dazu:

    1892069 - dom.block_download_insecure causes a different file to download from a website
    NEW (nobody) in Core - DOM: Core & HTML. Last updated 2024-04-18.
    bugzilla.mozilla.org

    Hat das was mit Folgendem zu tun?

    dom.block_download_insecure steht hier auf false. Ist ein Überbleibsel aus der Zeit, wo Microsoft aus dem Catalog nur per HTTP angeboten hatte.

    Wir sind keine Beschwerdestelle, hier gibt es nur Lösungen!

  • Hat das was mit Folgendem zu tun?

    dom.block_download_insecure steht hier auf false.

    Ja, aber nicht in dem Sinne, dass dieser Schalter den Verhaltensunterschied von Firefox 124 auf Firefox 125 verantwortet. Mit diesem Schalter auf true (Standard-Verhalten seit Firefox 93) werden http://-Downloads auf https://-Websites blockiert. Seit Firefox 125 werden damit auch http://-Downloads auf http://-Websites blockiert. Dafür gibt es keine gesonderte Option.