Firefox findet neue Internet-Verbindung nicht

  • Hier unterwegs mit FF 60.8.0esr (64-Bit) auf opensuse Linux 15.1 (aber auch schon mit früheren Versionen) habe ich das Problem dass FF eine neue Internetverbindung einfach nicht finden will!


    Sehr oft läuft mein Notebook tagelang, mit vielen virtuellen Screens, vielen offenen Programmen und oft auch mit mehreren FF mit jeweils vielen Tabs: hier die Mail, dort eine Anleitung, da noch Nachrichten oder sonst was. Dann klappe ich den Notebook zu (ab in den Schlafmodus...) und öffne ihn in einem anderen Netz wieder. Das ist für das System kein Problem: es verbindet sich automatisch - und alles ist gut. Ping von der Kommandozeile ist kein Problem, sonstige Anwendungen mit Internetverbindung auch nicht.


    AUSSER Firefox! Der meint dann jeweils weiterhin, er habe keine Netzwerk-Verbindung! Irgendwie "klammert" sich der FF an eine einmal gefundene Verbindung und kümmert sich absolut nicht darum wenn eine neue da ist. Und leider weiss ich auch keinen Weg wie man dem FF das "erzählen" kann...


    Die einzige Art, wie ich mich dann bisher retten kann - mitsamt einer Sitzung mit vielen Tabs usw.! - ist dann:


    - FF nicht schliessen, sondern "abwürgen"

    - FF wieder öffnen - und wenn er sich dann für den "Absturz entschuldigt", die Rekonstruktion der vorigen Sitzung wählen


    Das klappt dann problemlos, weil FF jetzt endlich auch die Verbindung erkennt!


    FRAGE: Kennt da jemand eine ETWAS elegantere Lösung? Ich wäre dankbar für hilfreiche Tipps!

  • Ich nutze auch Linux (Mint) und wechsle häufig das Netz solange FF offen ist (bei Gewitter zeitweise von Kabel auf WiFi, bei schlechten Empfang zum mobilen Hotspot oder aktiviere einen Hotspot auf dem Lappi selbst, wenn ich LAN habe). Aber immer nutzt FF automatisch die aktive Internetverbindung. Mit suse kenn ich mich leider nicht aus, aber ich denke nicht, dass das Problem bei Firefox liegt, sonst hätten wohl viele dieses Problem, da ist wohl eher was an deiner Linux-Installation faul. Brauchst ja nur mal testen, ob der Fehler auch bei einer Live-CD auftritt. Wahrscheinlich wird man dir dann in einem Forum für suse Linux eher helfen können als hier.


    Bis du eine Lösung hast, vielleicht vor einem Ortswechsel den Lappi doch normal runterfahren oder zumindest den Firefox beenden. Alle offenen Tabs können dabei per Voreinstellung automatisch gespeichert werden, dann musst du auch nix abwürgen (Vorherige Sitzung wiederherstellen). Du könntest auch versuchen, das Netzwerk im Netzwerkmanager kurzzeitig komplett zu deaktivieren oder es mal mit einem portablen Fuchs versuchen.

  • Ich sagte ja schon: Andere Programme, die eine Internetverbindung benötigen, bekommen den Netzwerkwechsel jeweils sofort mit! Nur nicht der Firefox. Was eben gerade der Grund dafür ist dass ich es hier mal gepostet habe und nicht beiden open-suselern. Denn wenn ich eben dies dort erzähle wird man mir doch logischerweise genau dies raten: Poste das mal in einem FF-Forum!


    Ich nehme aber trotzdem zur Kenntnis dass offenbar andere Leute auf anderen Systemen andere Erfahrungen gemacht haben.


    Nur finden bei mir die Wechsel meist "im Schlaf" statt: zuklappen (Schlafmodus!), Ortswechsel, aufklappen ("aufwachen") - und das Netz ist nicht mehr das gleiche. Ich werde mal gezielt testen müssen ob das Problem auch bei einem "wachen Wechsel" auftritt, denn die Wechsel, die du beschreibst, waren wohl eben solche - dass man beim laufenden Compi das Netz wechselt.


    Vielleicht schickt das Betriebssystem ja irgendein "Signal", wenn das Netz ändert - und FF wertet das aus? Was dann eben z.B. im Schlaf nicht stattfindet!??

    In dem Fall wäre ggf. als Workaround auch möglich, vor dem Zuklappen zuerst das Netz auszuschalten (sodass der FF das auch mitbekommt!). Dann ist ja nach dem Aufwachen die Netzsituation ja unverändert: "kein Netz". Und dann wieder einschalten - "im Wachzustand".

  • Deshalb sagte ich ja, wenn der FF nicht will, vielleicht mal kurz das Netzwerk deaktivieren. Oder halt schon schon vor dem Schlaf.


    Ja den Schlafmodus nutze ich tatsächlich nie. Ich weiß jedoch, dass manche das Problem haben, dass nach dem Aufwachen der WLAN-Treiber nicht mehr funktioniert (kein WLAN-Gerät erkannt). Bei mir tritt das z.B. beim Reboot auf. Ich muss also seit irgendeinem Update immer ganz ausschalten, statt einfach nur neu zu starten. Aber da alles andere bei dir ja Internet bekommt, kann es das schon mal nicht sein. Schon mal in die Verbindungseinstellungen des Firefox geschaut? Vielleicht steht da irgendein Proxy drin, der nach dem Netzwechsel nicht mehr verfügbar ist. Ich würde einfach mal alles an potentiellen Fehlerquellen deaktivieren, also FF Plugins (im abgesicherten Modus starten), evtl. Antivirensoftware, Firewalls, Proxys etc. vielleicht läuft es dann plötzlich wie es soll. Und evtl. auch mal einen festen DNS-Server in den Netzwerkeinstellungen eintragen (z.B. 8.8.8.8), statt den den automatisch vom Router vorgegebenen.

  • Jetzt ist ein Übergang tatsächlich mal gelungen! Nach zweierlei Schritten:


    - In den Einstellungen umgeschalten von "kein Proxy" (was an sich an beiden Standorten stimmt) auf "Proxy-Einstellungen des Systems verwenden"


    - Vor dem Schlafmodus Netzwerk ausschalten, und erst nach dem Aufwachen wieder einschalten.


    Letzteres hatte ich auch schon mal probiert, hat aber alleine nicht ausgereicht.


    Ersteres ist vielleicht darum hilfreich weil es den FF dazu treibt, mit dem System wg. Proxy und Netzwerk zu kommunizieren - und nicht einfach gleich aufzugeben! Auch wenn das Ergebnis der Nachfrage in beiden Fällen, wie schon gesagt, auch nur "kein Proxy" ist.


    Kurz: VIELLEICHT habe ich hiermit die Lösung gefunden!? Ich traue dem Frieden aber erst nach ein paar weiteren erfolgreichen "Erweckungen"!

  • (bei Gewitter zeitweise von Kabel auf WiFi,

    Bin zufällig über deinen Beitrag gestolpert, musste nachdenken: Worin liegt hier der Sinn?

    Bei Gewitter haut dir ein Blitz in die Stromleitung, in die TAE-Dose, in den Router.

    Und dem ist es gleich, ob du LAN oder W-Lan nutzt. Dem Blitz übrigens auch.


    Der Avatar kommt aber gut ;)

  • - In den Einstellungen umgeschalten von "kein Proxy" (was an sich an beiden Standorten stimmt) auf "Proxy-Einstellungen des Systems verwenden"

    Ich glaube, das ist sogar die Standardeinstellung, die Firefox nach der Installation verwendet.

    Wäre schön, wenn das Problem damit gelöst ist.

  • Bin zufällig über deinen Beitrag gestolpert, musste nachdenken: Worin liegt hier der Sinn?

    Bei Gewitter haut dir ein Blitz in die Stromleitung, in die TAE-Dose, in den Router.

    Und dem ist es gleich, ob du LAN oder W-Lan nutzt. Dem Blitz übrigens auch.

    Das Stromkabel vom Lappi ziehe ich natürlich ebenfalls ab, so schlau bin ich schon. Es macht schon einen gewaltigen Unterschied, ob ich dann LAN oder WLAN nutze. Über WLAN kommt jedenfalls so schnell kein Blitz in meine Hardware ;)


    Die WLAN-Router im Netz laufen rund um die Uhr. Darauf habe ich jedoch keinen Einfluß, ich wohne in einer Art Studentenwohnhein.

  • Die WLAN-Router im Netz laufen rund um die Uhr. Darauf habe ich jedoch keinen Einfluß, ich wohne in einer Art Studentenwohnhein.

    Das macht dann natürlich Sinn.

    Ja, die schönen Studi-Buden :) Gute Zeiten, immer schnelles Internet und kostenfreies W-Lan. Bei uns jedenfalls, schon länger her ;)

  • Leider jetzt das Gegenbeispiel:


    - Proxy-Einstellung gelassen

    - Compi-Deckel NICHT geschlossen, sondern das Ding offen zum anderen Netz getragen


    Und der Effekt: FF ist mal wieder "tot", während alle anderen internet-affinen Programme fröhlich auf Empfang und Senden sind!


    Workaround: wieder mal FF "abwürgen", neu starten - und Sitzung restaurieren lassen!


    SCHLUSSFOLGERUNGEN:


    - mit den entsprechenden Proxy-Einstellungen schafft es der FF öfter als anders, sich in einem neuen Netz wieder zu finden


    - GRUNDSÄTZLICH krankt der FF aber daran, dass er sich mit Netzwechseln sehr schwer tut und gerne mal streikt!

  • Mein Linux wechselt manchmal automatisch zu anderen WLAN-Verbindungen, wenn ein Signal mal zu schwach ist (auf jeder Etage steht ein WLAN-Router), aber Firefox bleibt davon völlig unbeeindruckt, nach dem Connect steht die Verbindung sofort wieder zur Verfügung. Und das war bei mir auch noch nie anders. Es ist also definitiv kein grundsätzliches Problem von Firefox.


    Wurde vielleicht irgendwas an der Konfiguration verändert?

    https://support.mozilla.org/de…er-andere-Programme-schon


    Teste doch einfach mal den FF im abgesicherten Modus und auch mal mit einem neuen sauberen Profil. Alternativ kannst du dir zum Testen natürlich auch einen zweiten portablen FF frisch installieren.


    Und stelle doch bitte mal deinen FF so ein, dass er die letzte Sitzung beim Beenden automatisch speichert, abwürgen kann ja wohl nicht die Lösung sein.

  • Leider ist es scheinbar doch ein grundsätzliches Problem von Firefox - bei mir jedenfalls ganz sicher! Das kann niemand "lösen" durch einfach negieren: "Nein, du kannst das Problem garnicht haben"!


    Danke dennoch für den Versuch, hilfreich zu sein - auch wenn's in meinem Fall halt nicht geholfen hat!


    Und die meisten der schönen Ratschläge habe ich natürlich längst auch hin und her probiert. Wobei das auch sehr zeitaufwändig ist, weil man jede Testkonfiguration halt auch eine Weile erst beibehalten muss: Das Problem ist nicht ganz einfach gezielt reproduzierbar. Als Software-Entwickler sind das für mich die mühsamsten Fehler zum debuggen. Und so bin ich eben schliesslich - nach längerer Zeit! - zum Schluss gekommen dass der FF halt bei allen schönen Features doch auf diesem Punkt einen echten Mangel hat. Dass er irgendwie zu viel selber ins "Verbindungsmanagement" hinein funkt - und dabei Fehler macht.


    Schlussfolgerungen:


    - nochmal in anderen Foren nach Antworten suchen wo jemand vielleicht das Problem nicht nur negiert, sondern möglicherweise gar eine Lösungsidee hat


    - vielleicht halt doch zähneknirschend auf den zunehmend zum "Standard" werdenden Chrome-Browser setzen - was ich aber definitiv nicht gerne tue


    - oder halt auch in Zukunft mit gelegentlichem Abwürgen leben oder meinetwegen auch mit "Sitzung speichern": klar, ist "hübscher", kommt am Ende aber auch aufs Gleiche heraus

  • Niemand zweifelt daran, dass du auf deinem System Probleme mit Firefox hast. Dennoch würde die selbe Firefoxversion wahrscheinlich auf einem anderen Linux-System anstandslos laufen. Mit Live-CDs könnte man dies auch einfach austesten. Aber da du sicher deine Gründe hast, warum du dich gerade für suse entschieden hast und dich wahrscheinlich auch nicht umgewöhnen willst, ist dies jetzt auch nicht zielführend.


    Ich bin nur ein Anwender, kein Entwickler und mir gehen langsam die Ideen aus, woran der Fehler bei dir liegen könnte. Falls sich hier von den Profis keiner zu Wort meldet, kannst du nur mal in einem suse Forum um Hilfe ersuchen oder dich halt damit abfinden, den Browser nach einem Ortswechsel neu zu starten.

    Wenn dir das zuviel Arbeit ist, zwingt dich natürlich keiner den Firefox zu nutzen. Aber andere Browser sind nicht automatisch besser, jeder hat seine Vor- und Nachteile und die dauerhafte Verbindung erkaufst du dir so vielleicht mit irgendwelchen anderen Problemen. Aber das muss jeder selber wissen... Chrome nutze ich jedenfalls nur im Notfall (z.B. für Skype), braucht bei mir aber ewig zum starten und nervt mich dann auch noch wegen dem Passwort für den Schlüsselbund, obwohl ich nie Passwörter im Browser speichere. Und in Sachen Privatsphäre und Werbeblocker ist Chrome auch nicht gerade empfehlenswert.

  • Hallo cobo,


    wieso es ein "grundsätzliches Problem von Firefox" sein soll, wenn du ihm manuell die Netzwerkeinstellungen abwürgst, kann ich nicht so ganz verstehen. Die Hauptursache für das beschriebene Verhalten dürfte sein, dass du offenbar ständig an den Verbindungseinstellungen im Firefox herumdrehst. Wenn du dauerhaft die "Proxyeinstellungen des Systems" verwendest wie von dir in Beitrag #5 geschrieben, dürftest du keine Probleme auch bei wechselnden Netzen haben. Denn ohne dein Eingreifen würde der Browser von sich aus nie andere Netze als das probieren, welches vom Betriebssystem als das gerade Funktionierende für alle Anwendungen (sofern sie aufs Internet zugreifen) bereitgestellt wird.

    Natürlich können auch noch weitere Einstellungen außer der genannten reinspielen, irgendwelche AddOns vielleicht. Ich teile die Meinung von Uwe, dass, auch wenn deine konkrete Installation welche aufweist, nicht der Firefox an sich diese Art Probleme hat.


    Ob es zusätzlich noch Effekte durchs Schlafenlegen des Computers an sich gibt, ist selbstredend auch noch möglich. Meine Linux-Experimente habe ich noch nicht auf Mobilcomputer ausgeweitet, daher bin ich mit solchen Problemen nocht nicht konfrontiert worden.


    MfG

    Drachen

  • Jetzt hört doch auf, meine Feststellung über die Verbindungsprobleme von FF persönlich zu nehmen: Bei mir existieren sie und darum habe ich auf diesem Forum nach Lösungsansätzen gefragt! Und wenn sie bei mir existieren dann existieren sie eben, auch wenn jemand anders aufgrund seiner Benutzungsweise nicht darauf stösst. Leider hat halt hier niemand was dazu gewusst - Pech gehabt: Ist ja auch niemand dazu verpflichtet. Auch im englischen Forum habe ich inzwischen gefragt, weniger moralisierende Antworten erhalten, aber auch keine echte Lösung. Ich werde mit dem Problem halt offenbar leben müssen und mir mit Workarounds behelfen - nichts ist perfekt!


    Und wenn's jemanden freut: Ich ziehe auch mit Mängeln bisher den FF noch immer allen anderen Alternativen vor, auch wenn die genau dieses spezielle Problem mit den verlorenen Verbindungen nicht haben; sie haben dafür andere Macken und Nachteile.


    Ausserdem ist das doch auch eine ziemliche Verdrehung meiner Aussagen wenn jetzt behauptet wird ich täte "dauernd an den Verbindungseinstellungen herumdrehen": Ich habe halt verschiedene Einstellungen ausprobiert NACHDEM ich die Verbindungsprobleme hatte. Und als das auch nichts genützt hatte habe ich mal im Forum hier gepostet: Ist doch auch sinnvoller wenn man selber zuerst mal die naheliegenden Dinge durch probiert - oder etwa nicht?


    Dass ich den Firefox nach seinem "Festfrieren" manchmal lieber "abwürge" anstatt die Einstellungen so zu verändern dass er immer meine vorige Session wieder herstellt hat den einfachen Grund dass ich NORMALERWEISE meine alten Sessions halt nicht wieder herstellen möchte - zumal ich halt meist sehr viele Tabs offen habe! Klar, man kann dann einfach "alle Tabs schliessen" bevor man FF beendet. Nur hat das alles ja auch wieder nichts mit dem Verbindungsproblem zu tun und ist halt Geschmackssache.

  • Hallo cobo,


    sorry, wenn es "moralisierend" rüberkam, war nicht gewollt (nicht einmal bewusst) und bringt auch nix. Das mit den Netzwerkeinstellungen konnte ich aber nur aus deiner Schilderung ableiten und die gab nicht her, dass du "kein Proxy" nur mal ausprobiert hattest. Es fiel mir nur auf, denn dass manuelle Änderungen an der Stelle genau zu solchen Problemen wie bei dir führen, habe ich durch eigene Fehler an gleicher Stelle gelernt: bei mir war ein manuell geänderter und dann vergessener DNS-Server-Eintrag zum Testen von Pi-Hole, der Effekt bei einer späteren Änderung am Netz war derselbe wie bei dir: alles ging, nur Firefox nicht.


    So oder so viel Erfolg

    Drachen



    PS: ich bin nicht an Mozilla beteiligt und verdiene auch nichts am Firefox oder Beratungsleistungen oder Support für deren Produkte, nehme das alles also ohnehin nicht persönlich. Mit überzogenen und in der Sache falschen Feststellungen wie "grundsätzliches Problem von Firefox" provozierst du aber zweifellos Antworten, die dir dann persönlich vorkommen mögen. Eventuell behälst du das im Hinterkopf und lässt es in die Bewertung der Antworten auf solche Formulierungen mit einfließen ;-)

  • Auch im englischen Forum habe ich inzwischen gefragt

    Link? Bei mozillazine kennt dein Problem niemand und auch bei support.mozilla.org gibt es keinen Beitrag, der zu "opensuse" oder ähnlichem passt. Ich könnte daher nur ein OpenSuse-Forum vermuten.


    Scheint aber nicht auf Linux begrenzt zu sein, auch heir musste ich Firefox schon gelegentlich neu starten, wenn sich was an der Internet-Verbindung geändert hatte, wobei das ausschliesslich auf die Einstellungen unter Windows betraf oder auch mal ein Router-FW-Update.


    Unter Android kenne ich das gar nicht, wenn ich zwischen Mobile und WLAN wechsel.