FF69.0: ältere Profile verwenden bei Neuinstallation fast unmöglich

  • Hallo,

    ich musste mein Notebook ein paar mal neu aufsetzen und wollte nach der FF-Installation den Inhalt meines vorher verwendeten recht neuen Profils nach Löschen des Inhalt des neuen Profils in dieses einkopieren. Das klappt ja natürlich auch. Nur wollte sich danach FF nicht mehr öffnen lassen mit der Warnung, man solle kein altes Profil verwenden. Nach klicken auf "abbrechen" schloss sich Firefox. Das habe ich mehrfach versucht.

    Anschließend habe ich versucht, die profiles.ini so zu verändern, dass sich mein Arbeitsprofil zwingend öffnen müsste. Auch das schlug fehl. Allerdings sieht das Innenleben der profiles.ini neuerdings anders aus: es hat einige wenige Einträge mehr, von denen ich leider nicht weiß, was ich mit denen anfangen soll. Ich habe dann am Ende einfach eine ältere profiles. ini genommen und irgendwann ist es mir auch gelungen so mein altes Profil wieder zum Laufen zu bekommen.

    Warum ist es mit den neuen Versionen nicht mehr so einfach alte Profile zu übernehmen und könnte mir bitte jemand die neuen Funktionen der profiles.ini erklären?

    Oder habe ich einen Fehler gemacht?


    Gruß

  • Es gibt seit Firefox 67 dedizierte Profile, jeder Release-Kanal hat sein eigenes Profil, Endversion, Beta und Nightly. Du kannst ein Profil nicht mehr über Kreuz verwenden, das heißt, ein und dasselbe Profil mal für die Endversion, mal für die Beta und mal für die Nightly verwenden. Du kannst dann nur ein neues Profil anlegen.


    Siehe hier:


    https://www.soeren-hentzschel.…profile-pro-installation/

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Warum ist es mit den neuen Versionen nicht mehr so einfach alte Profile zu übernehmen


    Dieses ganze Vermischen von Profilen, teilweise mit Profilen neuerer Versionen in älteren Firefox-Versionen, verursacht Probleme, die bis hin zu Datenverlusten führen. Darum wurden die dedizierten Profile pro Installation und der Downgrade-Schutz in Firefox 67 eingeführt. Beides lässt sich über Umgebungsvariablen abschalten (was ich aber nicht empfehle). Siehe Ende des folgenden Artikels:


    Alles Wissenswerte zu Firefox ESR 68 inklusive Unterschiede zu Firefox 68

  • Du kannst dir aber behelfen, indem du die Datei compatibility.ini im Profilordner leerst. Allerdings ist die nur eine Notlösung.

  • Du kannst dir aber behelfen, indem du die Datei compatibility.ini im Profilordner leerst. Allerdings ist die nur eine Notlösung.

    Danke auch von mir für diese "Notlösung". Zum Testen in jedem Fall sehr nützlich:thumbup:

    Lieber ein Narr sein auf eigene Faust, als ein Weiser nach fremdem Gutdünken ! (Nietzsche)