Leeren Tab beim Start ausblenden in 70.0b3

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • In der 69.0 macht der unten eingefügte Code was er soll. In der 70.0b3 wird zwar auch der Tab ausgeblendet, aber wenn folgend ein Link aufgerufen wird, so wird zwar die Seite geladen, aber es erscheint der dazugehörige Tab nicht.


    CSS
    /*********************** leerer Tab wird beim Start ausgeblendet **********************************************/
    .tabbrowser-tab[first-visible-tab] {
    display: none !important;
    }

    Grüße vom FuchsFan

  • Der Code blendet nur aus. Sonst macht er nichts.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Der Code lädt keinen Tab neu. Für das Neuladen, wäre eher ein Skript zuständig. Hast du irgendein Skript dafür?

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Hallo Andreas!


    In der 69 ist es so, dass beim Start der leere Tab ausgeblendet ist. Es ist nur der NewTab-Button (kleine Kreuz) am linken Rand zu sehen.

    Wird jetzt ein Link gewählt, so erscheint die Seite in einem neu geöffneten Tab. Schließe ich den Tab über das Schließekreuz, so bleibt am linken Rand wieder nur das Kreuz des NewTab-Button. So soll es auch sein.

    Im 70 wird der Tab beim Start auch ausgeblendet, aber lade ich einen neuen Link, so erscheint dieser nicht, Seite ict aber geöffnet.

    Nehme ich z.B. den folgenden Code, so wird zwar wie gewünscht auch ein neuer Tab bei Auswahl eines Links geöffnet, aber wenn ich dann die Tabs alle einzeln schließe, so bleibt am Schluss ein leerer Tab geööfnet, was ich eigentlich nicht möchte.


    CSS
    /*********************** leerer Tab wird beim Start ausgeblendet **********************************************/
    .tabbrowser-tab:-moz-any([label="New Tab"], [label="Neuer Tab"])[first-visible-tab] {
    display: none !important;
    }

    Grüße vom FuchsFan

  • Ein leerer Tab ist m. E. nur möglich, wenn ich eine leere Seite als Startseite festgelegt habe oder wenn ich ein Startleisten-Skript verwende und die notwendige Skriptzeile nicht verwende, die verhindert, dass ein leerer Tab erscheint.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • In allen Versionen habe ich bisher als Startseite Firefox-Startseite (Standard) und bei neuer Tab die gleiche Auswahl. Lief bisher problemlos. Es kann nur mit dem 70er zusammenhängen, weil der Code so nicht mehr passt. Siehe mal Beitrag #7 , da wird ja auch der Tab geöffnet, aber es bleibt beim Beenden einer übrig.

    Grüße vom FuchsFan

  • FuchsFan Du meinst nicht zufällig die TabLEISTE, die mit nur einem Tab ausgeblendet werden soll?

    Gruß
    Manfred


    FF in aktueller Betaversion, auf MacBook Pro unter macOS Mojave 10.14.6

  • Ein Hallo in die Runde!


    Entschuldigt bitte, wenn ich damit nerve, aber kann mir niemand dabei helfen den Code aus Beitrag #7 so abzuändern, dass auch der letzte Tab beim Schließen im 70 ausgeblendet wird. Wie dort auch erwähnt, funktioniert das im 69.0 ohne Probleme.


    Grüße

    FuchsFan

    Grüße vom FuchsFan