Nach Update von V91 auf V103 gehen meine scripte nimmer - erledigt

  • Firefox-Version
    103.0.2
    Betriebssystem
    Windows 10 64 bit

    Hi,

    war ja schon länger nimmer hier, aber jetzt hab ich mal wieder Probleme. Ich hab im chrome Ordner mehrere scripte von denen keines mehr funktioniert

    RestartFirefoxButton_Movable.uc.js und

    RAMBack.uc.js


    die Datei config-prefs.js ist im pref Ordner vorhanden

    die Datei config.js ist direkt unter Firefox (wo auch die firefox.exe ist) vorhanden


    Jetzt die Frage was muss ich wo ändern, dass das wieder geht


    Vllt. kann mir da wer helfen

    Vielen Dank schon mal

    Frank


    config.js


    config-prefs.js

    Code
    pref("general.config.obscure_value", 0);
    pref("general.config.filename", "config.js");
    pref("general.config.sandbox_enabled", false);


    RAMBack.uc.js


    RestartFirefoxButton_Movable.uc.js

  • scorpie

    Hat den Titel des Themas von „Nach Update von V99 auf V103 gehen meine scripte nimmer“ zu „Nach Update von V91 auf V103 gehen meine scripte nimmer“ geändert.
  • Ist erledigt, woran genau es lag weiß ich nicht. Denk mal an der userChrome.js


    Vorher sah die so aus


    Code
    // userChrome.js
    userChrome.ignoreCache = true;
    userChrome.import("*", "UChrm");

    jetzt so


    Code
    // userChrome.js
    userChrome.ignoreCache = true;
    userChrome.import("/scrollbars.uc.js", "UChrm");
    userChrome.import("/Firefox_ToolBarButtons.uc.js", "UChrm");
    userChrome.import("/RAMBack.uc.js", "UChrm");
    userChrome.import("/RestartFirefoxButton_Movable.uc.js", "UChrm");


    Ging vorher mit dem Platzhalter auch ohne jede Datei einzeln einzutragen. Oder den gefühlten 100 Neustarts.

    Na egal, erledigt

    Einmal editiert, zuletzt von scorpie ()

  • scorpie

    Hat den Titel des Themas von „Nach Update von V91 auf V103 gehen meine scripte nimmer“ zu „Nach Update von V91 auf V103 gehen meine scripte nimmer - erledigt“ geändert.
  • Denk mal an der userChrome.js

    Hallo,

    wie heißt es in einem Song: ...einer von 80 Millionen... ;)

    Evtl. ist etwas anderes im Argen, sonst würde eine nicht mehr brauchbare userChrome.js hier Wellen schlagen.

    Gruß, oldman53

  • Ging vorher mit dem Platzhalter auch ohne jede Datei einzeln einzutragen. Oder den gefühlten 100 Neustarts.

    Na egal, erledigt

    Es geht immer noch so.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook


  • Also hast du die Änderungen denn selber eingetragen, oder hat sich die userChrome.js plötzlich von alleine geändert ?

    Es liest ja der Eine oder Andere mit, und könnte von gemachten Erfahrungen profitieren ...


    Davon abgesehen funktionieren meine paar Scripts mit einer userChrome.js, die nach wie vor so aussieht :


    JavaScript
    // userChrome.js
    userChrome.ignoreCache = true;
    userChrome.import("*", "UChrm");
  • userChrome.import("*", "UChrm");

    Diese Zeile sorgt dafür, dass alle Skripte eingelesen werden. Dadurch ist es unnötig, einzelne Skripte einzutragen.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice, LibreOffice Onlinehilfe, WordPress und Facebook

  • Jup dar Platzhalter sorgt für das Laden aller Scripte und vorher ging die ja auch.

    Die Änderungen hab ich selber eingetragen, glaube aber ehrlich gesagt ned, dass es daran lag. Mir fällt aber gerade ein, dass ich die für die Ausführung von js Scripten notwendigen Dateien überschrieben habe. Der Link war hier aus dem Forum. Hab mir die Dateien vorher aber angesehen und keinen Unterschied festgestellt.


    Hier aus aus dem ersten Beitrag

    Scripte