Tooltiptext anpassen in Erweiterung...

  • Hallo,


    folgende Erweiterung ist bei mir installiert (Fx70) : Reload All Tabs (ist nur ein Beispiel, gilt für alle Tooltips von Erweiterungen...)



    Irgendwie will es mir nicht gelingen den Text für den Tooltip zu ändern. Innerhalb der Entwicklungsumgebung funktioniert es durch einfaches überschreiben, aber ich weiß nicht wie ich das über CSS selektiert und geändert bekomme. Hat da jemand eine Idee und ist das so überhaupt möglich? :/

  • Was willst du denn eigentlich ändern? Bei einer deutschen Übersetzung ist es besser, an den Erweiterungsentwickler zu schreiben.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Das kannst du, aber du musst das sicherlich innerhalb des xpi machen und dann die Erweiterung unter einer anderen GUID neu signieren lassen (wenn das noch so ist :/). Ob man da per Skript in die Erweiterung eingreifen kann? Vielleicht.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • 2002Andreas : Es ging BrokenHeart darum, den vorhandenen Text zu ersetzen und nicht den vorhandenen Text zu gestalten. Wie Sören schon schrieb, kann man keinen Inhalt ändern.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Danke für die Hilfe!


    Ich habe es sogar temporär! hinbekommen, aber - Firefox nicht blöd - hat gemerkt, dass ich die signierte Erweiterung (.xpi) in der 'manifest.json' verändert habe und beim nächsten Start die manipulierte Erweiterung wieder runter geschmissen.


    Verstehe allerdings nicht, warum er es überhaupt einmal zugelassen hat?! :/.



    Edit: Ok, habe gerade gemerkt, dass der Toolbarbutton zwar noch da ist, aber keine Funktion mehr hat!


    Die Einstellung 'extensions.langpacks.signatures.required' und 'xpinstall.whitelist.required' in about:config hat in der 68ESR auch nichts gebracht.


    Wie man neu signieren kann, weiß ich nicht und das ganze ist mir irgendwie auch zu aufwendig...

  • Ohne Signatur kann man im Nightly und in Firefox Developer testen, indem man die Einstellung xpinstall.signatures.required in about:config auf false setzt. Für dauerhaft musst du die veränderte Version bei AMO signieren lassen.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Mist, ich hatte mich verschrieben, ich meinte 'xpinstall.signatures.required' und 'xpinstall.whitelist.required'. Die beiden Einträge hatte ich schon in der ESR auf false gesetzt. Wie oben geschrieben, hat das trotzdem nicht funktioniert. Oder gibt es noch ein Schalter, den man umlegen muss?

  • In der ESR und in der finalen normalen Version funktioniert das auch nicht. Es ist möglich, dass es die Einstellung dort noch gibt, sie ist aber in finalen Versionen unwirksam. Seit Jahren kannst du den Schalter nur noch in Firefox Developer und in Nightlies nutzen, genauer, seit Einführung der Signierung. Das war noch vor der Einführung der Webextensions.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress

  • Ok, danke für die Infos! I


    Ich hatte meine Informationen von hier. Da steht auch explizit ESR. Ob die Seite noch aktuell ist ( der Screenshot sieht schon ziemlich ältlich aus ;) ) , kann ich allerdings nicht sagen. Schade, dass bei den FireFox-Hilfe-Artikeln, nie ein Datum steht. Wie gesagt, ich werde jetzt nicht mehr in dieser Richtung weiter testen. ..

  • Ach, ich wusste gar nicht, dass das auch für ESR-Versionen gilt. Na ja, Unternehmen haben etwas andere Anforderungen. Nach den Screenshots kannst du nicht unbedingt gehen. Screenshots sind zusätzliche Arbeit zum Übersetzen von Artikeln. Die letzte Änderung am Artikel ist vom 3. Juli.

    Übersetzer für Obersorbisch und Niedersorbisch auf pontoon.mozilla.org u.a. für Firefox, Firefox für Android, Firefox für iOS, Firefox Klar/Focus für iOS und Android, Thunderbird, Pootle, Django, LibreOffice und WordPress