Schriftart sieht auf vielen Seiten bescheiden aus

  • Es gabe einen neuen Grafiktreiber. Habe ich installiert und den Rechner sicherheitshalber neu gestartet. Problem ist unverändert.


    Hier der Inhalt der about:support:



    Edit 2002Andreas
    Text in Klammercode gesetzt.

  • Hast du nach dem Deaktivieren der Hardwarebeschleunigung Firefox neu gestartet?


    Interessant wären noch deine Schrift-Rendering-Einstellungen von Windows. Da ich kein Windows nutze, muss jemand anderes sagen, wo du diese findest, und wenn du diese gepostet hast, ob da irgendwas auffällig dran ist. Auch wenn das Problem nur in Firefox auftritt, könnte es ja sein, dass dein Firefox in Kombination mit einer bestimmten System-Einstellung dieses Problem aufweist.

  • Weitere Ansätze:


    Suche in about:config nach "azure.backends", dort findest du zwei Schalter mit dem folgenden Inhalt:


    direct2d1.1,skia,cairo


    Ändere mal die Reihenfolge der Rendering-Backends, dass skia am Beginn steht, oder cairo. Danach jeweils Firefox neu starten und testen. Ändert das was?


    Ansonsten suche nach "gfx.font_rendering.cleartype_params.rendering_mode". Der Schalter steht standardmäßig auf "-1". Dort könnntest du mit Werten zwischen 1 und 5 (einschließlich) experimentieren.


    Was ich schrieb, hat viel mit versuchen zu tun, aber das ist kein Problem, welches häufig Thema hier ist, und ohne selbst betroffen zu sein, bleibt nicht viel mehr übrig als Ansätze zu liefern, was man ausprobieren könnte.


  • ...
    Die Angabe habe ich nicht gelöscht. Firefox läuft direkt auf einem nicht virualisierten Windows 10.
    ...


    Ich hatte ein ähnliches Problem wie du.
    Bei mir war es Sandboxie, eine Anwendungsvirtualisierung.
    Die Firefox-Sandbox innerhalb der "Sandboxie" funktionierte nicht richtig beim Rendern.


    Hast du vielleicht Sicherheitssoftware installiert, die Sandbox-Techniken benutzt?

  • Ja, ich habe nach dem Deaktivieren der Hardwarebeschleunigung Firefox neu gestartet.


    Die Reihenfolgeänderung an den azure.backends hat nichts gebracht.
    Bei "gfx.font_rendering.cleartype_params.rendering_mode" habe ich alle Werte von 1 bis 5 ausprobiert (auch jeweils mit Neustart). Leider auch kein Erfolg.


    Ich verwende kein Sandboxie und das von mir verwendete ESET nutzt lokal auch keine Sandbox-Techniken (soweit mir zumindest bekannt).

  • Soeben habe ich im englischen Firefox-Forum die Lösung gefunden:


    Klick auf das Windows-Symbol in der Taskleiste -> Suche "Erweiterte Systemeinstellungen anzeigen" -> Den Reiter "Erweitert" anklicken -> Im Block "Leistung" Klick auf "Einstellungen..." -> In der Liste die Option "Kanten der Bildschirmschriftarten verfeinern" anhaken


    Viele Grüße
    pelumu

  • Einen Nachteil hat die Einstellung aber: z.B. im Windows-Explorer habe ich nicht mehr die feinen Bildschirmschriftarten. Da ist alles nun so - zumindest für mich - unschön fett.

  • Die für mich im Moment zufriedenstellendste Lösung:
    Unter Einstellungen -> Allgemein -> Sprache und Erscheinungsbild -> Schriftarten und Farben -> Klick auf "Erwietert" -> Haken bei "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" entfernen.


    Mal sehen, wann ich mit dieser Einstellung auf andere Probleme stoße.