Win10 Firefox Portable als Standardbrowser

  • Ich möchte Firefox Portable bei Win10 als Standardbrowser definieren.
    Für die Endungen .url, .htm und .html hab ich das schon hingekriegt, trotzdem öffnet sich Edge bei manchen Gelegenheiten, was ich nicht nachvollziehen kann.
    Welche sonstigen Endungen müssen sonst noch mit FF portable verknüpft werden?


    Vielen Dank im voraus,


    Gruß
    Wolfgang

  • Tippe unter Windows unten links in das Suchfeld "Einstellungen für Standard-Apps" ein. Es öffnet sich ein Fenster, in dem du u.a. für Mail, Mediendateien, Browser und mehr die Software auswählen kannst, die automatisch genutzt werden soll. Wähle unten unter Webbrowser den installierten Firefox aus. Das sollte auch für den portablen funktionieren....

  • ...das funktioniert bei mir nur für installierte Programme und nicht für portable...
    D.h., in dieser Ansicht werden nur die installierten Programme angezeigt, es gibt keine Möglichkeit nach dem Installationsort zu suchen.

  • Wie bereits geschrieben konnte ich mit einem Extension Manager die Verknüpfungen von .url, .htm und .html auf den Firefox "umbiegen". Das funktioniert auch, aber bei manchen Gelegenheiten, die ich momentan nicht nachvollziehen kann, startet nicht der FF, sondern Edge...


  • ...das funktioniert bei mir nur für installierte Programme und nicht für portable...


    Du musst den portablen ja irgendwie am Computer am Laufen haben.. meinetwegen von einem Stick oder auch auf der Festplatte.. die Starterdatei dort wäre zu verknüpfen.. nicht die Firefox.exe des portablen im dortigen Programmordner..
    BTW: Warum willst du unbedingt einen portablen Firefox als Standardbrowser nutzen? :-??

  • Ich glaub ich muß das erklären.


    Ich hab ein Multiboot-System (2x WinXP, Win7, 2x Vista, Win8.1(32), Win8.1(64) und Win10).


    Damit ich nicht auf allen Systemen separate Installationen pflegen muß, hab ich mich entschieden den FF portable auf einem separaten Laufwerk zu positionieren, worauf ich von allen Systemen aus Zugriff habe. Das funktioniert bis jetzt ausgezeichnet, nur bei Win10 hab ich den genannten Effekt


    Zitat

    die Starterdatei dort wäre zu verknüpfen.. nicht die Firefox.exe des portablen im dortigen Programmordner


    Klar. Ich verknüpfe selbstverständlich mit FirefoxPorable.exe

  • ...ich muß meine Aussage aus dem 1. Thread etwas revidieren.
    es sind eben genau die Endungen ".url, .htm und .html", die unter Win10 nicht den FF öffnen, sondern Edge, obwohl ich für alle drei Endungen mit einem Ext.-Manager (Nirsoft FileTypes Manager) die Verknüpfung mit dem FF gemacht habe. D.h., die Verknüpfungen sind so in der Registry eingetragen, aber nicht dort wo ich vermutete.
    Trotzdem öffnet sich Edge beim Anklicken dieser Objekte...


    D.h., der Extension-Manager scheint nicht für Win10 geeignet zu sein.
    Schon seltsam...


    Also suche ich wieder eine Möglichkeit, diese Dateien mit dem portablen FF zu verknüpfen...

  • Seit Win10 scheint das Personalisieren der Installation sehr schwer geworden zu sein...
    Vielleicht kennt jemand einen Erweiterungs-Manager, der mit Win10 kann...
    Den Nir Sofer werde ich jedenfalls mal drauf aufmerksam machen.

  • Ich hab es jetzt soweit hingebracht, daß weder Edge noch IE geöffnet werden.


    Jedoch kann ich Internetverknüpfungen (.url) nicht mit dem portablen FF öffnen, es wird immer der im darunter liegenden Verzeichnis \FirefoxPortable\App\Firefox\firefox.exe gestartet...
    Und da fehlen meine ganzen Bookmarks u.a.


    Der Versuch, das mit .url verknüpfte Programm zu editieren scheitert, da der Zugriff gesperrt ist.


    Hat hier jemand noch eine Idee?
    Ansonsten werd ich mich mal an ein Windows-Forum wenden...

  • @ Mausebär,


    den portablen Firefox bitte auf Standardbrowser setzten ansonsten kannst du folgende Anleitung nicht machen.
    Du muss im Pfad C:\Users\BENUTZER\AppData\Roaming\Mozilla\Firefox
    die profiles.ini so anpassen:


    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=0
    Path=C:\Program Files Portable\Firefox\Profilordner
    Default=1


    Wobei C:\Program Files Portable\Firefox\Profilordner bei dir angepasst werden muss, dass ist meine Einstellung.

    Gruß Micha


    Ich beantworte keine technische Fragen per PN, ICQ, Email, sondern nur in diesem Forum!