Firefox läuft im Hintergrund weiter

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hallo zusammen,
    das Problem tritt bei mir auch seit Firefox 29 wieder auf.


    Windos 7 64bit.


    Was habe ich bisher getan:
    - Neues Profil
    - Keine Addons
    - Nur Flash Plugin (aktuellste Version)


    Was ich bisher feststellen kann:
    Hat man unter Einstellungen - Datenschutz - nach Benutzerdefinierten anlegen aktiv und dort dann noch zusätzlich
    - Die Chronik löschen, wenn Firefox beendet wird (alle Haken drin),


    dann wird Firefox nicht korrekt beendet.


    Hat man jedoch die Option: "anlegen" aktiviert und sonst nicht, beendet sich Firefox normal.


    Der Fehler tritt nicht auf einen "Kubuntu 14.04 LTS" mit den gleichen Einstellungen auf.


    Grüße Micha



    Info by Road-Runner: Bitte vor dem Posten lesen sagt unter Punkt 5:


    Zitat

    Eröffne Deinen eigenen Thread im Forum. Auch wenn das in einem anderen Thread geschilderte Problem auf den ersten Blick identisch mit Deinem Problem ist: es gibt immer die eine oder andere Abweichung (anderes Betriebssystem, andere Erweiterungen, andere Sicherheitssoftware usw.). Ausserdem werden Threads, in denen mehrere User das +- gleiche Problem schildern schnell unübersichtlich und es könnte sogar sein, dass Deine Frage schlicht und einfach übersehen wird.


    Deswegen habe ich Deine Frage von hier abgetrennt.

  • Also - die parent.lock wird schon länger nicht mehr beim Beenden von Firefox gelöscht, das wird anders geregelt mit dieser Datei.

    Zitat

    Die Chronik löschen, wenn Firefox beendet wird (alle Haken drin),


    Sollte zu dem Zeitpunkt Flash aktiv sein, dann ist es ein bestätigter Bug, dass Flash hängt und Firefox dann auch.


    Hast du Absturzmeldungen bei dir? https://support.mozilla.org/de/kb/Firefox-stuerzt-ab


    Ansonsten ist das so, dass Plugins fast immer durch Sicherheitssoftware gestört werden, manchmal ist auch ein verkorkstes Profil schuld, dann hilft nur, Firefox zurückzusetzen oder ein neues Profil zu erstellen.


    Bitte lesen und abarbeiten: http://www.camp-firefox.de/forum/viewtopic.php?f=1&t=66525


    1. Füge bitte den Inhalt von about:support hier als CODE ein
    1a. Liste alle Plugins auf (about:plugins)


    2. https://support.mozilla.org/de…heben-abgesicherter-modus
    2a. Deaktiviere alle Plugins


    Falls ohne Erfolg
    3. https://support.mozilla.org/de…n-probleme-einfach-loesen

  • Hallo Bernd,


    - Nein, keine Absturzmeldungen
    - Profil ist neu. Falls verkorkst, dann wurde es so angelegt.


    About support:


    About:plugins


    - Flash habe ich bereits deaktiviert, ohne Erfolg.
    - Firefox wurde bereits zurückgesetzt, mit Erfolg, bis oben genannte Funktion aktiviert wurde.


    Windows ist gerade 3 Tage alt, also frisch.


    Grüße Micha

  • RoadRunner - hier das erste Mal genannt http://www.camp-firefox.de/for…opic.php?p=911682#p911682
    --> https://bugzilla.mozilla.org/show_bug.cgi?id=980938


    Zur Fehlerkombo dürfte der Protected Mode von Flash beitragen, wenn ich das richtig gelesen habe, daher sehe den Fehler mehr in Flash als Firefox. Im Flash-Debugger tritt der Fehler angeblich auch nicht auf, kann eigentlich auch nicht, weil der keinen PM nutzt.


    Nachtrag:
    ATI Catalyst 14.4 ist aktuell, bitte installieren, erst dann weiter.
    IDM 6.19build 8 (sehe ich an der Erweiterung, dass bei dir veraltet)


    Schon ausgeführt?
    Hardwarebeschleunigung abschalten
    https://support.mozilla.org/de…beschleunigung-abschalten


    Und:
    3. https://support.mozilla.org/de…n-probleme-einfach-loesen

  • Hi,


    ich habe das selbe Problem unter Win 8.1 Upd 1. Meine Lösung: Firefox 24.5 ESR, damit funktioniert es und ich kann in 6 Wochen auf Firefox 30 umsteigen. Dann wird der Bug hoffentlich behoben sein.


    Gruß
    smarties

    Gruß
    smarties

  • Bei mir habe ich den Fehler gefunden. Das hatte NICHTS mit Addons zu tun oder dem Flash-Plugin, wie hier sofort gemutmaßt wurde. Nach dem Zürücksetzen funktionierte FF29 wieder normal. Ich habe dann - wie ich das immer mache - zuerst die Einstellungen verändert.


    Ab dem Moment, wo ich die Einstellungen für die Chronik verändert habe (ich lasse immer alles löschen, wenn FF schließt), beendete FF nicht mehr und lief im Hintergrund weiter.


    Jetzt habe ich das alte Profil wieder und nur die Chronik-Einstellungen so belassen,wie FF das für richtig hält und alles funktioniert einwandfrei. Fehler gefunden - Schuld liegt bei den Entwicklern!


    EDIT: Genau ist der Fehler beim Löschen der Chronik verortet. Und zwar der Punkt "Besuchte Seiten & Downloadchronik. Sobald der Haken in der Checkbox entfernt ist, ist alles Bestens. Alle anderen Punkte machen keinen Ärger. Er löscht im benutzerdefinierten Modus alles andere einwandfrei und beendet auch wieder.

  • Zitat von Jekyll&Hyde

    Das hatte NICHTS mit Addons zu tun...


    Zitat

    Nach dem Zürücksetzen funktionierte FF29 wieder normal.


    Den Widerspruch bemerkst du nicht?

    Firefox zurücksetzen – die meisten Probleme einfach lösen [Blockierte Grafik: http://i39.tinypic.com/s1kgb4.png]


    Dies wird Firefox auf die Standardeinstellungen zurücksetzen. Deine Lesezeichen und Passwörter gehen dabei nicht verloren. Die bisherigen Erweiterungen musst du allerdings neu installieren. Nach dem Zurücksetzen werden die alten Profildaten in einem Ordner namens „Alte Firefox Daten“ abgelegt. Wenn das Zurücksetzen das Problem nicht behebt, können einige der Daten, die nicht ins neue Profil übernommen wurden, von dort in das neue Profil kopiert werden. Wenn der Ordner nicht mehr benötigt wird, sollte man diesen löschen, da sensible Daten darin enthalten sind.


    Zitat

    Schuld liegt bei den Entwicklern!


    Dann mal los: Bug melden [Blockierte Grafik: http://i39.tinypic.com/s1kgb4.png]

  • @Jekyll - du wilderst wieder in fremden Themen, bleib doch bitte in deinem Thema, zumal du eine ganz andere Fehlerursache hast :roll:


    smarties, wenn du keine Lösung hast zu diesem Problem, dann bitte nicht, ESR wurde nicht erwünscht und hilft dem Kunden nicht ein Stück weiter. Solltest du dein eigenes Problem besprechen wollen, dann bitte öffnen ein neues Thema, danke. Und nein, Firefox trägt keine Schuld, sonst hätte alle dieses Problem und dem ist nicht so.

  • Also wenn Flash ausscheidet, dann müssen wir uns das System anschauen:


    OTL, Download http://www.trojaner-board.de/8…l-otlogfile-oldtimer.html
    Mit Admin-Rechten ausführen. Die 2 Logbücher (OTL.txt, EXTRAS.txt) bitte hier als ZIP anhängen.


    AdwCleaner
    http://www.bleepingcomputer.com/download/adwcleaner/
    Erst suchen, dann das Logbuch hier als CODE einfügen, dann erst löschen lassen!


    Malwarebytes' Anti-Malware (MBAM)
    http://www.malwarebytes.org/
    Mit Admin-Rechten ausführen, Updates laden, vollständigen Scan!
    Das Logbuch bitte hier als CODE einfügen

  • Zitat von Bernd.

    @Jekyll - du wilderst wieder in fremden Themen, bleib doch bitte in deinem Thema, zumal du eine ganz andere Fehlerursache hast :roll:


    Meinen habe ich schließen lassen, als mir klar wurde, dass ich hier keine Hilfe bekomme. Das Erste, was man doch macht, ist Googlen. Und da ist die Liste ellenlang mit Tipps, wie man das Problem angeblich behebt. Und hier lässt man mich erstmal Spießrutenlaufen.


    Ich habe den FF zurückgesetzt und weder Flash noch irgendein Addon installiert gehabt. Er hängt sich beim Löschen der Chronik auf, so wie ich es beschrieben habe. Nix Addon, nix Flash, nix mein Fehler. Ich wollte euch das nur nochmal unter die Nase reiben, weil ihr ja auch nicht mit Spott gespart habt oder meinen Ärger als Trolling bezeichnet habt.


    Ich weiß, dass der FF kostenlos ist. Dafür bin ich den Entwicklern wirklich dankbar. Aber sowas geht trotzdem nicht. Wenn man ein Produkt ausliefert, sollte man es vorher ausgiebig testen. Und wenn dann unmittelbar nach dem Release die User im Bugregen stehen, ist das nicht okay. Dann stimmt was mit dem BETA-Test nicht.

  • Zitat von Jekyll&Hyde

    Aber sowas geht trotzdem nicht. Wenn man ein Produkt ausliefert, sollte man es vorher ausgiebig testen. Und wenn dann unmittelbar nach dem Release die User im Bugregen stehen, ist das nicht okay. Dann stimmt was mit dem BETA-Test nicht.


    Und du meinst, das Produkt würde vor der Auslieferung nicht getestet werden? Dir ist schon klar, dass Firefox über 500 Millionen Nutzer hat und dieses Problem wohl nur für die wenigsten Nutzer existiert?


    Was den Beta-Test betrifft, mit dem etwas nicht stimmt, jeder Nutzer hat die Möglichkeit, Beta-Versionen zu testen und Probleme zu melden. Firefox wurde schon mit ein paar Fehlern weniger ausgeliefert, weil ich mir die Mühe gemacht habe, einen Bugreport zu erstellen. Genau so läuft das mit den Betatests nämlich. Reale Nutzer müssen die Betaversionen testen und Fehler melden. Es gibt unzählige verschiedene Konfigurationen und die meisten Fehler treten nur unter bestimmten Voraussetzungen auf. Offensichtliche Probleme sind die kleinsten Probleme, davon gibt es selten viele in einem ausgelieferten Produkt.

  • Jekyll&Hyde, könntest du versuchen unter about:config "network.seer.enabled" auf false zu stellen, firefox neu zu starten und dann deine datenschutz/chronik löschen-einstellungen wieder so zu setzen wie beim ausgangspunkt des problems & es damit eine weile unter beobachtung halten?


  • Genau das ist der Bug! Die Chronik-Einstellung "Besuchte Seiten & Downloadchronik". Habe das gleiche Problem nach dem Update auf 29.0. Vorher keine Probleme gehabt. Habe alle Add-ons deaktiviert und sogar FF neu installiert (löschen aller Profile, mit CCleaner Reg. gesäubert inkl.). Nichts half, bis ich selbige Idee hatte wie Jekyll&Hyde. Allerdings hatte ich nicht bis zur Verortung durchgecheckt. Selbiges Problem auch auf weiteren Rechnern, sowohl zuhause als auch im Büro.


    Hinweis:
    Anscheinend ein Problem mit Win7 x64 und FF 29.0 (Alle betroffenen Rechner haben diese Konfig). Auf Rechnern mit Win8 x32 und FF 29.0 taucht dieses Problem nicht auf.


    Tipp mit about:config "network.seer.enabled" auf false zu stellen brachte nicht den gewünschten Erfolg!


    Viele Grüße

  • hallo, um das problem angehen zu können, wäre es hilfreich das genau reproduzieren zu können - wenn du ein neues profil erstellt hast, welche anderen änderungen außer dem einstellen dass "Besuchte Seiten & Downloadchronik" nach jedem schließen gelöscht werden hast du vorgenommen bzw. welche webseiten besucht bevor das problem auftritt? danke


    (der versuch mit dem ausschalten von network.seer.enabled bedarf vermutlich eines neustartes bevor die änderung auch in kraft tritt)

  • Könnte ich so bejahen mit Win7-64. Zeichnet sich in anderen Foren auch so ab. Also trivila bzw. sporadisch auftretend scheint mir das nicht. Man hat in jedem von mir bestreiftem Forum paar Leute mit genau diesem Problem.


    Warum das aber am Inhalt des Caches leigen soll (welche Seiten wurden besucht), das wüßte ich jetzt nicht. Und irgendwie hab ich auch ein dejavu dabei. Ich meine exakt das Prob hatten wir schon einige Male in der Geschichte des Fx...

    Probieren geht über Studieren

  • Zitat von Sören Hentzschel

    Was den Beta-Test betrifft, mit dem etwas nicht stimmt, jeder Nutzer hat die Möglichkeit, Beta-Versionen zu testen und Probleme zu melden.


    Den Schuh ziehe ich mir nicht an. Ich mache das für Blender (3D-Software). Beim FF oder TB nicht, weil ich darauf wirklich angewiesen bin als Entwickler und Nutzer. Die müssen funktionieren, wenn ich sie benutze. Ich trage also auch dazu bei, dass wir alle kostenlose Software benutzen können. Ich biete überdies kostenlos einen Wappengenerator im Netz an und unterstütze Auslandshelfer mit einer kostenlosen HP. Und ich habe diverse Bugs für vB5 gemeldet. Ich kann nun wirklich nicht alles selbst tun.