Weblinks in TB werden im FF doppelt geöffnet

Du benötigst Hilfe bezüglich Firefox? Bitte stelle deine Frage im öffentlichen Bereich des Forums und nicht per Konversation an wahllos ausgesuchte Benutzer. Wähle dazu einen passenden Forenbereich, zum Beispiel „Probleme auf Websites“ oder „Erweiterungen und Themes“ und klicke dann rechts oben auf die Schaltfläche „Neues Thema“.
  • Hi,


    @ CompMan: Wovor hast du Angst? Manchmal muß mal "das Alte" wegschmeißen, um Platz für neues zu machen. :wink:


    Ich habe mir erst die Erweiterungen angeschaut ( Extras -> Add-ons -> Erweiterungen) und notiert.


    Nach dem "Reseten" habe ich diese über Add-Ons suchen wiedergefunden und installiert. ;)

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Werd's mal versuchen. Habe mir Screenshots von about:config und about:support gemacht.
    Werden eigentlich die gesetzten und nicht gesetzten Häkchen unter "Einstellungen" ebenfalls zurückgesetzt? Muss ich mir davon auch noch Screenshots machen?

  • Hi,


    woran es wirklich lag weiß ich auch nicht wirklich.


    Die Add-ons sind wieder die gleichen.


    Aber, ich muß auch dazu sagen, das vor 3 Monaten, die Festplatte " ins Jenseits " marschiert ist. Eine Spiegelung (1/1) mit "schieben oder ziehen" war nicht mehr möglich. Nur eine externe Datensicherung.


    Ich habe damals nur die Ordner für jedes Benutzerkonto (z.B. Profile für FX) "rüberkopiert", um die alten Einstellungen wieder zu bekommen. Daher kann da schon das Problem gewesen sein.


    Aber das wäre doch auch eine Option. Einfach den Ordner von Fx kopieren und umbenennen. (Als Sicherung ;) )


    PS: Der FX war damals das kleinste Problem. Da die Registrierung klien war, konnte sich das Betriebssystem an keine Lizenz erinnern :roll: -> Ich bin da jetzt schon in Übung mit der Wiederherstellung und Einstellung vom Anwendungen. :lol::lol::D

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Ich glaube, ich hab's hinbekommen. Bin wie folgt vorgegangen und hab gleich noch ein paar Fragen an Euch beide:


    1.) Noch in der 13er-Version die AddOns auf Aktualität geprüft, alles OK.
    2.) Die 14.0.1 installiert, automatische Prüfung der AddOn-Kompatibilitäten beim Erststart OK, Ausgangs-Fehler (natürlich) wieder da.
    3.) Nochmals manuell die AddOns auf Aktualität in der 14er geprüft, alles OK.
    4.) Profil resettet, Fehler weg, die AddOns und meine Einstellungen ebenfalls
    5.) Durch das Resetten wurde neues Profil neben dem alten angelegt. Das alte hieß in etwa "123abc.default", das neue hingegen "456xyz.default-123456789"
    6.) Die prefs.js aus dem alten ins neue Profil kopiert, Startseite und sonstige Einstellungen wieder da, nur halt die AddOns noch nicht.
    7.) Ordner "extensions" ebenfalls vom alten ins neue Profil kopiert.
    8.) FF starten, mehrere Tabs öffnen sich und fragen, ob jeweils die Erweiterung XYZ installiert werden soll.
    9.) Eine nach der anderen installieren lassen.
    10.) Beim AddOn "Cookie Culler" hieß es plötzlich "nicht kompatibel mit FF 14", obwohl vorher vor dem Profil-Reset einwandfrei in der 14er gelaufen und bei der Kompatibilitäts-Prüfung beim Erststart nicht beanstandet.
    11.) Jetzt weiß ich nicht mehr genau, wie's weiterging. Ich glaube, "Cookie Culler" deaktiviert, neu gestartet und wieder aktiviert (geht das überhaupt?).
    12.) Jetzt läuft's (bisher) ohne Fehler, auch mit "Cookie Culler"


    "Cookie Culler" ist auch auf den beiden anderen PCs, könnte der Grund gewesen sein. Wird noch getestet.


    Hast Du "Cookie Culler" auch, Thommy?


    Kann ich das alte Profil in ein paar Tagen löschen? Muss/kann ich dann anschließend das neue umbenennen, also die vielen Ziffern hinter *.default" entfernen?

  • Hi,


    Zitat von CompMan

    Hast Du "Cookie Culler" auch, Thommy?


    Nein, wofür soll das gut sein?

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Hallo,
    ich habe Cookie Culler 1.4 schon seit mehreren FF Versionen,
    und auch jetzt mit FF 14.0.1 läuft die Erweiterung mit Firefox einwandfrei.

    Windows 10 Home
    Firefox 98.0.1

  • Zitat von CompMan

    Kann ich das alte Profil in ein paar Tagen löschen?


    Ja, musst du aber nicht.

    Zitat von CompMan

    Muss/kann ich dann anschließend das neue umbenennen also die vielen Ziffern hinter *.default" entfernen?


    Nein,musst du nicht, nutz es einfach so wie es ist wenn alles damit funktioniert.

  • Es lag definitiv an "Cookie Culler", der sich so tief ins Profil eingräbt, dass selbst sein Entfernen das Ausgangsproblem nicht löst.
    "Cookie Culler" finde ich spezieller und individieller konfigurierbar als die FF-Bordmittel.
    Bei den beiden anderen PCs bin ich gleichermaßen wie beschrieben vorgangen. Als die Meldung kam, "Cookie Culler" sei nicht kompatibel mit FF 14, war nur noch "Entfernen" angeboten, kein "Aktivieren" oder "Deaktivieren". Wenn man dann auf "Updates prüfen" klickt, kommen diese beiden Buttons zurück. Wieder aktivieren, und schon läuft's fehlerfrei!!!


    Interessant: Als nach dem Resetten alle AddOns verschwunden waren, habe ich bei der AddOn-Suche in FF mal "Cookie" eingegeben. Gefunden wurde statt "Cookie Culler 1.4" nun "Cookie Controller 1.4", mglw. dasselbe. Ich bin dann aber bei "Cookie Culler" geblieben. Auch auf der Seite https://addons.mozilla.org/de/firefox/ wird nur noch der "Cookie Controller" angeboten. Gibt man hingegen "Culler" als Suchbegriff ein, wird er gefunden.


    Ein kleines Problem habe ich aber noch nach dem Resetten des Profils: Ich habe in der Lesezeichen-Symbolleiste zwei "Ordner" mit Lesezeichen, die jetzt nur noch mit dem normalen Ordnersymbol angezeigt werden. Vorher hatte ich diesen beiden kleine Bildchen/Icons zugewiesen. Wie bekomme ich die wieder zurück? Wo wurden die gespeichert? Unter "Eigenschaften" kann ich nur einen Namen eingeben.


    emi: Und das Ausgangsproblem hast Du damit nicht ??? Ich hatt's hier auf 3 Rechnern.

    Einmal editiert, zuletzt von CompMan ()

  • Hi,


    Zitat von Road-Runner

    Ich komme ganz ohne Cookie Culler aus und erreiche das gleiche Resultat mit Bordmitteln (siehehier).


    also, Cookies, Chronik und Cache leere ich manuell jede Woche. ;)


    Aber danke für den Hinweis :klasse:

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Hi,


    ich noch mal :roll:


    Zitat von CompMan

    Es lag definitiv an "Cookie Culler", der sich so tief ins Profil eingräbt, dass selbst sein Entfernen das Ausgangsproblem nicht löst.


    Sicher?
    Ich hatte nach dem Update auf FX 14.0.1 das gleiche Problem. Aber von Cookie Culler hatte ich vorher noch nie etwas gehört. :-??


    Es muß ja irgendetwas gewesen sein, was den FX doppelt geöffnet hat, mit den gleichen Anweisungen. :?:

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Bei mir kämen die nicht aus TB, werden aber mit Culler auch nur einmal geöffnet. Entweder ist TB dahingehend buggy oder was anderes stört bei dir.

  • CompMan
    Ich nutze TB - FF- und Cookie Culler seit langem, also xJahre.
    Hatte noch nie damit Probleme.


    Road-Runner
    Danke für den Tipp ..........das gleiche Resultat mit Bordmitteln
    Muss ich mir mal in Ruhe ansehen, bin nicht so versiert, aber Dank euch immer versierter :)

    Windows 10 Home
    Firefox 98.0.1

  • Mit Bordmitteln werden dann aber ALLE Cookies gelöscht, und mit Cookie Culler kann ich davon explizit bestimmte ausnehmen. Allerdings muss dann der Haken bei "Cookies löschen" im FF entfernt sein, sonst werden die trotz Lösch-Schutzes entfernt.


    Sicher? Nein, Thommy, aber auf allen drei PCs konnte ich wie beschrieben die Probleme über die angebl. Inkompatibilität von Cookie Culler lösen. Vielleicht war's auch eine andere Macke im Profil.
    "Es muß ja irgendetwas gewesen sein, was den FX doppelt geöffnet hat, mit den gleichen Anweisungen." Ja, Thommy, interessanterweise öffnete ein Klick auf einen Link auf zwei Systemen den FF in zwei Instanzen, auf einem PC in einer Instanz und zwei identischen TABs.


    Boersenfeger hatte geschrieben, dass die Einstellungen von about:config in der prefs.js gespeichert werden. Vorher/Nachher-Vergleich zeigte aber trotz ZUrückspielens dieser Datei ins neue Profil bei ganz wenigen Benutzer-Änderungen Unterschiede.

  • Also, ich weiß ja nicht, ob das jetzt blöd ist was ich hier beitrage :-??
    Habe eben versucht aus TB einen Link mit Doppelklick zu öffnen - FF öffnet 2x
    Mit einem einfachem Klick nur 1x
    Irgendwo kann man doch beim PC irgendetwas einstellen, was so ein Klick/Doppelklick bewirkt :?
    Wenn mein Beitrag dämlich ist, dann überseht ihn einfach bitte.

    Windows 10 Home
    Firefox 98.0.1

  • Hi,


    Zitat von emi

    Also, ich weiß ja nicht, ob das jetzt blöd ist was ich hier beitrage :-??
    Habe eben versucht aus TB einen Link mit Doppelklick zu öffnen - FF öffnet 2x
    Mit einem einfachem Klick nur 1x


    :lol::lol::lol::lol::lol::lol:


    Klar, wir habe nach dem Update schlagartig unser Gewohnheiten mitgeändert :?::D:D


    Greetinx

    Gruß Th 8) mmy


    Backup not found: (A)bort, (R)etry, (P)anic?

  • Hast Recht, Road-Runner, soweit runter hatte ich erst nicht gelesen. Werde mich damit mal beschäftigen, dann kann ich Cookie Culler vielleicht entfernen.


    Meine Frage zu den Symbolen bei Lesezeichen-Ordnern hat sich erledigt. Habe die userchrome.css aus dem alten Profil ins neue kopiert, alles wieder da.

  • Zusatz zur Info:
    Interessant - habe zu Kontrollzwecken mal das alte Profil "aktiviert", also den Namen des neuen in der profiles.ini sowie die beiden neuen Profilverzeichnisse entfernt.
    FF startet nun wieder mit dem alten Profil. Schließen von FF.
    Klick auf einen Link in einer Mail öffnet FF nur EINMAL ! Das alte Profil ist demnach ebenfalls OK.
    Weiß der Himmel ...